aboutsummaryrefslogtreecommitdiff
path: root/comms/sunxi-tools
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-29 16:03:39 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-29 16:03:39 +0000
commit828a5a0da0d1b18c6f0755a17ce46fb74bf3bac0 (patch)
tree07b03427ad885ae5a790e60220197dcb9f1a0e22 /comms/sunxi-tools
parent4a604cfef2066242fbd44ff17dcd9be37cfdd16f (diff)
downloadports-828a5a0da0d1b18c6f0755a17ce46fb74bf3bac0.tar.gz
ports-828a5a0da0d1b18c6f0755a17ce46fb74bf3bac0.zip
Fix build on GCC-based architectures:
unrecognized command line option "-Wno-unused-result" PR: 235540 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=497160
Diffstat (limited to 'comms/sunxi-tools')
-rw-r--r--comms/sunxi-tools/Makefile4
-rw-r--r--comms/sunxi-tools/files/patch-Makefile6
2 files changed, 4 insertions, 6 deletions
diff --git a/comms/sunxi-tools/Makefile b/comms/sunxi-tools/Makefile
index 4d601ed1b9f3..26ce0d21eef3 100644
--- a/comms/sunxi-tools/Makefile
+++ b/comms/sunxi-tools/Makefile
@@ -11,10 +11,6 @@ COMMENT= Tools to help hacking Allwinner devices
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-BROKEN_mips= fails to build: unrecognized command line option "-Wno-unused-result"
-BROKEN_mips64= fails to build: unrecognized command line option "-Wno-unused-result"
-BROKEN_powerpc64= fails to build: unrecognized command line option "-Wno-unused-result"
-
USES= gmake pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= linux-sunxi
diff --git a/comms/sunxi-tools/files/patch-Makefile b/comms/sunxi-tools/files/patch-Makefile
index 9e0ed40d773c..5598602454bd 100644
--- a/comms/sunxi-tools/files/patch-Makefile
+++ b/comms/sunxi-tools/files/patch-Makefile
@@ -1,14 +1,16 @@
--- Makefile.orig 2016-11-29 13:07:51 UTC
+++ Makefile
-@@ -17,7 +17,7 @@
+@@ -17,8 +17,8 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
CC ?= gcc
-DEFAULT_CFLAGS := -std=c99
+-DEFAULT_CFLAGS += -Wall -Wextra -Wno-unused-result
+DEFAULT_CFLAGS += -std=c99
- DEFAULT_CFLAGS += -Wall -Wextra -Wno-unused-result
++DEFAULT_CFLAGS += -Wall -Wextra
DEFAULT_CFLAGS += -D_POSIX_C_SOURCE=200112L
+ # Define _BSD_SOURCE, necessary to expose all endian conversions properly.
@@ -63,7 +63,7 @@ BINDIR ?= $(PREFIX)/bin
tools: $(TOOLS) $(FEXC_LINKS)
target-tools: $(TARGET_TOOLS)