aboutsummaryrefslogtreecommitdiff
path: root/comms/thebridge
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-02-27 14:30:03 +0000
committerDiane Bruce <db@FreeBSD.org>2020-02-27 14:30:03 +0000
commit4a0be7456cc07a5cceb29c65109aeeaec38a2d14 (patch)
tree113316df91a0003528a8945828805b093e8ae513 /comms/thebridge
parentb70ceb675faf40de34e794493c3412433de7169d (diff)
downloadports-4a0be7456cc07a5cceb29c65109aeeaec38a2d14.tar.gz
ports-4a0be7456cc07a5cceb29c65109aeeaec38a2d14.zip
Pet portlint regenerate patchfiles while here. [db]
The original one in ports doesn't include readline support . but they support readline according to the configure. So I think add a readline support option should be nice PR: ports/244468 Submitted by: papadavecn@gmail.com
Notes
Notes: svn path=/head/; revision=527258
Diffstat (limited to 'comms/thebridge')
-rw-r--r--comms/thebridge/Makefile8
-rw-r--r--comms/thebridge/files/patch-Makefile.in6
-rw-r--r--comms/thebridge/files/patch-configure.in6
-rw-r--r--comms/thebridge/files/patch-src_Makefile.in10
-rw-r--r--comms/thebridge/files/patch-src_conference.c4
-rw-r--r--comms/thebridge/files/patch-src_dirclient.c4
-rw-r--r--comms/thebridge/files/patch-tbdcmd_Makefile.in6
7 files changed, 24 insertions, 20 deletions
diff --git a/comms/thebridge/Makefile b/comms/thebridge/Makefile
index d4e63c1db3b1..998f2ee03918 100644
--- a/comms/thebridge/Makefile
+++ b/comms/thebridge/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thebridge
PORTVERSION= 1.09
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= SF/cqinet/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -25,7 +25,11 @@ SHEBANG_FILES= addons/usermgmt.cgi
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS READLINE
+OPTIONS_DEFAULT= READLINE
+
+READLINE_CONFIGURE_WITH= readline
+READLINE_USES= readline
post-patch:
@${REINPLACE_CMD} 's!tbdcmd=\/usr\/local!tbdcmd=${PREFIX}!'\
diff --git a/comms/thebridge/files/patch-Makefile.in b/comms/thebridge/files/patch-Makefile.in
index 2f8eb846a4f0..b8883f62f86c 100644
--- a/comms/thebridge/files/patch-Makefile.in
+++ b/comms/thebridge/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2012-12-10 01:05:20.000000000 -0500
-+++ Makefile.in 2013-01-03 20:39:17.000000000 -0500
-@@ -253,7 +253,7 @@
+--- Makefile.in.orig 2012-12-10 06:05:20 UTC
++++ Makefile.in
+@@ -253,7 +253,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
diff --git a/comms/thebridge/files/patch-configure.in b/comms/thebridge/files/patch-configure.in
index b3a017bec393..5877ee6be87f 100644
--- a/comms/thebridge/files/patch-configure.in
+++ b/comms/thebridge/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2013-01-03 19:17:41.000000000 -0500
-+++ configure.in 2013-01-03 19:18:21.000000000 -0500
-@@ -84,5 +84,5 @@
+--- configure.in.orig 2012-12-10 05:57:10 UTC
++++ configure.in
+@@ -84,5 +84,5 @@ AC_DEFINE_UNQUOTED(OUR_HOST,"${host}",
[Set to a text string describing your operating system and hardware])
AC_OUTPUT(Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile
diff --git a/comms/thebridge/files/patch-src_Makefile.in b/comms/thebridge/files/patch-src_Makefile.in
index 80ab2dba0a2a..bd5095ae7f07 100644
--- a/comms/thebridge/files/patch-src_Makefile.in
+++ b/comms/thebridge/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2012-12-10 15:00:44.000000000 +0900
-+++ src/Makefile.in 2013-10-24 13:57:30.000000000 +0900
-@@ -115,7 +115,7 @@
+--- src/Makefile.in.orig 2012-12-10 06:00:44 UTC
++++ src/Makefile.in
+@@ -115,7 +115,7 @@ am__tbd_SOURCES_DIST = conference.c conference.h confi
tbd_OBJECTS = $(am_tbd_OBJECTS)
am__DEPENDENCIES_1 =
@LINK_BOX_FALSE@tbd_DEPENDENCIES = $(top_builddir)/common/libcommon.a \
@@ -9,7 +9,7 @@
@LINK_BOX_FALSE@ $(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
-@@ -233,12 +233,12 @@
+@@ -233,12 +233,12 @@ top_srcdir = @top_srcdir@
@LINK_BOX_TRUE@ dirclient.c dirclient.h thebridge.c users.c users.h \
@LINK_BOX_TRUE@ hostfile.c hostfile.h eventhook.c eventhook.h avrs.c avrs.h
@@ -24,7 +24,7 @@
@LINK_BOX_TRUE@ -DSYSCON_DIR=\"$(sysconfdir)\" $(am__append_1)
@LINK_BOX_FALSE@AM_CFLAGS = -Wall $(am__append_2)
@LINK_BOX_TRUE@AM_CFLAGS = -Wall $(am__append_2)
-@@ -246,7 +246,7 @@
+@@ -246,7 +246,7 @@ top_srcdir = @top_srcdir@
@LINK_BOX_FALSE@ dirclient.h thebridge.c users.c users.h hostfile.c hostfile.h \
@LINK_BOX_FALSE@ eventhook.c eventhook.h avrs.c avrs.h
diff --git a/comms/thebridge/files/patch-src_conference.c b/comms/thebridge/files/patch-src_conference.c
index d15b1de8547a..bae2a7195ef6 100644
--- a/comms/thebridge/files/patch-src_conference.c
+++ b/comms/thebridge/files/patch-src_conference.c
@@ -1,5 +1,5 @@
---- src/conference.c.orig 2013-01-03 21:44:25.000000000 -0500
-+++ src/conference.c 2013-01-03 21:44:51.000000000 -0500
+--- src/conference.c.orig 2012-12-09 19:21:01 UTC
++++ src/conference.c
@@ -784,7 +784,7 @@
#include "ilink.h"
#include "sf.h"
diff --git a/comms/thebridge/files/patch-src_dirclient.c b/comms/thebridge/files/patch-src_dirclient.c
index 498eacac385a..9d084e612f99 100644
--- a/comms/thebridge/files/patch-src_dirclient.c
+++ b/comms/thebridge/files/patch-src_dirclient.c
@@ -1,5 +1,5 @@
---- src/dirclient.c.orig 2013-01-03 21:44:33.000000000 -0500
-+++ src/dirclient.c 2013-01-03 21:45:03.000000000 -0500
+--- src/dirclient.c.orig 2008-09-14 17:04:51 UTC
++++ src/dirclient.c
@@ -222,7 +222,7 @@
#include "dirclient.h"
#include "hostfile.h"
diff --git a/comms/thebridge/files/patch-tbdcmd_Makefile.in b/comms/thebridge/files/patch-tbdcmd_Makefile.in
index bfce2a5f9e40..812250444b9d 100644
--- a/comms/thebridge/files/patch-tbdcmd_Makefile.in
+++ b/comms/thebridge/files/patch-tbdcmd_Makefile.in
@@ -1,6 +1,6 @@
---- tbdcmd/Makefile.in.orig 2012-12-10 15:00:44.000000000 +0900
-+++ tbdcmd/Makefile.in 2013-10-24 13:36:31.000000000 +0900
-@@ -530,7 +530,7 @@
+--- tbdcmd/Makefile.in.orig 2012-12-10 06:00:44 UTC
++++ tbdcmd/Makefile.in
+@@ -530,7 +530,7 @@ uninstall-am: uninstall-binPROGRAMS
@LINK_BOX_FALSE@ if test -f $(DESTDIR)$(bindir)/tbdchat; then \
@LINK_BOX_FALSE@ rm $(DESTDIR)$(bindir)/tbdchat; \
@LINK_BOX_FALSE@ fi