aboutsummaryrefslogtreecommitdiff
path: root/comms/thebridge
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2015-04-05 15:10:22 +0000
committerDiane Bruce <db@FreeBSD.org>2015-04-05 15:10:22 +0000
commitb5878bf44a07e9c3b196369cd505f57912e184a4 (patch)
tree25dbac23624b3fcecf1f128cad0c5b7ac2f7905f /comms/thebridge
parent9441766330071c29235d4eee7a9d329869a37b0a (diff)
downloadports-b5878bf44a07e9c3b196369cd505f57912e184a4.tar.gz
ports-b5878bf44a07e9c3b196369cd505f57912e184a4.zip
add 'USES=shebangfix' to fix 'usermgmt.cgi' script.
PR: ports/199056 Submitted by: takefu@airport.fm
Notes
Notes: svn path=/head/; revision=383296
Diffstat (limited to 'comms/thebridge')
-rw-r--r--comms/thebridge/Makefile19
-rw-r--r--comms/thebridge/files/patch-addons_usermgmt.cgi17
-rw-r--r--comms/thebridge/files/patch-tbdcmd_Makefile.in2
3 files changed, 14 insertions, 24 deletions
diff --git a/comms/thebridge/Makefile b/comms/thebridge/Makefile
index dd6cdd6d9954..b4fab68a6642 100644
--- a/comms/thebridge/Makefile
+++ b/comms/thebridge/Makefile
@@ -11,19 +11,26 @@ COMMENT= Amateur Radio Echolink conference bridge
LICENSE= GPLv2
-USES= gmake tar:tgz
+USES= gmake shebangfix tar:tgz
GNU_CONFIGURE= yes
PORTDOCS= README
USE_RC_SUBR= tbd
MAKE_ARGS= AUTOMAKE="${TRUE}"
+SHEBANG_FILES= addons/usermgmt.cgi
+SHEBANG_LANG= bash
+
INSTALL_TARGET= install-strip
+post-patch:
+ @${REINPLACE_CMD} 's!tbdcmd=\/usr\/local!tbdcmd=${PREFIX}!'\
+ ${WRKSRC}/addons/usermgmt.cgi
+
post-install:
- @${MKDIR} ${STAGEDIR}/${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}/${DOCSDIR}
- ${MKDIR} ${STAGEDIR}/${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/addons/usermgmt.cgi ${STAGEDIR}/${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/addons/README ${STAGEDIR}/${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/addons/usermgmt.cgi ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/addons/README ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/comms/thebridge/files/patch-addons_usermgmt.cgi b/comms/thebridge/files/patch-addons_usermgmt.cgi
deleted file mode 100644
index 3487ae4a8b93..000000000000
--- a/comms/thebridge/files/patch-addons_usermgmt.cgi
+++ /dev/null
@@ -1,17 +0,0 @@
---- addons/usermgmt.cgi.orig 2011-02-21 10:51:53.000000000 +0900
-+++ addons/usermgmt.cgi 2011-02-21 10:55:12.000000000 +0900
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!%%LOCALBASE%%/bin/bash
- #-------------------------------------------------------------------
- # TheBridge Echolink Conference Server User Management Utility
- #
-@@ -15,7 +15,7 @@
- admin= # admin's callsign or quoted name
- qrz=yes # leave blank to disable QRZ lookups
- chginfo=no # enable/disable Info/Location changes
--tbdcmd=/usr/local/bin/tbdcmd # path to "tbdcmd" executable
-+tbdcmd=%%PREFIX%%/bin/tbdcmd # path to "tbdcmd" executable
- #-------------------------------------------------------------------
- echo 'Content-type: text/html'
- echo ''
diff --git a/comms/thebridge/files/patch-tbdcmd_Makefile.in b/comms/thebridge/files/patch-tbdcmd_Makefile.in
index a64d2e8f3ea4..bfce2a5f9e40 100644
--- a/comms/thebridge/files/patch-tbdcmd_Makefile.in
+++ b/comms/thebridge/files/patch-tbdcmd_Makefile.in
@@ -6,6 +6,6 @@
@LINK_BOX_FALSE@ fi
-@LINK_BOX_FALSE@ ln -s $(DESTDIR)$(bindir)/tbdcmd $(DESTDIR)$(bindir)/tbdchat
+@LINK_BOX_FALSE@ ln -s tbdcmd $(DESTDIR)$(bindir)/tbdchat
-
+
@LINK_BOX_FALSE@uninstall-hook:
@LINK_BOX_FALSE@ rm $(DESTDIR)$(bindir)/tbdchat