aboutsummaryrefslogtreecommitdiff
path: root/comms/tilp2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /comms/tilp2/Makefile
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'comms/tilp2/Makefile')
-rw-r--r--comms/tilp2/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index 31b1e9ed9100..654dff01dc2d 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tilp2
PORTVERSION= 1.07
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tilp
@@ -34,9 +35,15 @@ PLIST_SUB= NLS="@comment "
.endif
CONFIGURE_ARGS+= --without-kde
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -UGTK_DISABLE_DEPRECATED" \
LDFLAGS="-L${LOCALBASE}/lib -export-dynamic"
MAN1= tilp.1
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-D.*_DISABLE_DEPRECATED||g'
+ @${REINPLACE_CMD} -e 's|#define .*_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/src/device.c ${WRKSRC}/src/toolbar.c
+
.include <bsd.port.mk>