aboutsummaryrefslogtreecommitdiff
path: root/comms/tlf/Makefile
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-06-27 19:55:50 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-06-27 19:55:50 +0000
commit230f3ffa567c52009c76a187de20fd94bdbdbb0b (patch)
tree5f173e18f4c7c9108d39ad3641e2f0585cf3982e /comms/tlf/Makefile
parent37a172c645dfe6a1f9fdf03d903e7da5f91ff0a2 (diff)
downloadports-230f3ffa567c52009c76a187de20fd94bdbdbb0b.tar.gz
ports-230f3ffa567c52009c76a187de20fd94bdbdbb0b.zip
Notes
Diffstat (limited to 'comms/tlf/Makefile')
-rw-r--r--comms/tlf/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/comms/tlf/Makefile b/comms/tlf/Makefile
index e8d2413635cd..e985fcca5c0c 100644
--- a/comms/tlf/Makefile
+++ b/comms/tlf/Makefile
@@ -10,24 +10,23 @@ MASTER_SITES= http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/ \
MASTER_SITE_SUBDIR= db
DISTNAME= tlf-0.9.31-2
-MAINTAINER= db@FreeBSD.org
+MAINTAINER= hamradio@FreeBSD.org
COMMENT= Amateur Radio curses based logging program
+LICENSE= GPLv2
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_AUTOTOOLS= autoconf libtool aclocal automake
+USE_AUTOTOOLS= autoconf aclocal automake
+USES= libtool
AUTOMAKE_ARGS= --add-missing
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
- --libdir="${LOCALBASE}/lib"
-LDFLAGS+= ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
OPTIONS_DEFINE= HAMLIB
HAMLIB_DESC= Use hamlib
OPTION_DEFAULT= HAMLIB
-MAN1= tlf.1
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MHAMLIB}