aboutsummaryrefslogtreecommitdiff
path: root/comms/uhd
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2018-02-18 17:52:52 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2018-02-18 17:52:52 +0000
commita55fe0bba0dc0156883058077568434c819302c2 (patch)
treeba9ccc58325adeb88d67e35438931e9c55207950 /comms/uhd
parentc55c8d36d6687d38b1c05860df48e3a8303ee946 (diff)
downloadports-a55fe0bba0dc0156883058077568434c819302c2.tar.gz
ports-a55fe0bba0dc0156883058077568434c819302c2.zip
Update to 3.10.3.0 and try to fix compilation under current.
Notes
Notes: svn path=/head/; revision=462257
Diffstat (limited to 'comms/uhd')
-rw-r--r--comms/uhd/Makefile17
-rw-r--r--comms/uhd/distinfo10
-rw-r--r--comms/uhd/files/patch-examples_CMakeLists.txt8
-rw-r--r--comms/uhd/files/patch-host_examples_network_relay.cpp16
-rw-r--r--comms/uhd/files/patch-host_lib_transport_tcp_zero_copy.cpp9
-rw-r--r--comms/uhd/files/patch-host_lib_transport_udp_simple.cpp9
-rw-r--r--comms/uhd/files/patch-host_lib_transport_udp_zero_copy.cpp9
-rw-r--r--comms/uhd/pkg-plist2
8 files changed, 16 insertions, 64 deletions
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 3c0a61a37430..7c41f57ecd2c 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= uhd
-PORTVERSION= 3.10.2.0
+PORTVERSION= 3.10.3.0
PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= http://files.ettus.com/binaries/images/
@@ -11,7 +11,8 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= mr@FreeBSD.org
COMMENT= Ettus Research UHD driver framework
-LIB_DEPENDS= ${PY_BOOST}
+LIB_DEPENDS= ${PY_BOOST} \
+ libboost_system.so:devel/boost-libs
BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
cheetah-analyze:devel/py-cheetah@${PY_FLAVOR} \
rst2html:textproc/py-docutils \
@@ -20,19 +21,21 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
USE_GITHUB= yes
GH_ACCOUNT= EttusResearch
-GH_TAGNAME= bd6e21dc06cfca6f1165b1eba6ddbf5a46dc343c
+GH_TAGNAME= ef1576780bc927b8611640091b15f3d051cb97ad
CONFLICTS= usrp-[0-9]*
BROKEN_powerpc64= fails to link: undefined reference to boost function
-USES= compiler:c++0x cmake:outsource ncurses pkgconfig \
+USES= compiler:c++11-lib cmake:outsource ncurses pkgconfig \
dos2unix python:2.7 shebangfix
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
#MAKE_JOBS_UNSAFE= yes
-CXXFLAGS_amd64= -msse2
-CXXFLAGS_i386= -msse2
+#CXXFLAGS_amd64= -msse2 -std=c++11
+#CXXFLAGS_i386= -msse2 -std=c++11
+CXXFLAGS_amd64= -msse2 -std=c++98
+CXXFLAGS_i386= -msse2 -std=c++98
SHEBANG_GLOB= *.py *.py.in
@@ -40,7 +43,7 @@ CMAKE_ARGS+= -DPKG_LIB_DIR:STRING="share/uhd" -DUHD_TXRX_DEBUG_PRINTS="yes"
# for excruciating debug use this -db
#CMAKE_ARGS+= --debug-output --trace
-IMAGE_FILE= uhd-images_003.010.002.000-release.zip
+IMAGE_FILE= uhd-images_003.010.003.000-release.zip
OPTIONS_DEFINE= DOXYGEN
#OPTIONS_DEFAULT= DOXYGEN
diff --git a/comms/uhd/distinfo b/comms/uhd/distinfo
index ec23e7f858d1..06fdb9db539c 100644
--- a/comms/uhd/distinfo
+++ b/comms/uhd/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1513524207
-SHA256 (uhd/uhd-images_003.010.002.000-release.zip) = a4ae7df05230c0ed7819ec34720a3a079f2f28ae6c52a0ee039fd58cab4ad906
-SIZE (uhd/uhd-images_003.010.002.000-release.zip) = 57471231
-SHA256 (uhd/EttusResearch-uhd-3.10.2.0-bd6e21dc06cfca6f1165b1eba6ddbf5a46dc343c_GH0.tar.gz) = 7ac7fd15f2be5ed44152d69f99dc4f7eb1d58a5f093841990c8650224d3f7f7a
-SIZE (uhd/EttusResearch-uhd-3.10.2.0-bd6e21dc06cfca6f1165b1eba6ddbf5a46dc343c_GH0.tar.gz) = 7554133
+TIMESTAMP = 1518970871
+SHA256 (uhd/uhd-images_003.010.003.000-release.zip) = 541fbed21d593a1dff05ed56b7ce8c72d9564e4e5146690531337cde0cf411f0
+SIZE (uhd/uhd-images_003.010.003.000-release.zip) = 57008597
+SHA256 (uhd/EttusResearch-uhd-3.10.3.0-ef1576780bc927b8611640091b15f3d051cb97ad_GH0.tar.gz) = a0af01b7fc6a6b2aca6b2ecb264156e0a93c2524d61f36295b02bdef256affd7
+SIZE (uhd/EttusResearch-uhd-3.10.3.0-ef1576780bc927b8611640091b15f3d051cb97ad_GH0.tar.gz) = 7566186
diff --git a/comms/uhd/files/patch-examples_CMakeLists.txt b/comms/uhd/files/patch-examples_CMakeLists.txt
deleted file mode 100644
index 72b7f0ce8e7e..000000000000
--- a/comms/uhd/files/patch-examples_CMakeLists.txt
+++ /dev/null
@@ -1,8 +0,0 @@
---- host/examples/CMakeLists.txt.orig 2015-11-14 16:31:04.640272000 +0000
-+++ host/examples/CMakeLists.txt 2015-11-14 17:26:27.512820000 +0000
-@@ -50,4 +50,5 @@
- UHD_INSTALL(TARGETS ${example_name} RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
- ENDFOREACH(example_source)
-+TARGET_LINK_LIBRARIES(network_relay -pthread)
-
- ########################################################################
diff --git a/comms/uhd/files/patch-host_examples_network_relay.cpp b/comms/uhd/files/patch-host_examples_network_relay.cpp
deleted file mode 100644
index 3bc737bef508..000000000000
--- a/comms/uhd/files/patch-host_examples_network_relay.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- host/examples/network_relay.cpp.orig 2017-12-17 19:37:02.232333000 +0000
-+++ host/examples/network_relay.cpp 2017-12-17 19:37:35.331222000 +0000
-@@ -128,5 +128,5 @@
- std::vector<char> buff(insane_mtu);
- while (not boost::this_thread::interruption_requested()){
-- if (wait_for_recv_ready(_server_socket->native())){
-+ if (wait_for_recv_ready(_server_socket->native_handle())){
- boost::mutex::scoped_lock lock(_endpoint_mutex);
- const size_t len = _server_socket->receive_from(asio::buffer(&buff.front(), buff.size()), _endpoint);
-@@ -154,5 +154,5 @@
- std::vector<char> buff(insane_mtu);
- while (not boost::this_thread::interruption_requested()){
-- if (wait_for_recv_ready(_client_socket->native())){
-+ if (wait_for_recv_ready(_client_socket->native_handle())){
- const size_t len = _client_socket->receive(asio::buffer(&buff.front(), buff.size()));
- boost::mutex::scoped_lock lock(_endpoint_mutex);
diff --git a/comms/uhd/files/patch-host_lib_transport_tcp_zero_copy.cpp b/comms/uhd/files/patch-host_lib_transport_tcp_zero_copy.cpp
deleted file mode 100644
index 0b00e14f0a87..000000000000
--- a/comms/uhd/files/patch-host_lib_transport_tcp_zero_copy.cpp
+++ /dev/null
@@ -1,9 +0,0 @@
---- host/lib/transport/tcp_zero_copy.cpp.orig 2017-12-17 19:39:49.890757000 +0000
-+++ host/lib/transport/tcp_zero_copy.cpp 2017-12-17 19:40:36.125127000 +0000
-@@ -155,5 +155,5 @@
- _socket.reset(new asio::ip::tcp::socket(_io_service));
- _socket->connect(receiver_endpoint);
-- _sock_fd = _socket->native();
-+ _sock_fd = _socket->native_handle();
-
- //packets go out ASAP
diff --git a/comms/uhd/files/patch-host_lib_transport_udp_simple.cpp b/comms/uhd/files/patch-host_lib_transport_udp_simple.cpp
deleted file mode 100644
index 7bc6bf3598aa..000000000000
--- a/comms/uhd/files/patch-host_lib_transport_udp_simple.cpp
+++ /dev/null
@@ -1,9 +0,0 @@
---- host/lib/transport/udp_simple.cpp.orig 2017-12-17 19:40:02.609104000 +0000
-+++ host/lib/transport/udp_simple.cpp 2017-12-17 19:40:47.660730000 +0000
-@@ -57,5 +57,5 @@
-
- size_t recv(const asio::mutable_buffer &buff, double timeout){
-- if (not wait_for_recv_ready(_socket->native(), timeout)) return 0;
-+ if (not wait_for_recv_ready(_socket->native_handle(), timeout)) return 0;
- return _socket->receive_from(asio::buffer(buff), _recv_endpoint);
- }
diff --git a/comms/uhd/files/patch-host_lib_transport_udp_zero_copy.cpp b/comms/uhd/files/patch-host_lib_transport_udp_zero_copy.cpp
deleted file mode 100644
index b2608b698be0..000000000000
--- a/comms/uhd/files/patch-host_lib_transport_udp_zero_copy.cpp
+++ /dev/null
@@ -1,9 +0,0 @@
---- host/lib/transport/udp_zero_copy.cpp.orig 2017-12-17 16:25:59.637675000 +0100
-+++ host/lib/transport/udp_zero_copy.cpp 2017-12-17 16:26:12.713784000 +0100
-@@ -191,5 +191,5 @@
- _socket->open(asio::ip::udp::v4());
- _socket->connect(receiver_endpoint);
-- _sock_fd = _socket->native();
-+ _sock_fd = _socket->native_handle();
-
- //allocate re-usable managed receive buffers
diff --git a/comms/uhd/pkg-plist b/comms/uhd/pkg-plist
index 30ca67bb5a89..44bed175a030 100644
--- a/comms/uhd/pkg-plist
+++ b/comms/uhd/pkg-plist
@@ -150,7 +150,7 @@ share/man/man1/usrp_x3xx_fpga_burner.1.gz
%%DATADIR%%/examples/tx_timed_samples
%%DATADIR%%/examples/tx_waveforms
%%DATADIR%%/examples/txrx_loopback_to_file
-%%DATADIR%%/images/003.010.002.000.tag
+%%DATADIR%%/images/003.010.003.000.tag
%%DATADIR%%/images/LICENSE
%%DATADIR%%/images/bit/usrp_n200_r3_fpga.bit
%%DATADIR%%/images/bit/usrp_n200_r4_fpga.bit