aboutsummaryrefslogtreecommitdiff
path: root/comms/uird
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 13:57:57 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 13:57:57 +0000
commitf3465ba031bcda43ca5ce00cf70519777c5ca387 (patch)
treecd82a82c9e507bf95f596807d424ccb29469dca5 /comms/uird
parent34aad93b3473b0cb886ac8147463d322eac35fe0 (diff)
downloadports-f3465ba031bcda43ca5ce00cf70519777c5ca387.tar.gz
ports-f3465ba031bcda43ca5ce00cf70519777c5ca387.zip
- Support staging
- USES -> gmake
Notes
Notes: svn path=/head/; revision=346517
Diffstat (limited to 'comms/uird')
-rw-r--r--comms/uird/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/comms/uird/Makefile b/comms/uird/Makefile
index 32dcaa041cc7..5e369a8b4fe0 100644
--- a/comms/uird/Makefile
+++ b/comms/uird/Makefile
@@ -11,8 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= lx@FreeBSD.org
COMMENT= The Universal IR Receiver Daemon
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= ${PORTNAME}
@@ -20,21 +19,15 @@ ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/uird
PORTDOCS= Documentation
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|gcc|$${CC}\ $${CFLAGS}|; /strip/d' \
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/uird ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/uird ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>