aboutsummaryrefslogtreecommitdiff
path: root/comms/unixcw
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-12-12 12:26:03 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-12-12 12:26:03 +0000
commit114e81674c93819f439195119fd58bcc82f44b6e (patch)
tree9bf0acfd33163de27b5ddc9457015a453290264d /comms/unixcw
parentdaff9e5beb1fc0ef39436139177aeaf8498a1698 (diff)
downloadports-114e81674c93819f439195119fd58bcc82f44b6e.tar.gz
ports-114e81674c93819f439195119fd58bcc82f44b6e.zip
Update to 3.4.0 (build system fixes)
Remove XCWCP option and prepare this to be a master port instead. Otherwise there's no way to support xcwcp using pkg without making QT a dependency of comms/cwdaemon.
Notes
Notes: svn path=/head/; revision=374590
Diffstat (limited to 'comms/unixcw')
-rw-r--r--comms/unixcw/Makefile36
-rw-r--r--comms/unixcw/distinfo4
-rw-r--r--comms/unixcw/files/patch-src_libcw_Makefile.am29
-rw-r--r--comms/unixcw/files/patch-src_libcw_Makefile.in33
-rw-r--r--comms/unixcw/files/patch-src_libcw_libcw_oss.c29
-rw-r--r--comms/unixcw/files/patch-src_xcwcp_Makefile.am11
-rw-r--r--comms/unixcw/files/patch-src_xcwcp_Makefile.in11
-rw-r--r--comms/unixcw/pkg-plist4
8 files changed, 20 insertions, 137 deletions
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
index 470526c96134..480095822025 100644
--- a/comms/unixcw/Makefile
+++ b/comms/unixcw/Makefile
@@ -1,43 +1,33 @@
# $FreeBSD$
+# NOTE: comms/xcwcp is a sub-port of this. When making changes, ensure
+# it still works as well.
+
PORTNAME= unixcw
-PORTVERSION= 3.3.0
-PORTREVISION= 1
-CATEGORIES= comms hamradio
+PORTVERSION= 3.4.0
+CATEGORIES?= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-DISTNAME= unixcw_3.3.0.orig
+DISTNAME= unixcw_${PORTVERSION}.orig
MAINTAINER= hamradio@FreeBSD.org
-COMMENT= Libs for cw on unix
+COMMENT?= Libs for cw on unix
LICENSE= GPLv2
GNU_CONFIGURE= yes
+.ifndef CONFIGURE_ARGS
+CONFIGURE_ARGS= --disable-xcwcp
+.endif
CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
--disable-alsa --disable-pulseaudio
-.if defined(WITH_XCWCP)
-USE_QT4= gui moc_build qmake_build rcc_build uic_build designer
-USE_AUTOTOOLS= autoconf
-PLIST_SUB+= XCWCP=""
-CONFIGURE_ARGS+= --enable-xcwcp
-.else
-PLIST_SUB+= XCWCP="@comment "
-CONFIGURE_ARGS+= --disable-xcwcp
-.endif
USE_LDCONFIG= yes
-USES= gmake libtool
+USES= gmake libtool pkgconfig
USE_CSTD= gnu99
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-pre-extract:
-.if !defined(WITH_XCWCP)
- @${ECHO_CMD}
- @${ECHO_CMD} "****** To build xcwcp, interrupt the build ******"
- @${ECHO_CMD} "****** now, set WITH_XCWCP and start again. ******"
- @${ECHO_CMD}
- @sleep 3
-.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcw.so.6.2.1
.include <bsd.port.mk>
diff --git a/comms/unixcw/distinfo b/comms/unixcw/distinfo
index 4dfb7fa6ffb1..c95d787cd356 100644
--- a/comms/unixcw/distinfo
+++ b/comms/unixcw/distinfo
@@ -1,2 +1,2 @@
-SHA256 (unixcw_3.3.0.orig.tar.gz) = 2d0e38b5758014942612369eaa1b4989c44edcc1120abf3a30515c55413d4db0
-SIZE (unixcw_3.3.0.orig.tar.gz) = 657613
+SHA256 (unixcw_3.4.0.orig.tar.gz) = 2c26fc36c9cbcc0c3b05fa186b254392a8439dee54eb9db28ff542094fffd092
+SIZE (unixcw_3.4.0.orig.tar.gz) = 681432
diff --git a/comms/unixcw/files/patch-src_libcw_Makefile.am b/comms/unixcw/files/patch-src_libcw_Makefile.am
deleted file mode 100644
index d73c2e5635eb..000000000000
--- a/comms/unixcw/files/patch-src_libcw_Makefile.am
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/libcw/Makefile.am.orig 2013-10-21 13:44:21.000000000 -0500
-+++ src/libcw/Makefile.am 2013-12-30 09:58:21.000000000 -0500
-@@ -41,7 +41,7 @@
-
- # target-specific linker flags (objects to link)
- # libcw_la_LIBADD=-lm -lpthread $(AC_ALSA_LIBS) $(AC_PULSEAUDIO_LIBS)
--libcw_la_LIBADD=-lm -lpthread -ldl
-+libcw_la_LIBADD=-lm -lpthread
-
- # target-specific linker flags (additional flags)
- # http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-@@ -79,7 +79,7 @@
- libcwunittests_CPPFLAGS = $(AM_CPPFLAGS) -DLIBCW_UNIT_TESTS
-
- # target-specific linker flags (objects to link)
--libcwunittests_LDADD=-lm -lpthread -ldl
-+libcwunittests_LDADD=-lm -lpthread
-
- # target-specific compiler flags
- libcwunittests_CFLAGS = -rdynamic
-@@ -95,7 +95,7 @@
-
-
- standalone:
-- gcc -O0 -g -DHAVE_CONFIG_H -std=gnu99 -I. -I../../src -I../../src/ -I../../src/libcw/ -I../../src/cwutils/ -DLIBCW_WITH_DEV -DLIBCW_STANDALONE -DLIBCW_WITH_PULSEAUDIO -DLIBCW_WITH_OSS -DLIBCW_WITH_ALSA -DLIBCW_WITH_CONSOLE libcw.c libcwtest.c libcw_console.c libcw_null.c libcw_pa.c libcw_debug.c libcw_oss.c libcw_alsa.c -lm -ldl -lpthread -o libcw_standalone
-+ ${CC} -O0 -g -DHAVE_CONFIG_H -std=gnu99 -I. -I../../src -I../../src/ -I../../src/libcw/ -I../../src/cwutils/ -DLIBCW_WITH_DEV -DLIBCW_STANDALONE -DLIBCW_WITH_PULSEAUDIO -DLIBCW_WITH_OSS -DLIBCW_WITH_ALSA -DLIBCW_WITH_CONSOLE libcw.c libcwtest.c libcw_console.c libcw_null.c libcw_pa.c libcw_debug.c libcw_oss.c libcw_alsa.c -lm -ldl -lpthread -o libcw_standalone
-
-
- # target: libcw.pc
diff --git a/comms/unixcw/files/patch-src_libcw_Makefile.in b/comms/unixcw/files/patch-src_libcw_Makefile.in
index 883a268981aa..9360c6df5a0e 100644
--- a/comms/unixcw/files/patch-src_libcw_Makefile.in
+++ b/comms/unixcw/files/patch-src_libcw_Makefile.in
@@ -1,23 +1,7 @@
---- src/libcw/Makefile.in.orig 2013-12-09 18:00:56.000000000 -0500
-+++ src/libcw/Makefile.in 2013-12-30 09:56:43.000000000 -0500
-@@ -572,7 +572,7 @@
-
- # target-specific linker flags (objects to link)
- # libcw_la_LIBADD=-lm -lpthread $(AC_ALSA_LIBS) $(AC_PULSEAUDIO_LIBS)
--libcw_la_LIBADD = -lm -lpthread -ldl
-+libcw_la_LIBADD = -lm -lpthread
-
- # target-specific linker flags (additional flags)
- # http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-@@ -604,13 +604,13 @@
- libcwunittests_CPPFLAGS = $(AM_CPPFLAGS) -DLIBCW_UNIT_TESTS
-
- # target-specific linker flags (objects to link)
--libcwunittests_LDADD = -lm -lpthread -ldl
-+libcwunittests_LDADD = -lm -lpthread
-
- # target-specific compiler flags
- libcwunittests_CFLAGS = -rdynamic
+--- src/libcw/Makefile.in.orig 2014-12-12 03:00:52.000000000 -0800
++++ src/libcw/Makefile.in 2014-12-12 03:04:21.000000000 -0800
+@@ -663,7 +663,7 @@
+ libcw_test_simple_gen_CFLAGS = -rdynamic
# target: libcw.pc
-pkgconfigdir = $(libdir)/pkgconfig
@@ -25,12 +9,3 @@
# CLEANFILES extends list of files that need to be removed when
# calling "make clean"
-@@ -1430,7 +1430,7 @@
- rm -f signatures functions
-
- standalone:
-- gcc -O0 -g -DHAVE_CONFIG_H -std=gnu99 -I. -I../../src -I../../src/ -I../../src/libcw/ -I../../src/cwutils/ -DLIBCW_WITH_DEV -DLIBCW_STANDALONE -DLIBCW_WITH_PULSEAUDIO -DLIBCW_WITH_OSS -DLIBCW_WITH_ALSA -DLIBCW_WITH_CONSOLE libcw.c libcwtest.c libcw_console.c libcw_null.c libcw_pa.c libcw_debug.c libcw_oss.c libcw_alsa.c -lm -ldl -lpthread -o libcw_standalone
-+ ${CC} -O0 -g -DHAVE_CONFIG_H -std=gnu99 -I. -I../../src -I../../src/ -I../../src/libcw/ -I../../src/cwutils/ -DLIBCW_WITH_DEV -DLIBCW_STANDALONE -DLIBCW_WITH_PULSEAUDIO -DLIBCW_WITH_OSS -DLIBCW_WITH_ALSA -DLIBCW_WITH_CONSOLE libcw.c libcwtest.c libcw_console.c libcw_null.c libcw_pa.c libcw_debug.c libcw_oss.c libcw_alsa.c -lm -ldl -lpthread -o libcw_standalone
- greptest.sh:
- echo './libcwunittests | grep "test result: success"' > greptest.sh
- chmod +x greptest.sh
diff --git a/comms/unixcw/files/patch-src_libcw_libcw_oss.c b/comms/unixcw/files/patch-src_libcw_libcw_oss.c
deleted file mode 100644
index ba77367d8b45..000000000000
--- a/comms/unixcw/files/patch-src_libcw_libcw_oss.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/libcw/libcw_oss.c.orig 2013-01-03 17:09:29.000000000 -0500
-+++ src/libcw/libcw_oss.c 2013-12-30 14:20:18.000000000 -0500
-@@ -48,6 +48,9 @@
- #include <stdbool.h>
- #include <math.h>
-
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+# include <sys/param.h>
-+#endif
-
- #include "libcw_internal.h"
- #include "libcw_oss.h"
-@@ -291,14 +294,14 @@
- "cw_oss: ioctl(SNDCTL_DSP_SYNC): \"%s\"", strerror(errno));
- return CW_FAILURE;
- }
--
-+#ifndef __FreeBSD__
- parameter = 0; /* ignored */
- if (ioctl(*fd, SNDCTL_DSP_POST, &parameter) == -1) {
- cw_debug_msg ((&cw_debug_object), CW_DEBUG_SOUND_SYSTEM, CW_DEBUG_ERROR,
- "cw_oss: ioctl(SNDCTL_DSP_POST): \"%s\"", strerror(errno));
- return CW_FAILURE;
- }
--
-+#endif
- /* Set the audio format to 8-bit unsigned. */
- parameter = CW_OSS_SAMPLE_FORMAT;
- if (ioctl(*fd, SNDCTL_DSP_SETFMT, &parameter) == -1) {
diff --git a/comms/unixcw/files/patch-src_xcwcp_Makefile.am b/comms/unixcw/files/patch-src_xcwcp_Makefile.am
deleted file mode 100644
index fb7046075e2b..000000000000
--- a/comms/unixcw/files/patch-src_xcwcp_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xcwcp/Makefile.am.orig 2013-12-30 10:51:14.000000000 -0500
-+++ src/xcwcp/Makefile.am 2013-12-30 10:51:39.000000000 -0500
-@@ -37,7 +37,7 @@
- # target-specific preprocessor flags (#defs and include dirs)
- xcwcp_CPPFLAGS = $(AM_CPPFLAGS) $(AC_QT4CFLAGS) #-I$(AC_QT4INC)/QtCore -I$(AC_QT4INC)/QtGui
- # target-specific linker flags (objects to link)
--xcwcp_LDADD = -L$(top_builddir)/src/libcw/.libs -lcw -lQtGui -lQtCore $(top_builddir)/src/cwutils/lib_xcwcp.a
-+xcwcp_LDADD = -L$(top_builddir)/src/libcw/.libs -L$(QT4LIBS) -lcw -lQtGui -lQtCore $(top_builddir)/src/cwutils/lib_xcwcp.a
-
-
-
diff --git a/comms/unixcw/files/patch-src_xcwcp_Makefile.in b/comms/unixcw/files/patch-src_xcwcp_Makefile.in
deleted file mode 100644
index c53d77d4c1e4..000000000000
--- a/comms/unixcw/files/patch-src_xcwcp_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xcwcp/Makefile.in.orig 2013-12-30 10:51:06.000000000 -0500
-+++ src/xcwcp/Makefile.in 2013-12-30 10:51:22.000000000 -0500
-@@ -380,7 +380,7 @@
- # target-specific preprocessor flags (#defs and include dirs)
- xcwcp_CPPFLAGS = $(AM_CPPFLAGS) $(AC_QT4CFLAGS) #-I$(AC_QT4INC)/QtCore -I$(AC_QT4INC)/QtGui
- # target-specific linker flags (objects to link)
--xcwcp_LDADD = -L$(top_builddir)/src/libcw/.libs -lcw -lQtGui -lQtCore $(top_builddir)/src/cwutils/lib_xcwcp.a
-+xcwcp_LDADD = -L$(top_builddir)/src/libcw/.libs -L$(QT4LIBS) -lcw -lQtGui -lQtCore $(top_builddir)/src/cwutils/lib_xcwcp.a
-
- # copy man page to proper directory during installation
- man_MANS = xcwcp.1
diff --git a/comms/unixcw/pkg-plist b/comms/unixcw/pkg-plist
index 9bbf5fc81203..072b3b55c89a 100644
--- a/comms/unixcw/pkg-plist
+++ b/comms/unixcw/pkg-plist
@@ -1,17 +1,15 @@
bin/cw
bin/cwcp
bin/cwgen
-%%XCWCP%%bin/xcwcp
include/libcw.h
include/libcw_debug.h
lib/libcw.a
lib/libcw.so
lib/libcw.so.6
-lib/libcw.so.6.0.1
+lib/libcw.so.6.2.1
libdata/pkgconfig/libcw.pc
man/man1/cw.1.gz
man/man1/cwgen.1.gz
man/man1/cwcp.1.gz
-%%XCWCP%%/man/man1/xcwcp.1.gz
man/man3/libcw.3.gz
man/man7/cw.7.gz