aboutsummaryrefslogtreecommitdiff
path: root/comms/wsjtx
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2015-11-26 04:10:03 +0000
committerDiane Bruce <db@FreeBSD.org>2015-11-26 04:10:03 +0000
commit5e5fe407076d6d51bb252dfe85a2baa0fbee2bde (patch)
treefdbe886fb8cb8a9fa1ccb20de5f067676d546beb /comms/wsjtx
parent0f226ecc84d9a34c02c354819b812b4b516fb448 (diff)
downloadports-5e5fe407076d6d51bb252dfe85a2baa0fbee2bde.tar.gz
ports-5e5fe407076d6d51bb252dfe85a2baa0fbee2bde.zip
Clean up port to use pkgconfig
No change to actual port produced binaries results.
Notes
Notes: svn path=/head/; revision=402432
Diffstat (limited to 'comms/wsjtx')
-rw-r--r--comms/wsjtx/Makefile2
-rw-r--r--comms/wsjtx/files/patch-CMake_Modules_Findhamlib.cmake26
2 files changed, 1 insertions, 27 deletions
diff --git a/comms/wsjtx/Makefile b/comms/wsjtx/Makefile
index b8705395efc5..aef1c9111a14 100644
--- a/comms/wsjtx/Makefile
+++ b/comms/wsjtx/Makefile
@@ -26,7 +26,7 @@ MAKE_JOBS_UNSAFE= yes
USE_QT5= gui buildtools qmake_build widgets multimedia concurrent serialport
USE_GL= yes
USE_GCC= yes
-USES= cmake compiler:c++11-lib dos2unix fortran
+USES= cmake compiler:c++11-lib dos2unix fortran pkgconfig
#CMAKE_ARGS+= --debug-output --trace
CMAKE_ARGS+= -DPORT_BUILDING::STRING="ON" \
-DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib
diff --git a/comms/wsjtx/files/patch-CMake_Modules_Findhamlib.cmake b/comms/wsjtx/files/patch-CMake_Modules_Findhamlib.cmake
deleted file mode 100644
index 3b448a0cbc66..000000000000
--- a/comms/wsjtx/files/patch-CMake_Modules_Findhamlib.cmake
+++ /dev/null
@@ -1,26 +0,0 @@
---- CMake/Modules/Findhamlib.cmake.orig 2015-11-25 02:16:24 UTC
-+++ CMake/Modules/Findhamlib.cmake
-@@ -9,6 +9,7 @@
-
- include (LibFindMacros)
-
-+
- # pkg-config?
- find_path (__hamlib_pc_path NAMES hamlib.pc
- PATH_SUFFIXES lib/pkgconfig
-@@ -26,8 +27,13 @@ if (NOT PC_HAMLIB_STATIC_LIBRARIES)
- if (WIN32)
- set (PC_HAMLIB_STATIC_LIBRARIES hamlib ws2_32)
- else ()
-- set (PC_HAMLIB_STATIC_LIBRARIES hamlib m dl usb)
-- endif ()
-+ if (FREEBSD)
-+ set (PC_HAMLIB_STATIC_LIBRARIES hamlib m usb)
-+ message (STATUS "FREEBSD Hamlib")
-+ else()
-+ set (PC_HAMLIB_STATIC_LIBRARIES hamlib m dl usb)
-+ endif ()
-+ endif()
- endif ()
-
- # The libraries