aboutsummaryrefslogtreecommitdiff
path: root/comms/xmorse
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-08-28 12:09:58 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-08-28 12:09:58 +0000
commit5875d23e78b6f33fa20caadd3ac0852ac8acc22f (patch)
tree66fce2c1170fa7f1aa490e6aba2be9a2157f8b51 /comms/xmorse
parent11e7c7e8e8768f191452f04d980281860f66ad55 (diff)
downloadports-5875d23e78b6f33fa20caadd3ac0852ac8acc22f.tar.gz
ports-5875d23e78b6f33fa20caadd3ac0852ac8acc22f.zip
- Fix build
Reported by: QA Tindie
Notes
Notes: svn path=/head/; revision=219373
Diffstat (limited to 'comms/xmorse')
-rw-r--r--comms/xmorse/Makefile2
-rw-r--r--comms/xmorse/files/patch-m.fl11
2 files changed, 12 insertions, 1 deletions
diff --git a/comms/xmorse/Makefile b/comms/xmorse/Makefile
index 894a1d1b9ce0..997aa4211ac4 100644
--- a/comms/xmorse/Makefile
+++ b/comms/xmorse/Makefile
@@ -19,7 +19,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= sunrychen@gmail.com
COMMENT= A fully automatic Morse code teaching machine
-BUILD_DEPENDS= fluid:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_DISPLAY= yes
USE_SDL= sdl
diff --git a/comms/xmorse/files/patch-m.fl b/comms/xmorse/files/patch-m.fl
new file mode 100644
index 000000000000..f36daa6f0a19
--- /dev/null
+++ b/comms/xmorse/files/patch-m.fl
@@ -0,0 +1,11 @@
+--- m.fl.orig 2008-08-28 14:00:49.000000000 +0200
++++ m.fl 2008-08-28 14:00:58.000000000 +0200
+@@ -231,7 +231,7 @@
+ }
+ }
+ }
+- code {w->show(argc, argv);
++ //code {w->show(argc, argv);
+ while (1) {
+ int c = Lesson->select(); // Select random letter
+ bool pass = Teacher->teach(c);// Teach/test student