aboutsummaryrefslogtreecommitdiff
path: root/comms/xnecview
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-06-05 13:59:38 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-06-05 13:59:38 +0000
commit2f1df2f8beb14453393be1ec42dfd8c7f89c8518 (patch)
tree5c5ea5e3e47bdc21f44fd86ad77fcdfd746588d2 /comms/xnecview
parentdcb70017d9e2769bfc35760adb6a8975e865af9b (diff)
downloadports-2f1df2f8beb14453393be1ec42dfd8c7f89c8518.tar.gz
ports-2f1df2f8beb14453393be1ec42dfd8c7f89c8518.zip
- Fix build on 4.x
- Respect CC PR: 98523 (based on) Submitted by: Soeren Straarup (maintainer)
Notes
Notes: svn path=/head/; revision=164449
Diffstat (limited to 'comms/xnecview')
-rw-r--r--comms/xnecview/Makefile2
-rw-r--r--comms/xnecview/files/patch-Makefile18
-rw-r--r--comms/xnecview/files/patch-parse_input.c19
3 files changed, 36 insertions, 3 deletions
diff --git a/comms/xnecview/Makefile b/comms/xnecview/Makefile
index faefcae34822..2d3d6b8451af 100644
--- a/comms/xnecview/Makefile
+++ b/comms/xnecview/Makefile
@@ -21,6 +21,8 @@ USE_GNOME= gtk20
USE_GMAKE= yes
USE_X_PREFIX= yes
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+
MAN1= xnecview.1
PLIST_FILES= bin/xnecview
diff --git a/comms/xnecview/files/patch-Makefile b/comms/xnecview/files/patch-Makefile
index be9d4cb1df37..9d6137bffffa 100644
--- a/comms/xnecview/files/patch-Makefile
+++ b/comms/xnecview/files/patch-Makefile
@@ -1,6 +1,18 @@
---- Makefile.orig Fri May 26 21:40:46 2006
-+++ Makefile Fri May 26 21:42:42 2006
-@@ -11,7 +11,8 @@
+--- Makefile.orig Mon Mar 27 22:38:37 2006
++++ Makefile Mon Jun 5 15:37:15 2006
+@@ -3,15 +3,16 @@
+
+
+
+-CC = gcc
+-CFLAGS = -O2 -g -Wall `pkg-config gtk+-2.0 --cflags`
++CC ?= gcc
++CFLAGS += `pkg-config gtk+-2.0 --cflags`
+
+-LD = $(CC)
+-LDFLAGS = `pkg-config gtk+-2.0 --libs` -lm
++LD ?= $(CC)
++LDFLAGS += `pkg-config gtk+-2.0 --libs` -lm
ifeq ($(PNG),yes)
CFLAGS += -DHAVE_LIBPNG
diff --git a/comms/xnecview/files/patch-parse_input.c b/comms/xnecview/files/patch-parse_input.c
new file mode 100644
index 000000000000..e3473abe3e32
--- /dev/null
+++ b/comms/xnecview/files/patch-parse_input.c
@@ -0,0 +1,19 @@
+--- parse_input.c.orig Mon Jun 5 08:56:55 2006
++++ parse_input.c Mon Jun 5 08:57:56 2006
+@@ -527,6 +527,7 @@
+ int read_nec_SC(char *s) /* SC -> continuation of SM, SP, or SC */
+ {
+ Surface *su;
++ Surface *suLast;
+ int ns;
+ Point p3;
+ int n;
+@@ -575,7 +576,7 @@
+ case 'C':
+ n=sscanf(s,"SC%*i%d%g%g%g%g%g%g",&ns,&su->p2.x,&su->p2.y,&su->p2.z,&su->p3.x,&su->p3.y,&su->p3.z);
+ if (n!=7 && n!=4) return Err_scan;
+- Surface *suLast=surfaces+(numsurfaces-2);
++ suLast=surfaces+(numsurfaces-2);
+ su->p0=suLast->p3;
+ su->p1=suLast->p2;
+ updateextremes(&su->p2);