aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-11 16:52:38 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-11 16:52:38 +0000
commit13e9223889844bff88fd41a911ed095fb075f2a5 (patch)
treed96b6852077532cf74e4ac52433e79118c1bd007 /comms
parent75c3c5e394ba21e50b1b8743cc06ebc59de7060e (diff)
downloadports-13e9223889844bff88fd41a911ed095fb075f2a5.tar.gz
ports-13e9223889844bff88fd41a911ed095fb075f2a5.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/libimobiledevice/Makefile9
-rw-r--r--comms/libimobiledevice/pkg-plist2
-rw-r--r--comms/py-libimobiledevice/Makefile7
3 files changed, 10 insertions, 8 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 0c30addf90f3..4efaa5b31fbd 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libimobiledevice
PORTVERSION= 1.1.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= comms
MASTER_SITES= http://www.${PORTNAME}.org/downloads/
@@ -13,13 +13,14 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES= pathfix pkgconfig tar:bzip2
+USES= libtool pathfix pkgconfig tar:bzip2
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= openssl_CFLAGS="-I${OPENSSLINC}" \
openssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
.if ${SLAVE_PORT} == "no"
diff --git a/comms/libimobiledevice/pkg-plist b/comms/libimobiledevice/pkg-plist
index 0c9abd23fad5..c92304e86cac 100644
--- a/comms/libimobiledevice/pkg-plist
+++ b/comms/libimobiledevice/pkg-plist
@@ -30,9 +30,9 @@ include/libimobiledevice/sbservices.h
include/libimobiledevice/screenshotr.h
include/libimobiledevice/webinspector.h
lib/libimobiledevice.a
-lib/libimobiledevice.la
lib/libimobiledevice.so
lib/libimobiledevice.so.4
+lib/libimobiledevice.so.4.0.1
libdata/pkgconfig/libimobiledevice-1.0.pc
man/man1/idevice_id.1.gz
man/man1/idevicebackup.1.gz
diff --git a/comms/py-libimobiledevice/Makefile b/comms/py-libimobiledevice/Makefile
index 8798435d32f0..5e83a99149ec 100644
--- a/comms/py-libimobiledevice/Makefile
+++ b/comms/py-libimobiledevice/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= comms python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,11 +21,12 @@ BUILD_WRKSRC= ${WRKSRC}/cython
INSTALL_WRKSRC= ${BUILD_WRKSRC}
PLIST_FILES= ${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.a \
- ${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.la \
${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.so
post-patch:
- @${REINPLACE_CMD} -e 's,../src/libimobiledevice.la,${LOCALBASE}/lib/libimobiledevice.la,' \
+ @${REINPLACE_CMD} \
+ -e 's,../src/libimobiledevice.la,-limobiledevice,' \
+ -e 's/$$(imobiledevice_la_DEPENDENCIES)//' \
${BUILD_WRKSRC}/Makefile.in
.include "${MASTERDIR}/Makefile"