aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2014-12-16 02:32:21 +0000
committerDiane Bruce <db@FreeBSD.org>2014-12-16 02:32:21 +0000
commit1d3eebb51315c446f0e4175f9b09efbbf79a93b0 (patch)
tree73f4e42fc98b7d4d977141bb30290abd3caee4fa /comms
parentbc051b59a6b3929958cc62e5c0c669636365ab06 (diff)
downloadports-1d3eebb51315c446f0e4175f9b09efbbf79a93b0.tar.gz
ports-1d3eebb51315c446f0e4175f9b09efbbf79a93b0.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/wsjt/Makefile19
-rw-r--r--comms/wsjt/files/patch-WsjtMod_specjt.py28
-rw-r--r--comms/wsjt/files/patch-wsjt.py19
3 files changed, 60 insertions, 6 deletions
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index 7ae6a5413d27..86315f1e32d0 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wsjt
VERSION= 9.1
-PORTREVISION= 7
+PORTREVISION= 8
DISTVERSION= ${VERSION}.r${SVN_REV}
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_LOCAL}
@@ -12,8 +12,6 @@ DISTNAME= wsjt-r${SVN_REV}
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Weak signal ham radio communication package
-BROKEN= Fails to configure
-
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float \
@@ -22,15 +20,16 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/scipy:${PORTSDIR}/science/py-scipy \
${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2 \
${PYNUMPY}
-ALL_TARGET= build
+USE_GCC= yes
USES= fortran gmake python tar:bzip2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-gfortran --prefix=${LOCALBASE} \
+CONFIGURE_ARGS= --enable-gfortran --prefix=${STAGEDIR}${LOCALBASE} \
--with-portaudio-include-dir=${LOCALBASE}/include/portaudio2 \
--with-portaudio-lib-dir=${LOCALBASE}/lib/portaudio2
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-LDFLAGS+= -shared
+# Adding this breaks configure
+#LDFLAGS+= -shared
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
VERSION=${VERSION}
@@ -68,4 +67,12 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${d} ${STAGEDIR}${DOCSDIR}
.endfor
+do-build:
+ (cd ${WRKSRC};${GMAKE})
+
+post-stage:
+ (cd ${STAGEDIR}${PREFIX} \
+ && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PREFIX} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;})
+
.include <bsd.port.post.mk>
diff --git a/comms/wsjt/files/patch-WsjtMod_specjt.py b/comms/wsjt/files/patch-WsjtMod_specjt.py
new file mode 100644
index 000000000000..6304ea084cde
--- /dev/null
+++ b/comms/wsjt/files/patch-WsjtMod_specjt.py
@@ -0,0 +1,28 @@
+--- WsjtMod/specjt.py.orig 2011-09-13 15:56:59.000000000 -0400
++++ WsjtMod/specjt.py 2014-12-15 21:26:06.000000000 -0500
+@@ -11,13 +11,9 @@
+ import cPickle
+ import tkMessageBox
+
+-try:
+- from numpy.oldnumeric import zeros, multiarray
+-# print "specjt importing from numpy"
+-except:
+- from Numeric import zeros, multiarray
+-# print "specjt importing from Numeric"
+-import Image, ImageTk, ImageDraw
++from numpy import zeros
++from numpy.core import multiarray
++from PIL import Image, ImageTk, ImageDraw
+ from palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ #import wsjt #Is this OK to do?
+@@ -76,7 +72,7 @@
+ ttot=0.0
+
+ c=Canvas()
+-a=zeros(225000,'s')
++##a=zeros(225000,'s')
+ im=Image.new('P',(750,300))
+ line0=Image.new('P',(750,1)) #Image fragment for top line of waterfall
+ draw=ImageDraw.Draw(im)
diff --git a/comms/wsjt/files/patch-wsjt.py b/comms/wsjt/files/patch-wsjt.py
new file mode 100644
index 000000000000..795b9c41ea65
--- /dev/null
+++ b/comms/wsjt/files/patch-wsjt.py
@@ -0,0 +1,19 @@
+--- wsjt.py.orig 2012-01-26 12:01:08.000000000 -0500
++++ wsjt.py 2014-12-15 21:21:29.000000000 -0500
+@@ -10,14 +10,9 @@
+ import os,time
+ from WsjtMod import Audio
+ from math import log10
+-try:
+- from numpy.oldnumeric import zeros
+-# print "importing from numpy"
+-except:
+- from Numeric import zeros
+-# print "importing from Numeric"
++from numpy import zeros
+ import dircache
+-import Image,ImageTk #, ImageDraw
++from PIL import Image, ImageTk #, ImageDraw
+ from WsjtMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import *