aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-09-07 08:28:13 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-09-07 08:28:13 +0000
commit25ec1c992759f2cf0f2f2f135852f52ff6f33f71 (patch)
tree15ec03df76d8478e2e7b95220ecfdaccce511127 /comms
parentf764b7ec744f962acee3e003bf02cb1e8cd25f2b (diff)
downloadports-25ec1c992759f2cf0f2f2f135852f52ff6f33f71.tar.gz
ports-25ec1c992759f2cf0f2f2f135852f52ff6f33f71.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/echolinux/Makefile4
-rw-r--r--comms/echolinux/files/patch-echogui_testgui.c10
-rw-r--r--comms/echolinux/files/patch-echogui_testgui_cb.c11
-rw-r--r--comms/echolinux/files/patch-echogui_testgui_main.c11
4 files changed, 34 insertions, 2 deletions
diff --git a/comms/echolinux/Makefile b/comms/echolinux/Makefile
index 8bd787d34fb2..de6ffc5ed527 100644
--- a/comms/echolinux/Makefile
+++ b/comms/echolinux/Makefile
@@ -7,7 +7,7 @@
PORTNAME= echolinux
PORTVERSION= 0.17a
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms hamradio
MASTER_SITES= SF/cqinet/${PORTNAME}/${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio Echolink client for UNIX
-LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms \
+LIB_DEPENDS= forms.2:${PORTSDIR}/x11-toolkits/xforms \
gsm.1:${PORTSDIR}/audio/gsm
post-patch:
diff --git a/comms/echolinux/files/patch-echogui_testgui.c b/comms/echolinux/files/patch-echogui_testgui.c
new file mode 100644
index 000000000000..914032560030
--- /dev/null
+++ b/comms/echolinux/files/patch-echogui_testgui.c
@@ -0,0 +1,10 @@
+--- echogui/testgui.c.orig 2011-09-06 14:21:37.000000000 +0200
++++ echogui/testgui.c 2011-09-06 14:21:42.000000000 +0200
+@@ -1,6 +1,6 @@
+ /* Form definition file generated with fdesign. */
+
+-#include <X11/forms.h>
++#include <forms.h>
+ #include <stdlib.h>
+ #include "testgui.h"
+
diff --git a/comms/echolinux/files/patch-echogui_testgui_cb.c b/comms/echolinux/files/patch-echogui_testgui_cb.c
new file mode 100644
index 000000000000..12bc35c1185a
--- /dev/null
+++ b/comms/echolinux/files/patch-echogui_testgui_cb.c
@@ -0,0 +1,11 @@
+--- echogui/testgui_cb.c.orig 2011-09-06 14:20:54.000000000 +0200
++++ echogui/testgui_cb.c 2011-09-06 14:20:57.000000000 +0200
+@@ -14,7 +14,7 @@
+ #include <linux/soundcard.h>
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+-#include <X11/forms.h>
++#include <forms.h>
+ #include <math.h>
+ #include <signal.h>
+ #include <pthread.h>
diff --git a/comms/echolinux/files/patch-echogui_testgui_main.c b/comms/echolinux/files/patch-echogui_testgui_main.c
new file mode 100644
index 000000000000..86a5b0f77f5e
--- /dev/null
+++ b/comms/echolinux/files/patch-echogui_testgui_main.c
@@ -0,0 +1,11 @@
+--- echogui/testgui_main.c.orig 2011-09-06 14:19:54.000000000 +0200
++++ echogui/testgui_main.c 2011-09-06 14:20:09.000000000 +0200
+@@ -16,7 +16,7 @@
+ #include <linux/soundcard.h>
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+-#include <X11/forms.h>
++#include <forms.h>
+ #include <string.h>
+ #include <math.h>
+ #include <pthread.h>