aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-03-17 21:18:53 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-03-17 21:19:04 +0000
commit41264e4b5372aa5eb38b79fec818309ca8368a11 (patch)
tree6cad7a88683f5ee12109fc25b4a58cd0e9121ce7 /comms
parent480f6c954278475e179da2b947b387b74e0dc84f (diff)
downloadports-41264e4b5372aa5eb38b79fec818309ca8368a11.tar.gz
ports-41264e4b5372aa5eb38b79fec818309ca8368a11.zip
comms/trustedqsl: Fix plist and port
* Remove obsolete dependencies (BDB 5 and (lib)lmdb) * Add USES= sqlite * Fix plist While at it, make some minor changes to Makefile Approved by: portmgr (blanket, build fix)
Diffstat (limited to 'comms')
-rw-r--r--comms/trustedqsl/Makefile29
-rw-r--r--comms/trustedqsl/pkg-plist10
2 files changed, 24 insertions, 15 deletions
diff --git a/comms/trustedqsl/Makefile b/comms/trustedqsl/Makefile
index 4d9ea5dc7977..4f972a98c572 100644
--- a/comms/trustedqsl/Makefile
+++ b/comms/trustedqsl/Makefile
@@ -1,10 +1,10 @@
PORTNAME= trustedqsl
DISTVERSION= 2.7.2
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://www.arrl.org/files/file/LoTW%20Instructions/ \
LOCAL/shurd
-DISTNAME= tqsl-${PORTVERSION}
+DISTNAME= tqsl-${DISTVERSION}
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Amateur Radio Station electronic trusted logbook
@@ -16,30 +16,29 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
LIB_DEPENDS= libcurl.so:ftp/curl \
- libexpat.so:textproc/expat2 \
- liblmdb.so:databases/lmdb
+ libexpat.so:textproc/expat2
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-USES= bdb:5+ cmake compiler:c++11-lib pkgconfig ssl
-CMAKE_ARGS= -DBDB_PREFIX=${LOCALBASE}
-CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR:PATH="share/man"
+USES= cmake compiler:c++11-lib pkgconfig ssl sqlite
USE_WX= 3.2
USE_LDCONFIG= yes
-OPTIONS_DEFINE= GEN_CRQ LOAD_CERT STATION_LOC CONVERTER
-GEN_CRQ_DESC= Build gen_crq
-LOAD_CERT_DESC= Build load_cert
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR:PATH="share/man"
+
+OPTIONS_DEFINE= GEN_CRQ LOAD_CERT STATION_LOC CONVERTER
+OPTIONS_SUB= yes
+
+GEN_CRQ_DESC= Build gen_crq
+LOAD_CERT_DESC= Build load_cert
STATION_LOC_DESC= Build station_loc
-CONVERTER_DESC= Build converter
+CONVERTER_DESC= Build converter
GEN_CRQ_CMAKE_ON= -DBUILD_GENCRQ=ON
LOAD_CERT_CMAKE_ON= -DBUILD_LOADCERT=ON
STATION_LOC_CMAKE_ON= -DBUILD_STATIONLOC=ON
CONVERTER_CMAKE_ON= -DBUILD_CONVERTER=ON
-OPTIONS_SUB= yes
-
post-install-GEN_CRQ-on:
${INSTALL_PROGRAM} ${WRKSRC}/src/gen_crq ${STAGEDIR}${PREFIX}/bin
post-install-LOAD_CERT-on:
diff --git a/comms/trustedqsl/pkg-plist b/comms/trustedqsl/pkg-plist
index 991a81385503..deb283f95236 100644
--- a/comms/trustedqsl/pkg-plist
+++ b/comms/trustedqsl/pkg-plist
@@ -131,6 +131,13 @@ share/TrustedQSL/help/tqslapp/update.htm
share/TrustedQSL/help/tqslapp/update1.bmp
share/TrustedQSL/help/tqslapp/update2.bmp
share/TrustedQSL/languages.dat
+share/applications/org.arrl.trustedqsl.desktop
+share/icons/hicolor/128x128/apps/org.arrl.trustedqsl.png
+share/icons/hicolor/16x16/apps/org.arrl.trustedqsl.png
+share/icons/hicolor/32x32/apps/org.arrl.trustedqsl.png
+share/icons/hicolor/48x48/apps/org.arrl.trustedqsl.png
+share/icons/hicolor/64x64/apps/org.arrl.trustedqsl.png
+share/locale/ca_ES/LC_MESSAGES/tqslapp.mo
share/locale/de/LC_MESSAGES/tqslapp.mo
share/locale/es/LC_MESSAGES/tqslapp.mo
share/locale/fi/LC_MESSAGES/tqslapp.mo
@@ -138,8 +145,11 @@ share/locale/fr/LC_MESSAGES/tqslapp.mo
share/locale/hi_IN/LC_MESSAGES/tqslapp.mo
share/locale/it/LC_MESSAGES/tqslapp.mo
share/locale/ja/LC_MESSAGES/tqslapp.mo
+share/locale/pl_PL/LC_MESSAGES/tqslapp.mo
share/locale/pt/LC_MESSAGES/tqslapp.mo
share/locale/ru/LC_MESSAGES/tqslapp.mo
+share/locale/sv_SE/LC_MESSAGES/tqslapp.mo
+share/locale/tr_TR/LC_MESSAGES/tqslapp.mo
share/locale/zh_CN/LC_MESSAGES/tqslapp.mo
share/locale/zh_TW/LC_MESSAGES/tqslapp.mo
share/man/man5/tqsl.5.gz