aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /comms
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/anyremote/Makefile2
-rw-r--r--comms/minicom/Makefile2
-rw-r--r--comms/obexapp/Makefile3
3 files changed, 5 insertions, 2 deletions
diff --git a/comms/anyremote/Makefile b/comms/anyremote/Makefile
index c1ac0111d880..970638453d8f 100644
--- a/comms/anyremote/Makefile
+++ b/comms/anyremote/Makefile
@@ -15,7 +15,7 @@ USES= pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
OPTIONS_DEFINE= DOCS DBUS X11
OPTIONS_DEFAULT= DBUS X11
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 033f4b1f02ed..5471464ef947 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock \
--enable-dfl-port=/dev/cuau0
-MAKE_ARGS+= LIBS+="-liconv -lcurses"
+MAKE_ARGS+= LIBS+="${ICONV_LIB} -lcurses"
MAN1= minicom.1 runscript.1 ascii-xfr.1 xminicom.1
diff --git a/comms/obexapp/Makefile b/comms/obexapp/Makefile
index 2062912c5b45..a8d7bbf7b60a 100644
--- a/comms/obexapp/Makefile
+++ b/comms/obexapp/Makefile
@@ -26,4 +26,7 @@ MAKE_ENV+= NO_MAN=yes
MAKE_ENV+= NO_WERROR=yes
+post-patch:
+ @${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/Makefile
+
.include <bsd.port.mk>