aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2012-11-10 16:56:40 +0000
committerDiane Bruce <db@FreeBSD.org>2012-11-10 16:56:40 +0000
commit6ec5eaf60cbb448c127dad65fdc5a0df1713f176 (patch)
tree6ce5995a70aeebd313cbc53bcf89f863066977c1 /comms
parentada2e37f3b98364c231f20fbb3e3910ef91934ba (diff)
downloadports-6ec5eaf60cbb448c127dad65fdc5a0df1713f176.tar.gz
ports-6ec5eaf60cbb448c127dad65fdc5a0df1713f176.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/soundmodem/Makefile16
-rw-r--r--comms/soundmodem/distinfo4
-rw-r--r--comms/soundmodem/files/patch-configapp_src_main.c6
-rw-r--r--comms/soundmodem/files/patch-configure26
-rw-r--r--comms/soundmodem/files/patch-libmisc_getopt.h12
-rw-r--r--comms/soundmodem/files/patch-pammodem_meas.c25
-rw-r--r--comms/soundmodem/files/patch-pskmodem_measpsk.c11
-rw-r--r--comms/soundmodem/files/patch-soundcard_main.c6
-rw-r--r--comms/soundmodem/files/patch-soundcard_ptt.c65
-rw-r--r--comms/soundmodem/pkg-plist12
10 files changed, 43 insertions, 140 deletions
diff --git a/comms/soundmodem/Makefile b/comms/soundmodem/Makefile
index 2adb28dd4646..8ebc3dc99314 100644
--- a/comms/soundmodem/Makefile
+++ b/comms/soundmodem/Makefile
@@ -1,13 +1,7 @@
-# ports collection makefile for: soundmodem
-# Date created: 4 November 2006
-# Whom: db
-#
# $FreeBSD$
-#
PORTNAME= soundmodem
-PORTVERSION= 0.10
-PORTREVISION= 3
+PORTVERSION= 0.17
CATEGORIES= comms hamradio
MASTER_SITES= http://www.baycom.org/~tom/ham/soundmodem/ \
http://chronos.org.uk/distfiles/
@@ -21,23 +15,19 @@ CONFIGURE_ARGS= --disable-alsatest
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_GMAKE= yes
HAS_CONFIGURE= yes
-ONLY_FOR_ARCHS= i386
-USE_GNOME= gtk12 libxml
+USE_GNOME= gtk20 libxml2
MAN8= soundmodem.8 soundmodemconfig.8
-PLIST_FILES= bin/soundmodemconfig etc/rc.d/soundmodem \
- include/modem.h include/simd.h sbin/soundmodem
pre-patch:
@${CP} ${FILESDIR}/soundmodem ${WRKSRC}
post-patch:
- ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/soundcard/soundmodem.8 \
${WRKSRC}/soundcard/main.c \
${WRKSRC}/configapp/src/soundmodemconfig.8 \
${WRKSRC}/configapp/src/main.c \
${WRKSRC}/soundmodem
-
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/soundmodem ${PREFIX}/etc/rc.d
diff --git a/comms/soundmodem/distinfo b/comms/soundmodem/distinfo
index 4441aa60e2a5..3f5aa3f8b545 100644
--- a/comms/soundmodem/distinfo
+++ b/comms/soundmodem/distinfo
@@ -1,2 +1,2 @@
-SHA256 (soundmodem-0.10.tar.gz) = e7a42c413a180b873ae76b2c252904a3e34c9807c2604f2315426443d9e28627
-SIZE (soundmodem-0.10.tar.gz) = 491112
+SHA256 (soundmodem-0.17.tar.gz) = 741cd31b645340e6371a5592452f29aa03991943c467d03d4da9353b8dbb5edb
+SIZE (soundmodem-0.17.tar.gz) = 486024
diff --git a/comms/soundmodem/files/patch-configapp_src_main.c b/comms/soundmodem/files/patch-configapp_src_main.c
index 165747ba60c5..375013c66000 100644
--- a/comms/soundmodem/files/patch-configapp_src_main.c
+++ b/comms/soundmodem/files/patch-configapp_src_main.c
@@ -1,6 +1,6 @@
---- configapp/src/main.c.orig Sun Nov 5 21:45:29 2006
-+++ configapp/src/main.c Sun Nov 5 21:45:50 2006
-@@ -358,7 +358,7 @@
+--- configapp/src/main.c.orig 2010-10-30 11:49:09.000000000 -0500
++++ configapp/src/main.c 2012-11-05 17:20:25.000000000 -0500
+@@ -359,7 +359,7 @@
#else /* WIN32 */
static xmlDocPtr doc = NULL;
diff --git a/comms/soundmodem/files/patch-configure b/comms/soundmodem/files/patch-configure
index d34e203d90db..34a3253c92c1 100644
--- a/comms/soundmodem/files/patch-configure
+++ b/comms/soundmodem/files/patch-configure
@@ -1,22 +1,20 @@
---- configure.orig Tue Sep 12 14:52:56 2006
-+++ configure Tue Sep 12 16:48:30 2006
-@@ -7912,7 +7912,8 @@
+--- configure.orig 2012-11-07 05:55:37.000000000 -0500
++++ configure 2012-11-07 07:02:34.000000000 -0500
+@@ -844,7 +844,7 @@
+ psdir='${docdir}'
+ libdir='${exec_prefix}/lib'
+ localedir='${datarootdir}/locale'
+-mandir='${datarootdir}/man'
++mandir='${prefix}/man'
+
+ ac_prev=
+ ac_dashdash=
+@@ -7265,7 +7265,7 @@
int
main ()
{
-
+#include <stdio.h>
-+printf("RUNNING a conftest!\n");
/* ensure backward compatibility */
#if !defined(SND_LIB_MAJOR) && defined(SOUNDLIB_VERSION_MAJOR)
#define SND_LIB_MAJOR SOUNDLIB_VERSION_MAJOR
-@@ -7979,9 +7980,6 @@
-
- echo "$as_me:$LINENO: result: not present." >&5
- echo "${ECHO_T}not present." >&6
-- { { echo "$as_me:$LINENO: error: Sufficiently new version of libasound not found." >&5
--echo "$as_me: error: Sufficiently new version of libasound not found." >&2;}
-- { (exit 1); exit 1; }; }
- alsa_found=no
-
- fi
diff --git a/comms/soundmodem/files/patch-libmisc_getopt.h b/comms/soundmodem/files/patch-libmisc_getopt.h
deleted file mode 100644
index 56910e4843cc..000000000000
--- a/comms/soundmodem/files/patch-libmisc_getopt.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- libmisc/getopt.h.orig Mon Sep 18 22:42:44 2006
-+++ libmisc/getopt.h Tue Sep 19 17:43:44 2006
-@@ -101,7 +101,9 @@
- errors, only prototype getopt for the GNU C library. */
- extern int getopt (int argc, char *const *argv, const char *shortopts);
- #else /* not __GNU_LIBRARY__ */
-+#if 0
- extern int getopt ();
-+#endif
- #endif /* not __GNU_LIBRARY__ */
- extern int getopt_long (int argc, char *const *argv, const char *shortopts,
- const struct option *longopts, int *longind);
diff --git a/comms/soundmodem/files/patch-pammodem_meas.c b/comms/soundmodem/files/patch-pammodem_meas.c
deleted file mode 100644
index 78d6d07aed8b..000000000000
--- a/comms/soundmodem/files/patch-pammodem_meas.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- pammodem/meas.c.orig Tue Sep 19 17:44:23 2006
-+++ pammodem/meas.c Tue Sep 19 17:51:00 2006
-@@ -32,6 +32,8 @@
- #ifdef HAVE_STROPTS_H
- #include <stropts.h>
- #endif
-+#include <sys/param.h>
-+#include <sys/types.h>
- #ifdef HAVE_SYS_CONF_H
- #include <sys/conf.h>
- #endif
-@@ -45,12 +47,12 @@
- #include <sys/soundcard.h>
- #endif
-
--#include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <poll.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <strings.h>
- #include <unistd.h>
- #include <signal.h>
diff --git a/comms/soundmodem/files/patch-pskmodem_measpsk.c b/comms/soundmodem/files/patch-pskmodem_measpsk.c
deleted file mode 100644
index 166136953056..000000000000
--- a/comms/soundmodem/files/patch-pskmodem_measpsk.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- pskmodem/measpsk.c.orig Tue Sep 19 17:51:37 2006
-+++ pskmodem/measpsk.c Tue Sep 19 17:52:15 2006
-@@ -32,6 +32,8 @@
- #ifdef HAVE_STROPTS_H
- #include <stropts.h>
- #endif
-+#include <sys/param.h>
-+#include <sys/types.h>
- #ifdef HAVE_SYS_CONF_H
- #include <sys/conf.h>
- #endif
diff --git a/comms/soundmodem/files/patch-soundcard_main.c b/comms/soundmodem/files/patch-soundcard_main.c
index d6d26ae93b4a..7fb03d7960ff 100644
--- a/comms/soundmodem/files/patch-soundcard_main.c
+++ b/comms/soundmodem/files/patch-soundcard_main.c
@@ -1,6 +1,6 @@
---- soundcard/main.c.orig Sun Nov 5 21:44:34 2006
-+++ soundcard/main.c Sun Nov 5 21:44:53 2006
-@@ -354,7 +354,7 @@
+--- soundcard/main.c.orig 2010-10-30 11:49:10.000000000 -0500
++++ soundcard/main.c 2012-11-05 17:22:52.000000000 -0500
+@@ -358,7 +358,7 @@
{ "daemonize", 0, 0, 'D' },
{ 0, 0, 0, 0 }
};
diff --git a/comms/soundmodem/files/patch-soundcard_ptt.c b/comms/soundmodem/files/patch-soundcard_ptt.c
index 92ba9cf3cb4f..de073fc48cdb 100644
--- a/comms/soundmodem/files/patch-soundcard_ptt.c
+++ b/comms/soundmodem/files/patch-soundcard_ptt.c
@@ -1,60 +1,11 @@
---- soundcard/ptt.c.orig Sat Nov 9 10:31:53 2002
-+++ soundcard/ptt.c Mon Apr 23 10:24:36 2007
-@@ -48,6 +48,9 @@
-
- #ifdef HAVE_LINUX_PPDEV_H
- #include <linux/ppdev.h>
-+#elif defined(__FreeBSD__)
-+#include <dev/ppbus/ppi.h>
-+#include <dev/ppbus/ppbconf.h>
- #else
- #include "ppdev.h"
+--- soundcard/ptt.c.orig 2012-11-07 11:05:55.000000000 -0500
++++ soundcard/ptt.c 2012-11-07 11:06:15.000000000 -0500
+@@ -176,7 +176,7 @@
#endif
-@@ -62,7 +65,11 @@
-
- struct modemparams pttparams[] = {
- { "file", "PTT Driver", "Path name of the serial or parallel port driver for outputting PTT", "none", MODEMPAR_COMBO,
-+#ifdef __FreeBSD__
-+ { c: { { "none", "/dev/ttyd0", "/dev/ttyd1", "/dev/ppi0", "/dev/ppi1" } } } },
-+#else
- { c: { { "none", "/dev/ttyS0", "/dev/ttyS1", "/dev/parport0", "/dev/parport1" } } } },
-+#endif
- { NULL }
- };
-@@ -87,7 +94,11 @@
- if (!ioctl(fd, TIOCMBIC, &y)) {
- state->fd = fd;
- state->mode = serport;
-+#ifdef __FreeBSD__
-+ } else if (!ioctl(fd, PPISDATA, &x)) {
-+#else
- } else if (!ioctl(fd, PPCLAIM, 0) && !ioctl(fd, PPRDATA, &x)) {
-+#endif
- state->fd = fd;
- state->mode = parport;
- } else {
-@@ -122,7 +133,11 @@
- #endif
- } else if (state->mode == parport) {
- reg = state->ptt | (state->dcd << 1);
-+#ifdef __FreeBSD__
-+ ioctl(state->fd, PPISDATA, &reg);
-+#else
- ioctl(state->fd, PPWDATA, &reg);
-+#endif
+ logprintf(MLOG_INFO, "Opening PTT device \"%s\"\n", path);
+- if ((fd = open(path, O_RDWR, 0)) < 0) {
++ if ((fd = open(path, O_RDWR|O_NONBLOCK, 0)) < 0) {
+ logprintf(MLOG_ERROR, "Cannot open PTT device \"%s\"\n", path);
+ return -1;
}
- }
-
-@@ -148,7 +163,11 @@
- #endif
- } else if (state->mode == parport) {
- reg = state->ptt | (state->dcd << 1);
-+#ifdef __FreeBSD__
-+ ioctl(state->fd, PPISDATA, &reg);
-+#else
- ioctl(state->fd, PPWDATA, &reg);
-+#endif
- }
- }
-
diff --git a/comms/soundmodem/pkg-plist b/comms/soundmodem/pkg-plist
new file mode 100644
index 000000000000..24ad6a23356c
--- /dev/null
+++ b/comms/soundmodem/pkg-plist
@@ -0,0 +1,12 @@
+bin/soundmodemconfig
+sbin/soundmodem
+etc/rc.d/soundmodem
+include/modem.h
+include/simd.h
+share/locale/fr/LC_MESSAGES/soundmodem.mo
+share/locale/sv/LC_MESSAGES/soundmodem.mo
+@dirrmtry share/locale/fr/LC_MESSAGES
+@dirrmtry share/locale/sv/LC_MESSAGES
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/sv
+@dirrmtry share/locale