aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-12 22:31:11 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-13 14:24:16 +0000
commit7402592f93319c5ceb8c55d1d70b47f603823d90 (patch)
tree40e0a75a83ab6373be788fbec0aa0e30025d1a76 /comms
parent6b2ed15fd6f564ccba7fa484786969318e7b7548 (diff)
downloadports-7402592f93319c5ceb8c55d1d70b47f603823d90.tar.gz
ports-7402592f93319c5ceb8c55d1d70b47f603823d90.zip
Diffstat (limited to 'comms')
-rw-r--r--comms/xlog/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/comms/xlog/Makefile b/comms/xlog/Makefile
index b9255fc169c7..3c8190742154 100644
--- a/comms/xlog/Makefile
+++ b/comms/xlog/Makefile
@@ -4,7 +4,7 @@ PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= SAVANNAH
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Amateur Radio logging application
WWW= https://xlog.nongnu.org/
@@ -12,23 +12,31 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhamlib.so:comms/hamlib \
+ libharfbuzz.so:print/harfbuzz \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= compiler:c11 gnome pkgconfig shared-mime-info
+USES= compiler:c11 gnome pkgconfig shared-mime-info
USE_GNOME= cairo gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mime-update
CONFIGURE_ENV+= ac_cv_c_compiler_gnu=no
+DESKTOP_ENTRIES="${PORTNAME}" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Utility;" false
+
OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes
+
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
-DESKTOP_ENTRIES="${PORTNAME}" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Utility;" false
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+CFLAGS+= -Wno-error=deprecated-non-prototype
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>