aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2010-05-15 13:02:49 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2010-05-15 13:02:49 +0000
commit7f004430b13467ed636b62e9500ce33de91fc8ad (patch)
treeff8d6750f71eb87140f2aa57a761be4e2b316399 /comms
parent1dc980843cf6373247ef344d4ed09ab290312e11 (diff)
downloadports-7f004430b13467ed636b62e9500ce33de91fc8ad.tar.gz
ports-7f004430b13467ed636b62e9500ce33de91fc8ad.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/gammu-python/Makefile5
-rw-r--r--comms/gammu/Makefile7
-rw-r--r--comms/gammu/pkg-plist5
3 files changed, 12 insertions, 5 deletions
diff --git a/comms/gammu-python/Makefile b/comms/gammu-python/Makefile
index 03fb243ca0c5..9061fa3c47b8 100644
--- a/comms/gammu-python/Makefile
+++ b/comms/gammu-python/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
PKGNAMESUFFIX= -python
CONFLICTS= gammu-[1-9]* gammu-devel-[1-9]*
@@ -14,8 +13,4 @@ WITH_PYTHON_GAMMU= yes
MASTERDIR= ${.CURDIR}/../gammu
-post-install:
- @${PYTHON_CMD} ${PYTHON_SITELIBDIR}/${PORTNAME}/__init__.py
-
-
.include "${MASTERDIR}/Makefile"
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 710dd11fd47c..ed62589e0372 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -44,6 +44,13 @@ MAN7= gammu-smsd-files.7 gammu-smsd-mysql.7 gammu-smsd-pgsql.7 \
gammu-smsd-dbi.7 gammu-smsd-tables.7
.endif
+.if defined(WITH_PYTHON_GAMMU)
+post-install:
+.for opt in -Qold -O
+ ${PYTHON_CMD} ${opt} -m compileall -l ${PYTHONPREFIX_SITELIBDIR}/gammu
+.endfor
+.endif
+
.include <bsd.port.pre.mk>
post-patch:
diff --git a/comms/gammu/pkg-plist b/comms/gammu/pkg-plist
index 76bfa4849071..6cb650c88a2c 100644
--- a/comms/gammu/pkg-plist
+++ b/comms/gammu/pkg-plist
@@ -38,8 +38,13 @@ libdata/pkgconfig/gammu.pc
libdata/pkgconfig/gammu-smsd.pc
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/__init__.py
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/__init__.pyc
+%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/__init__.pyo
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/_gammu.so
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Data.py
+%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Data.pyc
+%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Data.pyo
%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Worker.py
+%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Worker.pyc
+%%WITH_PYTHON_GAMMU%%%%PYTHON_SITELIBDIR%%/gammu/Worker.pyo
@dirrm include/gammu
%%WITH_PYTHON_GAMMU%%@dirrm %%PYTHON_SITELIBDIR%%/gammu