aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-10-15 14:55:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-10-15 14:55:14 +0000
commit7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae (patch)
treed30bee8baf5be305289898828fb58299162e2f54 /comms
parentb3175cfda759707ed077a4649b634cad8934eb1b (diff)
downloadports-7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae.tar.gz
ports-7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae.zip
Drop 8 support.
With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3694
Notes
Notes: svn path=/head/; revision=399346
Diffstat (limited to 'comms')
-rw-r--r--comms/dabstick-radio/Makefile4
-rw-r--r--comms/hylafax/Makefile7
-rw-r--r--comms/lysdr/Makefile1
-rw-r--r--comms/lysdr/files/Makefile3
-rw-r--r--comms/lysdr/files/cexp.c46
-rw-r--r--comms/remserial/files/patch-stty.c6
6 files changed, 3 insertions, 64 deletions
diff --git a/comms/dabstick-radio/Makefile b/comms/dabstick-radio/Makefile
index ad6d8d223754..5d7d13b1ef3d 100644
--- a/comms/dabstick-radio/Makefile
+++ b/comms/dabstick-radio/Makefile
@@ -32,9 +32,7 @@ ONLY_FOR_ARCHS_REASON= uses MMX and SSE2 instructions
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-.if (${OSVERSION} >= 900014) && exists(${DESTDIR}/usr/bin/clang)
+.if exists(${DESTDIR}/usr/bin/clang)
CC= clang
CXX= clang++
CPP= clang-cpp
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 2b5b5b8c49bd..22ab0dfd4992 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -24,7 +24,8 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-TIFFINC="-I${LOCALBASE}/include" \
--with-GCOPTS=" " --with-GCXXOPTS=" " \
--with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=-I/usr/include \
- --with-DIR_HTML="${DOCSDIR}"
+ --with-DIR_HTML="${DOCSDIR}" \
+ --with-GETTY=SysV
CFLAGS+= -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -Wall -L${LOCALBASE}/lib
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
MAKE_ENV+= ROOT=${STAGEDIR}
@@ -66,10 +67,6 @@ PLIST_SUB+= HYLAFAX_SPOOL=${HYLAFAX_SPOOL}
CONFIGURE_ARGS+=--nointeractive
.endif
-.if ${OSVERSION} >= 900007
-CONFIGURE_ARGS+= --with-GETTY=SysV
-.endif
-
post-patch:
${REINPLACE_CMD} \
-e 's,/usr/local,${LOCALBASE},g' \
diff --git a/comms/lysdr/Makefile b/comms/lysdr/Makefile
index 3e4083ceab8b..75b6f931ef82 100644
--- a/comms/lysdr/Makefile
+++ b/comms/lysdr/Makefile
@@ -23,7 +23,6 @@ PLIST_FILES= bin/lysdr
post-patch:
${CP} ${FILESDIR}/Makefile ${WRKSRC}
- ${CP} ${FILESDIR}/cexp.c ${WRKSRC}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/lysdr ${STAGEDIR}${PREFIX}/bin/lysdr
diff --git a/comms/lysdr/files/Makefile b/comms/lysdr/files/Makefile
index 6903040952f2..70d4ede8d64a 100644
--- a/comms/lysdr/files/Makefile
+++ b/comms/lysdr/files/Makefile
@@ -6,9 +6,6 @@ CFLAGS+= `pkg-config -cflags ${PACKAGES}`
LDFLAGS+= `pkg-config -libs ${PACKAGES}` -lm
SRCS= gui.c sdr.c filter.c audio_jack.c smeter.c waterfall.c lysdr.c
-.if ${OSVERSION} < 900000
-SRCS+= cexp.c
-.endif
PROG= lysdr
WITHOUT_MAN= yes
diff --git a/comms/lysdr/files/cexp.c b/comms/lysdr/files/cexp.c
deleted file mode 100644
index 595e913be5d8..000000000000
--- a/comms/lysdr/files/cexp.c
+++ /dev/null
@@ -1,46 +0,0 @@
-/* $NetBSD: cexp.c,v 1.1 2007/08/20 16:01:34 drochner Exp $ */
-
-/*-
- * Copyright (c) 2007 The NetBSD Foundation, Inc.
- * All rights reserved.
- *
- * This code is derived from software written by Stephen L. Moshier.
- * It is redistributed by the NetBSD Foundation by permission of the author.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
- * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
- * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
-#include <complex.h>
-#include <math.h>
-
-double complex
-cexp(double complex z)
-{
- double complex w;
- double r, x, y;
-
- x = creal(z);
- y = cimag(z);
- r = exp(x);
- w = r * cos(y) + r * sin(y) * I;
- return w;
-}
diff --git a/comms/remserial/files/patch-stty.c b/comms/remserial/files/patch-stty.c
index ec2a3e8298c5..89e948cc1502 100644
--- a/comms/remserial/files/patch-stty.c
+++ b/comms/remserial/files/patch-stty.c
@@ -27,12 +27,6 @@
+#define VT0 0000000
+#define VT1 0040000
+#define VTDLY 0040000
-+#if OSVERSION < 800000
-+/* for older FreeBSD versions */
-+#define TAB0 0000000
-+#define TAB3 0014000
-+#define TABDLY 0014000
-+#endif
+#endif
+
extern int errno;