aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-11-21 18:18:34 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-11-21 18:18:34 +0000
commit93b90c42e3b7f15cc9ca20b156ba5b397f96c225 (patch)
treec1a26565b06260ee1f1991683fed1f3d28747a6a /comms
parentf604ad305535c0350cac8605a856c83084c5e2df (diff)
downloadports-93b90c42e3b7f15cc9ca20b156ba5b397f96c225.tar.gz
ports-93b90c42e3b7f15cc9ca20b156ba5b397f96c225.zip
Only define USE_LDCONFIG in devel/qt5-core
All the qt5-ports share the same library directory. devel/qt5-core is dependet on by all others. So there is no need to add identical entries to libdata/ldconfig, and restart the ldconfig service on every pkg change of those ports. Reported by: bapt Reviewed by: bapt Differential Revision: https://reviews.freebsd.org/D27224
Notes
Notes: svn path=/head/; revision=556007
Diffstat (limited to 'comms')
-rw-r--r--comms/qt5-connectivity/Makefile2
-rw-r--r--comms/qt5-sensors/Makefile2
-rw-r--r--comms/qt5-serialbus/Makefile2
-rw-r--r--comms/qt5-serialport/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/comms/qt5-connectivity/Makefile b/comms/qt5-connectivity/Makefile
index 95dad0a7d9aa..c367555173af 100644
--- a/comms/qt5-connectivity/Makefile
+++ b/comms/qt5-connectivity/Makefile
@@ -2,6 +2,7 @@
PORTNAME= connectivity
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
@@ -11,6 +12,5 @@ COMMENT= Qt connectivity (Bluetooth/NFC) module
USES= compiler:c++11-lang qmake qt-dist:5,connectivity
USE_QT= concurrent core declarative buildtools_build
-USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/comms/qt5-sensors/Makefile b/comms/qt5-sensors/Makefile
index 556e740ec743..053f2c429e70 100644
--- a/comms/qt5-sensors/Makefile
+++ b/comms/qt5-sensors/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sensors
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
@@ -11,6 +12,5 @@ COMMENT= Qt sensors module
USES= compiler:c++11-lang qmake:norecursive qt-dist:5,sensors
USE_QT= core declarative buildtools_build
-USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/comms/qt5-serialbus/Makefile b/comms/qt5-serialbus/Makefile
index 0b7962796a7a..117b4eea2396 100644
--- a/comms/qt5-serialbus/Makefile
+++ b/comms/qt5-serialbus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= serialbus
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
@@ -10,7 +11,6 @@ COMMENT= Qt functions to access industrial bus systems
USES= compiler:c++11-lib qmake qt-dist:5,serialbus
USE_QT= core network serialport buildtools_build
-USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
QT_BINARIES= yes
.include <bsd.port.mk>
diff --git a/comms/qt5-serialport/Makefile b/comms/qt5-serialport/Makefile
index 57d113647247..b023c386cedc 100644
--- a/comms/qt5-serialport/Makefile
+++ b/comms/qt5-serialport/Makefile
@@ -2,6 +2,7 @@
PORTNAME= serialport
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
@@ -10,6 +11,5 @@ COMMENT= Qt functions to access serial ports
USES= compiler:c++11-lang libtool qmake qt-dist:5,serialport
USE_QT= core buildtools_build
-USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>