aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-28 23:32:46 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-28 23:32:46 +0000
commit98093689ccdda12848910bb8a48fef80a6ac6a4b (patch)
treeb99ffdfbe85bfe78576234e6c4f23422b347cd2c /comms
parentd2953d78858d7d20e68d37b6638a814d4aa636bb (diff)
downloadports-98093689ccdda12848910bb8a48fef80a6ac6a4b.tar.gz
ports-98093689ccdda12848910bb8a48fef80a6ac6a4b.zip
New port: comms/libcodec2.
Codec 2 is an open source (LGPL licensed) speech codec for 3200 bit/s and below. WWW: http://www.rowetel.com/codec2.html PR: 203145 Submitted by: takefu@airport.fm
Notes
Notes: svn path=/head/; revision=409782
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/libcodec2/Makefile20
-rw-r--r--comms/libcodec2/distinfo2
-rw-r--r--comms/libcodec2/pkg-descr4
-rw-r--r--comms/libcodec2/pkg-plist28
5 files changed, 55 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 20e939993c35..9cdbfd3fd75e 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -79,6 +79,7 @@
SUBDIR += klog
SUBDIR += kremotecontrol
SUBDIR += kvasd
+ SUBDIR += libcodec2
SUBDIR += libconcord
SUBDIR += libfap
SUBDIR += libfec
diff --git a/comms/libcodec2/Makefile b/comms/libcodec2/Makefile
new file mode 100644
index 000000000000..8fc569cdccfc
--- /dev/null
+++ b/comms/libcodec2/Makefile
@@ -0,0 +1,20 @@
+# Created by: Takefu <takefu@airport.fm>
+# $FreeBSD$
+
+PORTNAME= libcodec2
+PORTVERSION= 0.4.1
+CATEGORIES= comms hamradio
+MASTER_SITES= http://files.freedv.org/codec2/
+DISTNAME= codec2-${PORTVERSION}
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Codec 2 speech codec
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speexdsp
+
+USE_LDCONFIG= yes
+USES= cmake:outsource
+
+.include <bsd.port.mk>
diff --git a/comms/libcodec2/distinfo b/comms/libcodec2/distinfo
new file mode 100644
index 000000000000..6cc3c6f8afa0
--- /dev/null
+++ b/comms/libcodec2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (codec2-0.4.1.tar.gz) = 2fe3b9410a98c72b1420eeda8bb3656c176a6e6a2813e55476a7779a216990bb
+SIZE (codec2-0.4.1.tar.gz) = 11100891
diff --git a/comms/libcodec2/pkg-descr b/comms/libcodec2/pkg-descr
new file mode 100644
index 000000000000..ef6eeece1eac
--- /dev/null
+++ b/comms/libcodec2/pkg-descr
@@ -0,0 +1,4 @@
+Codec 2 is an open source (LGPL licensed) speech codec for 3200 bit/s
+and below.
+
+WWW: http://www.rowetel.com/codec2.html
diff --git a/comms/libcodec2/pkg-plist b/comms/libcodec2/pkg-plist
new file mode 100644
index 000000000000..8b2bc77c286f
--- /dev/null
+++ b/comms/libcodec2/pkg-plist
@@ -0,0 +1,28 @@
+bin/c2dec
+bin/c2demo
+bin/c2enc
+bin/c2sim
+bin/fdmdv_demod
+bin/fdmdv_get_test_bits
+bin/fdmdv_interleave
+bin/fdmdv_mod
+bin/fdmdv_put_test_bits
+bin/fec_dec
+bin/fec_enc
+bin/fm_demod
+bin/insert_errors
+include/codec2/codec2.h
+include/codec2/codec2_cohpsk.h
+include/codec2/codec2_fdmdv.h
+include/codec2/codec2_fifo.h
+include/codec2/codec2_fm.h
+include/codec2/comp.h
+include/codec2/comp_prim.h
+include/codec2/freedv_api.h
+include/codec2/freedv_api_internal.h
+include/codec2/golay23.h
+include/codec2/kiss_fft.h
+include/codec2/modem_stats.h
+include/codec2/varicode.h
+lib/libcodec2.so
+lib/libcodec2.so.0.4