aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2012-08-14 23:14:35 +0000
committerDiane Bruce <db@FreeBSD.org>2012-08-14 23:14:35 +0000
commitb5cc599cbf4c14549ce59ea7454b97e57569cf09 (patch)
treee750f629249fb3152d97b3c87f00e23227973a70 /comms
parent6eca0580b7505e72d8eb5b9d67f877d13fb135df (diff)
downloadports-b5cc599cbf4c14549ce59ea7454b97e57569cf09.tar.gz
ports-b5cc599cbf4c14549ce59ea7454b97e57569cf09.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/tqsllib/Makefile46
-rw-r--r--comms/tqsllib/distinfo2
-rw-r--r--comms/tqsllib/pkg-descr7
-rw-r--r--comms/tqsllib/pkg-plist19
5 files changed, 75 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 19190ca43d24..013e9e2aedd6 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -149,6 +149,7 @@
SUBDIR += tkhylafax
SUBDIR += tkscanfax
SUBDIR += tlf
+ SUBDIR += tqsllib
SUBDIR += trustedqsl
SUBDIR += twpsk
SUBDIR += uarduno
diff --git a/comms/tqsllib/Makefile b/comms/tqsllib/Makefile
new file mode 100644
index 000000000000..7c159cc7ef44
--- /dev/null
+++ b/comms/tqsllib/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: tqsllib
+# Date created: 10th August 2012
+# Whom: Diane Bruce <db@db.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tqsllib
+PORTVERSION= 2.2
+CATEGORIES= comms hamradio
+MASTER_SITES= SF/trustedqsl/tqsllib/V2.2/
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Amateur Radio Station electronic trusted logbook libraries
+
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+
+GNU_CONFIGURE= YES
+USE_LDCONFIG= YES
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= "CXXFLAGS=${CXXFLAGS} -fpermissive" --enable-docs=no \
+ --with-openssl=${OPENSSLBASE}
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lcrypto|${OPENSSLLIB}/libcrypto.so|' \
+ ${WRKSRC}/Makefile
+
+pre-install:
+ (cd ${WRKSRC}; \
+ make converter;make gen_crq; \
+ make load_cert;make station_loc)
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/converter ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/gen_crq ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/load_cert ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/station_loc ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/tqsllib
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/share/doc/tqsllib
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/tqsllib
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/tqsllib/distinfo b/comms/tqsllib/distinfo
new file mode 100644
index 000000000000..0c6de7d1e59e
--- /dev/null
+++ b/comms/tqsllib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tqsllib-2.2.tar.gz) = 1865a642e7e414eb47758ad26c527b84850d4cc4f2f7f1f119700b765ce636ea
+SIZE (tqsllib-2.2.tar.gz) = 616257
diff --git a/comms/tqsllib/pkg-descr b/comms/tqsllib/pkg-descr
new file mode 100644
index 000000000000..f383824b9e3e
--- /dev/null
+++ b/comms/tqsllib/pkg-descr
@@ -0,0 +1,7 @@
+tqsllibs for TrustedQSL
+
+The mission of the Trusted QSL Group is to keep eQSL an open and free
+activity for amateur radio operators by promoting the
+Digital Signature Standard (DSS).
+
+WWW: http://www.trustedqsl.org/trusted-qsl
diff --git a/comms/tqsllib/pkg-plist b/comms/tqsllib/pkg-plist
new file mode 100644
index 000000000000..3f6144f9f8c4
--- /dev/null
+++ b/comms/tqsllib/pkg-plist
@@ -0,0 +1,19 @@
+bin/converter
+bin/dumptqsldata
+bin/gen_crq
+bin/load_cert
+bin/station_loc
+include/tqsllib.h
+include/tqslerrno.h
+include/cabrillo.h
+include/adif.h
+include/tqslconvert.h
+lib/libtqsllib.so.1
+lib/libtqsllib.so
+lib/libtqsllib.la
+lib/libtqsllib.a
+share/tqsl/config.xml
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/tqsl