aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-02 01:46:08 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-01-02 01:46:08 +0000
commitf2fbf5a1ed195e7994b3b0ee3d968be9b37f15ee (patch)
treec1428e3ef48406f008bf9e485352728e13586ff8 /comms
parentbb8c820157b78f5163933bfd87bd3c92e922f882 (diff)
downloadports-f2fbf5a1ed195e7994b3b0ee3d968be9b37f15ee.tar.gz
ports-f2fbf5a1ed195e7994b3b0ee3d968be9b37f15ee.zip
For ports on riscv64 that fail the same (or similar ways) to aarch64, mark
them BROKEN. While here, pet portlint (Makevar order). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=559904
Diffstat (limited to 'comms')
-rw-r--r--comms/mgetty+sendfax/Makefile9
-rw-r--r--comms/uartlirc/Makefile1
2 files changed, 6 insertions, 4 deletions
diff --git a/comms/mgetty+sendfax/Makefile b/comms/mgetty+sendfax/Makefile
index a62009dbf702..6a0cc41d546c 100644
--- a/comms/mgetty+sendfax/Makefile
+++ b/comms/mgetty+sendfax/Makefile
@@ -13,8 +13,12 @@ COMMENT= Handle external logins, send and receive faxes
LICENSE= GPLv2
-USE_CSTD= gnu89
+BROKEN_aarch64= fails to compile: error: initializer element is not a compile-time constant
+BROKEN_mips64= fails to compile: error: initializer element is not a compile-time constant
+BROKEN_riscv64= fails to compile: error: initializer element is not a compile-time constant
+
USES= makeinfo perl5 shebangfix
+USE_CSTD= gnu89
SHEBANG_FILES= samples/fax samples/new_fax.all/new_fax samples/new_fax.mime1 \
samples/new_fax.th samples/coverpg-pl.ps samples/faxview.th
@@ -29,9 +33,6 @@ CFLAGS+= -DAUTO_PPP
MAKE_JOBS_UNSAFE= yes
-BROKEN_aarch64= Fails to compile: error: initializer element is not a compile-time constant
-BROKEN_mips64= Fails to compile: error: initializer element is not a compile-time constant
-
OPTIONS_DEFINE= FIDO
FIDO_DESC= Enable FIDO EMSI support
FIDO_CFLAGS= -DFIDO
diff --git a/comms/uartlirc/Makefile b/comms/uartlirc/Makefile
index d4aa0d3747fc..b9f4599f367b 100644
--- a/comms/uartlirc/Makefile
+++ b/comms/uartlirc/Makefile
@@ -17,6 +17,7 @@ BROKEN_aarch64= fails to compile: uartlirc_core.c:273:19: expected expression
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
BROKEN_powerpc64= fails to compile: uart.h: No such file or directory
BROKEN_powerpc64le= fails to compile: uart.h: No such file or directory
+BROKEN_riscv64= fails to compile: uartlirc_core.c:273:19: expected expression
BROKEN_sparc64= fails to build
USES= kmod