aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-03-29 21:28:15 +0000
committerDiane Bruce <db@FreeBSD.org>2013-03-29 21:28:15 +0000
commitf3d86acca567a437be1a4ee90bc1ce1e3a213326 (patch)
tree7ac571600ec5478db224f9285a8c2683eb735627 /comms
parent8fdb1da1d07571d9e5f289c0709d3a817717b965 (diff)
downloadports-f3d86acca567a437be1a4ee90bc1ce1e3a213326.tar.gz
ports-f3d86acca567a437be1a4ee90bc1ce1e3a213326.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/fldigi/Makefile8
-rw-r--r--comms/fldigi/files/patch-src_misc_configuration.cxx30
-rw-r--r--comms/fldigi/files/patch-src_throb_throb.cxx20
-rw-r--r--comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp12
4 files changed, 64 insertions, 6 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 846e1b3b1c74..c5f843564489 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: fldigi
-# Date created: December 20 2006
-# Whom: Diane Bruce <db@db.net>
-#
# $FreeBSD$
-#
PORTNAME= fldigi
PORTVERSION= 3.21.59
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/downloads/fldigi/\
${MASTER_SITE_LOCAL}
@@ -124,7 +120,7 @@ post-configure:
${RM} ${WRKSRC}/doc/*.1
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO} ""
${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/comms/fldigi/files/patch-src_misc_configuration.cxx b/comms/fldigi/files/patch-src_misc_configuration.cxx
new file mode 100644
index 000000000000..7844fdb65720
--- /dev/null
+++ b/comms/fldigi/files/patch-src_misc_configuration.cxx
@@ -0,0 +1,30 @@
+--- src/misc/configuration.cxx.orig 2013-03-28 08:57:53.000000000 -0500
++++ src/misc/configuration.cxx 2013-03-28 08:59:54.000000000 -0500
+@@ -901,8 +901,6 @@
+
+ void configuration::testCommPorts()
+ {
+- int retval;
+-
+ inpTTYdev->clear();
+ inpRIGdev->clear();
+ inpXmlRigDevice->clear();
+@@ -919,6 +917,7 @@
+ #endif
+
+ #ifdef __linux__
++ int retval;
+ bool ret = false;
+ DIR* sys = NULL;
+ char cwd[PATH_MAX] = { '.', '\0' };
+@@ -965,9 +964,7 @@
+ "/dev/ttyS%u",
+ "/dev/ttyUSB%u",
+ "/dev/usb/ttyUSB%u"
+-#elif defined(__FreeBSD__)
+- "/dev/ttyd%u"
+-#elif defined(__OpenBSD__) || defined(__NetBSD__)
++#elif defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
+ "/dev/tty%2.2u"
+ #elif defined(__CYGWIN__)
+ "/dev/ttyS%u"
diff --git a/comms/fldigi/files/patch-src_throb_throb.cxx b/comms/fldigi/files/patch-src_throb_throb.cxx
new file mode 100644
index 000000000000..ce464d2bd14b
--- /dev/null
+++ b/comms/fldigi/files/patch-src_throb_throb.cxx
@@ -0,0 +1,20 @@
+--- src/throb/throb.cxx.orig 2013-03-28 13:27:03.683043974 -0400
++++ src/throb/throb.cxx 2013-03-28 13:27:55.988221471 -0400
+@@ -37,6 +37,8 @@
+ #include "fl_digi.h"
+ #include "status.h"
+
++#define MAX_TONES 15 // Highest used I noticed was 11
++
+ #undef CLAMP
+ #define CLAMP(x,low,high) (((x)>(high))?(high):(((x)<(low))?(low):(x)))
+
+@@ -410,7 +412,7 @@
+
+ void throb::rx(complex in)
+ {
+- complex rxword[num_tones];
++ complex rxword[MAX_TONES];
+ int i, tone1, tone2, maxtone;
+
+ symbol[symptr] = in;
diff --git a/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp b/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp
new file mode 100644
index 000000000000..7576d3f3988f
--- /dev/null
+++ b/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcDispatch.cpp
@@ -0,0 +1,12 @@
+--- src/xmlrpcpp/XmlRpcDispatch.cpp.orig 2013-03-28 09:09:49.000000000 -0500
++++ src/xmlrpcpp/XmlRpcDispatch.cpp 2013-03-28 09:10:13.000000000 -0500
+@@ -10,7 +10,9 @@
+
+ #include <errno.h>
+ #include <math.h>
++#ifdef USE_FTIME
+ #include <sys/timeb.h>
++#endif
+
+ #if defined(_WINDOWS)
+ # include <winsock2.h>