aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-01-03 16:06:00 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-01-03 16:06:00 +0000
commitfbd9122a40a8aef04301c3d176bb2573a5e66fa6 (patch)
tree20fb46a71453f65c9a7021567c09766245990eb3 /comms
parent7796094ddfe2830f75237ae54c7edf21e9033350 (diff)
downloadports-fbd9122a40a8aef04301c3d176bb2573a5e66fa6.tar.gz
ports-fbd9122a40a8aef04301c3d176bb2573a5e66fa6.zip
Convert comms to MDOCS and MEXAMPLES.
Hold-out shame list: perl
Notes
Notes: svn path=/head/; revision=338555
Diffstat (limited to 'comms')
-rw-r--r--comms/esmska/Makefile5
-rw-r--r--comms/gammu-devel/Makefile4
-rw-r--r--comms/kb/Makefile5
-rw-r--r--comms/linrad/Makefile2
-rw-r--r--comms/py-bulksms/Makefile5
-rw-r--r--comms/py-serial/Makefile7
-rw-r--r--comms/qico/Makefile5
-rw-r--r--comms/scmxx/Makefile5
-rw-r--r--comms/uird/Makefile5
-rw-r--r--comms/wsjt/Makefile2
-rw-r--r--comms/wspr/Makefile5
-rw-r--r--comms/yfklog/Makefile7
12 files changed, 42 insertions, 15 deletions
diff --git a/comms/esmska/Makefile b/comms/esmska/Makefile
index cc8111baa44c..5c88918ff2e4 100644
--- a/comms/esmska/Makefile
+++ b/comms/esmska/Makefile
@@ -22,6 +22,9 @@ SUB_FILES= esmska
PORTDOCS= readme.txt
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
do-install:
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/esmska.jar ${DATADIR}/
@@ -32,7 +35,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/esmska ${PREFIX}/bin/
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 005f25af45d7..081159b068b8 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -27,7 +27,9 @@ USE_LDCONFIG= yes
PORTDOCS= *
-.if defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
CMAKE_ARGS+= -DINSTALL_DOC=OFF -DINSTALL_PHP_EXAMPLES=OFF -DINSTALL_MEDIA=OFF
.else
MAN1= gammu.1 gammu-config.1 jadmaker.1 gammu-smsd.1 gammu-smsd-inject.1 \
diff --git a/comms/kb/Makefile b/comms/kb/Makefile
index a76b61d86fac..15c2db60508b 100644
--- a/comms/kb/Makefile
+++ b/comms/kb/Makefile
@@ -27,6 +27,9 @@ DESKTOP_ENTRIES="KB" \
true
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
pre-configure:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
.if !exists(/usr/include/dev/speaker/speaker.h)
@@ -47,7 +50,7 @@ do-install:
${MKDIR} ${PREFIX}/share/pixmaps/kb/icons
${INSTALL_DATA} ${FILESDIR}/kb-icon.png \
${PREFIX}/share/pixmaps/kb/icons/kb-icon.png
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${FILESDIR}/README_TIPS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/kb_bsd/README_BSD ${DOCSDIR}
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index 375add6a4009..19b894b804c9 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -53,7 +53,7 @@ do-install:
# Some day we may want the svga version as well.
# ${INSTALL_PROGRAM} -m04555 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}.svga
${INSTALL_PROGRAM} -m04555 ${WRKSRC}/x${PORTNAME} ${PREFIX}/bin/x${PORTNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${LINRAD_DOCFILES}
@${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}/$f
diff --git a/comms/py-bulksms/Makefile b/comms/py-bulksms/Makefile
index 28a007a5542a..c605f2bb7699 100644
--- a/comms/py-bulksms/Makefile
+++ b/comms/py-bulksms/Makefile
@@ -18,8 +18,11 @@ PYDISTUTILS_PKGVERSION= 1.0
WRKSRC= ${WRKDIR}/bulksms
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/README.html ${DOCSDIR}
.endif
diff --git a/comms/py-serial/Makefile b/comms/py-serial/Makefile
index 3eb8ff0b49ad..3f1cd029edb9 100644
--- a/comms/py-serial/Makefile
+++ b/comms/py-serial/Makefile
@@ -20,12 +20,15 @@ DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
diff --git a/comms/qico/Makefile b/comms/qico/Makefile
index adef0f73c015..f583752281df 100644
--- a/comms/qico/Makefile
+++ b/comms/qico/Makefile
@@ -25,6 +25,9 @@ PLIST_SUB+= WITH_QICO_MORDA="@comment "
.endif
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_DATA} ${WRKSRC}/qico.conf.sample ${PREFIX}/etc/
${INSTALL_PROGRAM} ${WRKSRC}/src/qico ${PREFIX}/libexec/
@@ -32,7 +35,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/qcc ${PREFIX}/bin/
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/qico
${INSTALL_DATA} ${WRKSRC}/FAQ ${PREFIX}/share/doc/qico/FAQ.ru
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/qico/README.ru
diff --git a/comms/scmxx/Makefile b/comms/scmxx/Makefile
index c795caa7ee0a..0d2fcc08dacd 100644
--- a/comms/scmxx/Makefile
+++ b/comms/scmxx/Makefile
@@ -24,6 +24,9 @@ DOCS= README docs/*.txt
EXAMPLES= sms.txt vCalendar.vcs vCard.vcf
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-patch:
@${FIND} ${WRKSRC} -name 'Makefile*' | ${XARGS} \
${REINPLACE_CMD} -e "s|CFLAGS=|CFLAGS+=|g"
@@ -31,7 +34,7 @@ post-patch:
post-install:
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+..if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
diff --git a/comms/uird/Makefile b/comms/uird/Makefile
index c2a64dbbe912..9bf61f00b8bd 100644
--- a/comms/uird/Makefile
+++ b/comms/uird/Makefile
@@ -21,13 +21,16 @@ PLIST_FILES= bin/uird
PORTDOCS= Documentation
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|gcc|$${CC}\ $${CFLAGS}|; /strip/d' \
${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uird ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index 9c29045b2863..fef490bd8f2b 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -62,7 +62,7 @@ do-fetch:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for d in ${WRKSRC}/WSJT_Quick_Reference.pdf ${WRKSRC}/WSJT_Source_Code.txt \
${WRKSRC}/WSJT_User_600.pdf ${WRKSRC}/UpdateHistory.txt \
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index 83dd1642de26..2ec4e23b5ed4 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -38,11 +38,13 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
VERSION= 3.00
NO_STAGE= yes
+
+.include <bsd.port.pre.mk>
post-configure:
cp ${FILESDIR}/wspr ${WRKSRC}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for d in ${WRKSRC}/LICENSE.TXT ${WRKSRC}/WSPR_Announcement.TXT \
${WRKSRC}/WSPR0_Instructions.TXT ${WRKSRC}/WSPR_Quick_Start.TXT \
@@ -55,7 +57,6 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
.if defined(BOOTSTRAP)
SVN_REV!= svn info http://svn.code.sf.net/p/wsjt/code/branches/wspr | ${GREP} Revision | cut -d' ' -f2
.else
diff --git a/comms/yfklog/Makefile b/comms/yfklog/Makefile
index ad904ef9401e..4cafb8159039 100644
--- a/comms/yfklog/Makefile
+++ b/comms/yfklog/Makefile
@@ -26,6 +26,9 @@ NO_BUILD= yes
MAN1= yfklog.1
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
${WRKSRC}/yfk ${WRKSRC}/yfksubs.pl
@@ -42,7 +45,7 @@ do-install:
zweckform3421.lab zweckform3475.lab zweckform3657.lab config
@${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
.endfor
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}/onlinelog
.for f in README search.php test.txt
@${INSTALL_DATA} ${WRKSRC}/onlinelog/$f ${EXAMPLESDIR}/onlinelog
@@ -52,7 +55,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/clubs/$f ${EXAMPLESDIR}/clubs
.endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in AUTHORS CHANGELOG COPYING INSTALL MANUAL README RELEASENOTES
@${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}