aboutsummaryrefslogtreecommitdiff
path: root/converters/fondu
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-09 09:37:58 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-09 09:37:58 +0000
commitdf1dfe5659ec09bf6dc755f87f0016a3a6a1978b (patch)
treec0dca473b4505978e537cf90530dd7be3cbdd8e9 /converters/fondu
parent2cbbf70e4b3c3100f9cde7543d4f6d882d43d77a (diff)
downloadports-df1dfe5659ec09bf6dc755f87f0016a3a6a1978b.tar.gz
ports-df1dfe5659ec09bf6dc755f87f0016a3a6a1978b.zip
Support staging
Notes
Notes: svn path=/head/; revision=343440
Diffstat (limited to 'converters/fondu')
-rw-r--r--converters/fondu/Makefile37
-rw-r--r--converters/fondu/pkg-plist15
2 files changed, 27 insertions, 25 deletions
diff --git a/converters/fondu/Makefile b/converters/fondu/Makefile
index 3ce89129550c..6e8ac23e4322 100644
--- a/converters/fondu/Makefile
+++ b/converters/fondu/Makefile
@@ -11,34 +11,21 @@ EXTRACT_SUFX= .tgz
MAINTAINER= vg@FreeBSD.org
COMMENT= A series of programs to interconvert between mac fonts
+LICENSE= BSD3CLAUSE
+
HAS_CONFIGURE= yes
-MAN1= dfont2res.1 \
- fondu.1 \
- frombin.1 \
- lumper.1 \
- showfond.1 \
- tobin.1 \
- ufond.1
-
-PLIST_FILES= bin/dfont2res \
- bin/${PORTNAME} \
- bin/frombin \
- bin/lumper \
- bin/setfondname \
- bin/showfond \
- bin/tobin \
- bin/ufond
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/dfont2res.1 ${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/fondu.1 ${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/frombin.1 ${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/lumper.1 ${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/showfond.1 ${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/tobin.1 ${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/ufond.1 ${MANPREFIX}/man/man1/
+BINS= fondu ufond showfond dfont2res tobin frombin lumper setfondname
+MANPAGES= fondu ufond showfond dfont2res tobin frombin lumper
+
+do-install:
+.for f in ${BINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+.endfor
+.for f in ${MANPAGES}
+ ${INSTALL_MAN} ${WRKSRC}/${f}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+.endfor
.include <bsd.port.mk>
diff --git a/converters/fondu/pkg-plist b/converters/fondu/pkg-plist
new file mode 100644
index 000000000000..703bb5875157
--- /dev/null
+++ b/converters/fondu/pkg-plist
@@ -0,0 +1,15 @@
+bin/dfont2res
+bin/fondu
+bin/frombin
+bin/lumper
+bin/setfondname
+bin/showfond
+bin/tobin
+bin/ufond
+man/man1/dfont2res.1.gz
+man/man1/fondu.1.gz
+man/man1/frombin.1.gz
+man/man1/lumper.1.gz
+man/man1/showfond.1.gz
+man/man1/tobin.1.gz
+man/man1/ufond.1.gz