aboutsummaryrefslogtreecommitdiff
path: root/converters/gbsdconv
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-07 11:49:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-07 11:49:02 +0000
commitb3249305b0139adef3a463ec4f6d42bc5dd2b956 (patch)
tree0443620dc0e36922e1a5474e462bec275aaf250c /converters/gbsdconv
parent6281e4a487d8fc1971e58376c7bbcfa8a00f6a3b (diff)
downloadports-b3249305b0139adef3a463ec4f6d42bc5dd2b956.tar.gz
ports-b3249305b0139adef3a463ec4f6d42bc5dd2b956.zip
- Fix depend on gobject-introspection
- Support staging - Patch upstream makefile to not mix LOCALBASE and PREFIX PR: 186196 Submitted by: amdmi3 Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=347376
Diffstat (limited to 'converters/gbsdconv')
-rw-r--r--converters/gbsdconv/Makefile11
-rw-r--r--converters/gbsdconv/files/patch-Makefile26
2 files changed, 28 insertions, 9 deletions
diff --git a/converters/gbsdconv/Makefile b/converters/gbsdconv/Makefile
index 7dc7ae99c20e..ce70905bef6a 100644
--- a/converters/gbsdconv/Makefile
+++ b/converters/gbsdconv/Makefile
@@ -12,21 +12,17 @@ COMMENT= GUI for bsdconv
LICENSE= BSD
LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsdconv>=8.0:${PORTSDIR}/converters/py-bsdconv \
- ${LOCALBASE}/bin/g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsdconv>=8.0:${PORTSDIR}/converters/py-bsdconv
USE_GITHUB= yes
GH_ACCOUNT= buganini
GH_COMMIT= 0a9ad34
-USE_GNOME= gtk30
+USE_GNOME= gtk30 introspection:run
USE_PYTHON= yes
USE_LDCONFIG= yes
-MAKE_ARGS= PREFIX=${PREFIX}
-NO_STAGE= yes
-
PLIST_FILES= bin/gbsdconv \
lib/gbsdconv_taglib.so \
%%DATADIR%%/gbsdconv.png \
@@ -34,7 +30,4 @@ PLIST_FILES= bin/gbsdconv \
%%DATADIR%%/gbsdconv2.png
PLIST_DIRS= %%DATADIR%%
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/gbsdconv
-
.include <bsd.port.mk>
diff --git a/converters/gbsdconv/files/patch-Makefile b/converters/gbsdconv/files/patch-Makefile
new file mode 100644
index 000000000000..5c98ca973cfb
--- /dev/null
+++ b/converters/gbsdconv/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig 2013-09-09 09:56:10.000000000 +0400
++++ Makefile 2014-01-28 04:02:41.281082541 +0400
+@@ -1,17 +1,17 @@
+ PREFIX?=/usr/local
+
+-LIBS=-L${PREFIX}/lib -ltag
++LIBS=-L${LOCALBASE}/lib -ltag
+
+ all: gbsdconv_taglib
+
+ gbsdconv_taglib: taglib/tag_c.cpp
+- $(CXX) -I${PREFIX}/include/taglib -fPIC -shared -o gbsdconv_taglib.so taglib/tag_c.cpp ${LIBS}
++ $(CXX) -I${LOCALBASE}/include/taglib -fPIC -shared -o gbsdconv_taglib.so taglib/tag_c.cpp ${LIBS}
+
+ install:
+- install -m 755 gbsdconv ${PREFIX}/bin
+- install -m 444 gbsdconv_taglib.so ${PREFIX}/lib
+- mkdir -p ${PREFIX}/share/gbsdconv
+- install -m 444 gbsdconv.png gbsdconv.xml gbsdconv2.png ${PREFIX}/share/gbsdconv
++ install -m 755 gbsdconv ${DESTDIR}${PREFIX}/bin
++ install -m 444 gbsdconv_taglib.so ${DESTDIR}${PREFIX}/lib
++ mkdir -p ${DESTDIR}${PREFIX}/share/gbsdconv
++ install -m 444 gbsdconv.png gbsdconv.xml gbsdconv2.png ${DESTDIR}${PREFIX}/share/gbsdconv
+
+ clean:
+ rm -f gbsdconv_taglib.so