aboutsummaryrefslogtreecommitdiff
path: root/converters/iconv-extra
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 09:43:25 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 09:43:25 +0000
commit0b31d075bc0e27d93cf260d6dda0f3fbe47654e6 (patch)
treecc417f6c1e09adfeacf163534c572adfc3e479f7 /converters/iconv-extra
parentfae245e621a47d9b5a1f044892b638c72a369b48 (diff)
Notes
Diffstat (limited to 'converters/iconv-extra')
-rw-r--r--converters/iconv-extra/Makefile2
-rw-r--r--converters/iconv-extra/files/patch-ces::Makefile14
-rw-r--r--converters/iconv-extra/files/patch-ces::iso-2022-cn.c14
-rw-r--r--converters/iconv-extra/files/patch-ces::iso-2022-jp-2.c14
-rw-r--r--converters/iconv-extra/files/patch-ces::iso-2022-jp.c14
-rw-r--r--converters/iconv-extra/files/patch-ces::iso-2022-kr.c14
-rw-r--r--converters/iconv-extra/files/patch-ces::unicode-1-1-utf-7.c14
7 files changed, 85 insertions, 1 deletions
diff --git a/converters/iconv-extra/Makefile b/converters/iconv-extra/Makefile
index ed2b6a00998e..687422547e84 100644
--- a/converters/iconv-extra/Makefile
+++ b/converters/iconv-extra/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.dante.net/staff/konstantin/FreeBSD/iconv/
MAINTAINER= Konstantin.Chuguev@dante.org.uk
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= biconv.2:${PORTSDIR}/converters/iconv
USE_PERL5= yes
diff --git a/converters/iconv-extra/files/patch-ces::Makefile b/converters/iconv-extra/files/patch-ces::Makefile
new file mode 100644
index 000000000000..4ef780ecf709
--- /dev/null
+++ b/converters/iconv-extra/files/patch-ces::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ces/Makefile 2002/03/17 11:14:41 1.1
++++ ces/Makefile 2002/03/17 11:15:02
+@@ -5,7 +5,7 @@
+
+ .if !defined(ICONVDIR_LIBC)
+ CFLAGS += -I/usr/local/include
+-LDADD += -L/usr/local/lib -liconv
++LDADD += -L/usr/local/lib -lbiconv
+ .endif
+
+ INTERNALLIB =
diff --git a/converters/iconv-extra/files/patch-ces::iso-2022-cn.c b/converters/iconv-extra/files/patch-ces::iso-2022-cn.c
new file mode 100644
index 000000000000..8408bd387c08
--- /dev/null
+++ b/converters/iconv-extra/files/patch-ces::iso-2022-cn.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ces/iso-2022-cn.c 2002/03/17 11:15:25 1.1
++++ ces/iso-2022-cn.c 2002/03/17 11:15:46
+@@ -31,7 +31,7 @@
+ */
+
+ #define ICONV_INTERNAL
+-#include <iconv.h>
++#include <biconv.h>
+
+ static const iconv_ces_iso2022_ccs ccsattr[] = {
+ {"us-ascii", "", 0, ICONV_SHIFT_SI},
diff --git a/converters/iconv-extra/files/patch-ces::iso-2022-jp-2.c b/converters/iconv-extra/files/patch-ces::iso-2022-jp-2.c
new file mode 100644
index 000000000000..c1d3da317c5b
--- /dev/null
+++ b/converters/iconv-extra/files/patch-ces::iso-2022-jp-2.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ces/iso-2022-jp-2.c 2002/03/17 11:15:25 1.1
++++ ces/iso-2022-jp-2.c 2002/03/17 11:15:46
+@@ -31,7 +31,7 @@
+ */
+
+ #define ICONV_INTERNAL
+-#include <iconv.h>
++#include <biconv.h>
+
+ static const iconv_ces_iso2022_ccs ccsattr[] = {
+ {"us-ascii", "\x1b(B", 3, ICONV_SHIFT_SI},
diff --git a/converters/iconv-extra/files/patch-ces::iso-2022-jp.c b/converters/iconv-extra/files/patch-ces::iso-2022-jp.c
new file mode 100644
index 000000000000..0ad244075833
--- /dev/null
+++ b/converters/iconv-extra/files/patch-ces::iso-2022-jp.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ces/iso-2022-jp.c 2002/03/17 11:15:25 1.1
++++ ces/iso-2022-jp.c 2002/03/17 11:15:46
+@@ -31,7 +31,7 @@
+ */
+
+ #define ICONV_INTERNAL
+-#include <iconv.h>
++#include <biconv.h>
+
+ static const iconv_ces_iso2022_ccs ccsattr[] = {
+ {"us-ascii", "\x1b(B", 3, ICONV_SHIFT_SI},
diff --git a/converters/iconv-extra/files/patch-ces::iso-2022-kr.c b/converters/iconv-extra/files/patch-ces::iso-2022-kr.c
new file mode 100644
index 000000000000..259e299cc7b0
--- /dev/null
+++ b/converters/iconv-extra/files/patch-ces::iso-2022-kr.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ces/iso-2022-kr.c 2002/03/17 11:15:25 1.1
++++ ces/iso-2022-kr.c 2002/03/17 11:15:46
+@@ -31,7 +31,7 @@
+ */
+
+ #define ICONV_INTERNAL
+-#include <iconv.h>
++#include <biconv.h>
+
+ static const iconv_ces_iso2022_ccs ccsattr[] = {
+ {"us-ascii", "", 0, ICONV_SHIFT_SI},
diff --git a/converters/iconv-extra/files/patch-ces::unicode-1-1-utf-7.c b/converters/iconv-extra/files/patch-ces::unicode-1-1-utf-7.c
new file mode 100644
index 000000000000..0b4f3e574c7a
--- /dev/null
+++ b/converters/iconv-extra/files/patch-ces::unicode-1-1-utf-7.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ces/unicode-1-1-utf-7.c 2002/03/17 11:20:12 1.1
++++ ces/unicode-1-1-utf-7.c 2002/03/17 11:20:21
+@@ -33,7 +33,7 @@
+ #include <stdlib.h>
+
+ #define ICONV_INTERNAL
+-#include <iconv.h>
++#include <biconv.h>
+
+ static inline int
+ lackofbytes(int bytes, size_t *bytesleft)