aboutsummaryrefslogtreecommitdiff
path: root/converters/iconv
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-08-21 13:08:44 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-08-21 13:08:44 +0000
commit5618ef12a8d5a187d64d043ffce40e7874016541 (patch)
treea10f8bb6c7eca685249d8c7533d6c85d4fc12505 /converters/iconv
parent6867854e4a33f2bcd0d88595f093c3efef931b10 (diff)
downloadports-5618ef12a8d5a187d64d043ffce40e7874016541.tar.gz
ports-5618ef12a8d5a187d64d043ffce40e7874016541.zip
converters/iconv: make iconv_mktbl optional
- Add a default option called CSSUTIL which installs iconv_mktbl and pulls in perl as a run dependency PR: ports/180877 Submitted by: wg (myself) Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=325125
Diffstat (limited to 'converters/iconv')
-rw-r--r--converters/iconv/Makefile17
-rw-r--r--converters/iconv/files/extra-patch-ccs_Makefile13
-rw-r--r--converters/iconv/pkg-plist4
3 files changed, 28 insertions, 6 deletions
diff --git a/converters/iconv/Makefile b/converters/iconv/Makefile
index 4baf4bd27e15..5ce851732e2a 100644
--- a/converters/iconv/Makefile
+++ b/converters/iconv/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= bland@FreeBSD.org
COMMENT= Charset conversion library and utilities
USES= shebangfix
-USE_PERL5= yes
+USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
SHEBANG_FILES= iconv_builtin ccs/iconv_mktbl
@@ -20,10 +20,19 @@ MANCOMPRESSED= yes
MAN1= biconv.1
MAN3= biconv.3 biconv_open.3 biconv_close.3
-.if defined(NO_PROFILE) || defined(NOPROFILE) || defined(WITHOUT_PROFILE)
-PLIST_SUB= PROFILE:="@comment "
+OPTIONS_DEFINE= CCSUTIL
+OPTIONS_DEFAULT=CCSUTIL
+
+OPTIONS_SUB= yes
+
+CCSUTIL_DESC= Install Coded character set (CCS) util
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCCSUTIL}
+USE_PERL5_RUN= yes
.else
-PLIST_SUB= PROFILE:=""
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-ccs_Makefile
.endif
.include <bsd.port.mk>
diff --git a/converters/iconv/files/extra-patch-ccs_Makefile b/converters/iconv/files/extra-patch-ccs_Makefile
new file mode 100644
index 000000000000..30af7a0a7be3
--- /dev/null
+++ b/converters/iconv/files/extra-patch-ccs_Makefile
@@ -0,0 +1,13 @@
+diff --git ccs/Makefile ccs/Makefile
+index b61420c..faffe0f 100644
+--- ccs/Makefile
++++ ccs/Makefile
+@@ -67,8 +67,6 @@ beforeinstall:
+ cd ${.CURDIR}; \
+ ${INSTALL} ${COPY} -o ${LIBOWN} -g ${LIBGRP} -m 444 \
+ ${INSTALLFLAGS} ${CHARSETS_TBL} ${DESTDIR}${TABLEDIR}; \
+- ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
+- iconv_mktbl ${DESTDIR}${BINDIR}
+
+ CLEANFILES += *.c *.cct
+
diff --git a/converters/iconv/pkg-plist b/converters/iconv/pkg-plist
index 8ac582dbe6d0..a35c6407e559 100644
--- a/converters/iconv/pkg-plist
+++ b/converters/iconv/pkg-plist
@@ -1,10 +1,10 @@
bin/biconv
-bin/iconv_mktbl
+%%CCSUTIL%%bin/iconv_mktbl
include/biconv.h
lib/libbiconv.a
lib/libbiconv.so
lib/libbiconv.so.2
-%%PROFILE:%%lib/libbiconv_p.a
+lib/libbiconv_p.a
libexec/iconv/euc-jp.so
libexec/iconv/euc-kr.so
libexec/iconv/euc-tw.so