aboutsummaryrefslogtreecommitdiff
path: root/converters/libiconv
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-01-29 20:24:49 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-01-29 20:24:49 +0000
commit0052e743ef40759774eb918aa5180bcb21ea9cc1 (patch)
tree81efc99ecce690aaf994c38365ad6855aaf5dc09 /converters/libiconv
parent01abf783d2fc93e5ebc4c473b9680bb445b2aafd (diff)
downloadports-0052e743ef40759774eb918aa5180bcb21ea9cc1.tar.gz
ports-0052e743ef40759774eb918aa5180bcb21ea9cc1.zip
- Add two new arguments to USES=iconv so ports can indicate they use GNU
iconv extensions that the base system iconv doesn't support yet: * wchar_t: port uses the special WCHAR_T character conversion. * translit: port uses //TRANSLIT or //IGNORE conversion options. Adding one or both of these arguments makes the port depend on converters/libiconv for now. - Allow installation of converters/libiconv on FreeBSD 10+. - Use ICONV_CONFIGURE_ARG in devel/gettext instead of defining CPPFLAGS and LDFLAGS to fix compilation with libiconv installed. - Stage converters/libiconv and devel/gettext. Approved by: bapt (on trust)
Notes
Notes: svn path=/head/; revision=341775
Diffstat (limited to 'converters/libiconv')
-rw-r--r--converters/libiconv/Makefile12
-rw-r--r--converters/libiconv/pkg-plist6
2 files changed, 7 insertions, 11 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 077126e0b991..319664619d6c 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -11,25 +11,20 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A character set conversion library
GNU_CONFIGURE= yes
-LIBTOOLFILES= configure libcharset/configure preload/configure
CONFIGURE_ARGS= --enable-static \
--without-libintl-prefix \
--docdir=${DOCSDIR}
-USE_LDCONFIG= yes
CONFIGURE_ENV= gl_cv_cc_visibility="no" \
am_cv_func_iconv="yes" \
am_cv_proto_iconv_arg1="const"
MAKE_JOBS_UNSAFE= yes
-
-MAN1= iconv.1
-MAN3= iconv.3 iconv_open.3 iconv_open_into.3 iconv_close.3 iconvctl.3
+USE_LDCONFIG= yes
OPTIONS_DEFINE= ENCODINGS PATCHES
OPTIONS_DEFAULT=ENCODINGS
ENCODINGS_DESC= Include extra character sets
PATCHES_DESC= Apply patches to fix CP932, add EUCJP-MS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MENCODINGS}
@@ -50,9 +45,4 @@ post-patch:
${WRKSRC}/libcharset/configure \
${WRKSRC}/preload/configure
-.if exists(/usr/include/iconv.h)
-IGNORE= converters/libiconv should not be used with iconv from base. \
-Please fix the port which tries to use it
-.endif
-
.include <bsd.port.mk>
diff --git a/converters/libiconv/pkg-plist b/converters/libiconv/pkg-plist
index fc450fbc5b6d..252f2fb756b9 100644
--- a/converters/libiconv/pkg-plist
+++ b/converters/libiconv/pkg-plist
@@ -11,6 +11,12 @@ lib/libiconv.a
lib/libiconv.la
lib/libiconv.so
lib/libiconv.so.3
+man/man1/iconv.1.gz
+man/man3/iconv.3.gz
+man/man3/iconv_open.3.gz
+man/man3/iconv_open_into.3.gz
+man/man3/iconv_close.3.gz
+man/man3/iconvctl.3.gz
%%DOCSDIR%%/iconv.1.html
%%DOCSDIR%%/iconv.3.html
%%DOCSDIR%%/iconv_close.3.html