aboutsummaryrefslogtreecommitdiff
path: root/converters/libiconv
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-05-18 18:31:59 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-05-18 18:31:59 +0000
commit75887e7adcfe38d83d9d312a9c9477ea747eb0e1 (patch)
treebbc1a9cc01fb3fe8cc518437a5b68fc87d4b075a /converters/libiconv
parent8584fed33ac1ab61c1209746e01a5db09eee89ec (diff)
downloadports-75887e7adcfe38d83d9d312a9c9477ea747eb0e1.tar.gz
ports-75887e7adcfe38d83d9d312a9c9477ea747eb0e1.zip
converters/libiconv: Update to 1.16
Update converters/libiconv to 1.16. This update removes the extra patches for CP932 and EUCJP-MS, as they are not compatible with this release. Add an UPDATING entry for this change. ABI/API stable, no need to bump dependent ports: https://abi-laboratory.pro/index.php?view=timeline&l=libiconv PR: 240954 Submitted by: Yuichiro NAITO Exp-run by: antoine Approved by: maintainer timeout (gnome@)
Notes
Notes: svn path=/head/; revision=535769
Diffstat (limited to 'converters/libiconv')
-rw-r--r--converters/libiconv/Makefile20
-rw-r--r--converters/libiconv/distinfo7
-rw-r--r--converters/libiconv/files/patch-include-iconv.h.in16
-rw-r--r--converters/libiconv/files/patch-libcharset__lib__config.charset43
-rw-r--r--converters/libiconv/files/patch-libcharset_lib_localcharset.c18
-rw-r--r--converters/libiconv/files/patch-src__Makefile.in8
-rw-r--r--converters/libiconv/pkg-plist3
7 files changed, 41 insertions, 74 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 1f2c6aaf7a17..64898d3835c0 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libiconv
-PORTVERSION= 1.14
-PORTREVISION= 11
+PORTVERSION= 1.16
CATEGORIES= converters devel
MASTER_SITES= GNU
@@ -13,6 +12,10 @@ COMMENT= Character set conversion library
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= libtool
+USE_CSTD= gnu89
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
--disable-nls \
@@ -20,25 +23,16 @@ CONFIGURE_ARGS= --enable-static \
am_cv_func_iconv=no
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
-USES= libtool
-USE_CSTD= gnu89
-USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS ENCODINGS PATCHES
+OPTIONS_DEFINE= DOCS ENCODINGS
OPTIONS_DEFAULT=ENCODINGS
ENCODINGS_DESC= Include extra character sets
-PATCHES_DESC= Apply patches to fix CP932, add EUCJP-MS
ENCODINGS_CONFIGURE_ENABLE= extra-encodings
-PATCHES_PATCH_SITES= http://apolloron.org/software/libiconv-1.14-ja/ \
- LOCAL/kwm
-PATCHES_PATCHFILES= ${DISTNAME}-ja-1.patch.gz:-p1
-
post-patch:
@${REINPLACE_CMD} -e 's:ei_ksc5601:ei_euc_kr:g' ${WRKSRC}/lib/aliases.h
@${REINPLACE_CMD} -e 's:gawk:awk:g' ${WRKSRC}/configure \
- ${WRKSRC}/libcharset/configure \
- ${WRKSRC}/preload/configure
+ ${WRKSRC}/libcharset/configure
.include <bsd.port.mk>
diff --git a/converters/libiconv/distinfo b/converters/libiconv/distinfo
index f7e57c9fdcb3..89e6e628e122 100644
--- a/converters/libiconv/distinfo
+++ b/converters/libiconv/distinfo
@@ -1,4 +1,3 @@
-SHA256 (libiconv-1.14.tar.gz) = 72b24ded17d687193c3366d0ebe7cde1e6b18f0df8c55438ac95be39e8a30613
-SIZE (libiconv-1.14.tar.gz) = 4984397
-SHA256 (libiconv-1.14-ja-1.patch.gz) = c9474ee420b971029073dabf5e599b049945fbb040f353dce4db32191401bfee
-SIZE (libiconv-1.14-ja-1.patch.gz) = 291963
+TIMESTAMP = 1569891121
+SHA256 (libiconv-1.16.tar.gz) = e6a1b1b589654277ee790cce3734f07876ac4ccfaecbee8afa0b649cf529cc04
+SIZE (libiconv-1.16.tar.gz) = 5166734
diff --git a/converters/libiconv/files/patch-include-iconv.h.in b/converters/libiconv/files/patch-include-iconv.h.in
index e29d9104314c..071ad7d160bb 100644
--- a/converters/libiconv/files/patch-include-iconv.h.in
+++ b/converters/libiconv/files/patch-include-iconv.h.in
@@ -1,17 +1,17 @@
---- include/iconv.h.in.orig 2011-08-07 17:48:03 UTC
+--- include/iconv.h.in.orig 2019-04-26 18:48:39 UTC
+++ include/iconv.h.in
-@@ -21,8 +21,10 @@
+@@ -20,8 +20,10 @@
#ifndef _LIBICONV_H
#define _LIBICONV_H
+#ifndef LIBICONV_PLUG
- #define _LIBICONV_VERSION 0x010E /* version number: (major<<8) + minor */
+ #define _LIBICONV_VERSION 0x0110 /* version number: (major<<8) + minor */
extern @DLL_VARIABLE@ int _libiconv_version; /* Likewise */
+#endif
/* We would like to #include any system header file which could define
iconv_t, 1. in order to eliminate the risk that the user gets compilation
-@@ -94,7 +96,6 @@ extern int iconv_close (iconv_t cd);
+@@ -93,7 +95,6 @@ extern int iconv_close (iconv_t cd);
#endif
@@ -19,7 +19,7 @@
/* Nonstandard extensions. */
-@@ -127,12 +128,16 @@ typedef struct {
+@@ -126,12 +127,16 @@ typedef struct {
/* Allocates descriptor for code conversion from encoding ‘fromcode’ to
encoding ‘tocode’ into preallocated memory. Returns an error indicator
(0 or -1 with errno set). */
@@ -36,7 +36,7 @@
extern int iconvctl (iconv_t cd, int request, void* argument);
/* Hook performed after every successful conversion of a Unicode character. */
-@@ -210,9 +215,15 @@ struct iconv_fallbacks {
+@@ -209,9 +214,15 @@ struct iconv_fallbacks {
#define ICONV_SET_DISCARD_ILSEQ 4 /* const int *argument */
#define ICONV_SET_HOOKS 5 /* const struct iconv_hooks *argument */
#define ICONV_SET_FALLBACKS 6 /* const struct iconv_fallbacks *argument */
@@ -52,7 +52,7 @@
extern void iconvlist (int (*do_one) (unsigned int namescount,
const char * const * names,
void* data),
-@@ -224,6 +235,7 @@ extern const char * iconv_canonicalize (const char * n
+@@ -223,6 +234,7 @@ extern const char * iconv_canonicalize (
/* Support for relocatable packages. */
@@ -60,7 +60,7 @@
/* Sets the original and the current installation prefix of the package.
Relocation simply replaces a pathname starting with the original prefix
by the corresponding pathname with the current prefix instead. Both
-@@ -231,12 +243,12 @@ extern const char * iconv_canonicalize (const char * n
+@@ -230,12 +242,12 @@ extern const char * iconv_canonicalize (
instead of "/"). */
extern void libiconv_set_relocation_prefix (const char *orig_prefix,
const char *curr_prefix);
diff --git a/converters/libiconv/files/patch-libcharset__lib__config.charset b/converters/libiconv/files/patch-libcharset__lib__config.charset
deleted file mode 100644
index ba30603dc83a..000000000000
--- a/converters/libiconv/files/patch-libcharset__lib__config.charset
+++ /dev/null
@@ -1,43 +0,0 @@
---- libcharset/lib/config.charset.orig 2010-04-05 02:25:38.000000000 +0200
-+++ libcharset/lib/config.charset 2011-10-23 22:05:50.000000000 +0200
-@@ -348,7 +348,7 @@ case "$os" in
- #echo "sun_eu_greek ?" # what is this?
- echo "UTF-8 UTF-8"
- ;;
-- freebsd* | os2*)
-+ freebsd4.[0-5]* | os2*)
- # FreeBSD 4.2 doesn't have nl_langinfo(CODESET); therefore
- # localcharset.c falls back to using the full locale name
- # from the environment variables.
-@@ -385,6 +385,31 @@ case "$os" in
- echo "ja_JP.Shift_JIS SHIFT_JIS"
- echo "ko_KR.EUC EUC-KR"
- ;;
-+ freebsd*)
-+ echo "US-ASCII ASCII"
-+ echo "ISO8859-1 ISO-8859-1"
-+ echo "ISO_8859-1 ISO-8859-1"
-+ echo "ISO8859-2 ISO-8859-2"
-+ echo "ISO_8859-2 ISO-8859-2"
-+ echo "ISO8859-4 ISO-8859-4"
-+ echo "ISO_8859-4 ISO-8859-4"
-+ echo "ISO8859-5 ISO-8859-5"
-+ echo "ISO_8859-5 ISO-8859-5"
-+ echo "ISO8859-7 ISO-8859-7"
-+ echo "ISO_8859-7 ISO-8859-7"
-+ echo "ISO8859-9 ISO-8859-9"
-+ echo "ISO_8859-9 ISO-8859-9"
-+ echo "ISO8859-13 ISO-8859-13"
-+ echo "ISO_8859-13 ISO-8859-13"
-+ echo "ISO8859-15 ISO-8859-15"
-+ echo "ISO_8859-15 ISO-8859-15"
-+ echo "eucCN GB2312"
-+ echo "eucJP EUC-JP"
-+ echo "eucKR EUC-KR"
-+ echo "Big5 BIG5"
-+ echo "Big5HKSCS BIG5-HKSCS"
-+ echo "SJIS SHIFT_JIS"
-+ ;;
- netbsd*)
- echo "646 ASCII"
- echo "ISO8859-1 ISO-8859-1"
diff --git a/converters/libiconv/files/patch-libcharset_lib_localcharset.c b/converters/libiconv/files/patch-libcharset_lib_localcharset.c
new file mode 100644
index 000000000000..c344c51026f7
--- /dev/null
+++ b/converters/libiconv/files/patch-libcharset_lib_localcharset.c
@@ -0,0 +1,18 @@
+--- libcharset/lib/localcharset.c.orig 2020-05-09 08:59:22 UTC
++++ libcharset/lib/localcharset.c
+@@ -92,6 +92,7 @@ static const struct table_entry alias_table[] =
+ # if defined __FreeBSD__ /* FreeBSD */
+ /*{ "ARMSCII-8", "ARMSCII-8" },*/
+ { "Big5", "BIG5" },
++ { "Big5HKSCS", "BIG5-HKSCS" },
+ { "C", "ASCII" },
+ /*{ "CP1131", "CP1131" },*/
+ /*{ "CP1251", "CP1251" },*/
+@@ -104,6 +105,7 @@ static const struct table_entry alias_table[] =
+ { "ISO8859-13", "ISO-8859-13" },
+ { "ISO8859-15", "ISO-8859-15" },
+ { "ISO8859-2", "ISO-8859-2" },
++ { "ISO8859-4", "ISO-8859-4" },
+ { "ISO8859-5", "ISO-8859-5" },
+ { "ISO8859-7", "ISO-8859-7" },
+ { "ISO8859-9", "ISO-8859-9" },
diff --git a/converters/libiconv/files/patch-src__Makefile.in b/converters/libiconv/files/patch-src__Makefile.in
index 04d0b09ef858..18c7b5113cbf 100644
--- a/converters/libiconv/files/patch-src__Makefile.in
+++ b/converters/libiconv/files/patch-src__Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2011-06-04 19:05:58.000000000 +0200
-+++ src/Makefile.in 2013-07-06 18:49:54.000000000 +0200
-@@ -71,7 +71,6 @@
+--- src/Makefile.in.orig 2019-01-27 22:07:13 UTC
++++ src/Makefile.in
+@@ -71,7 +71,6 @@ OBJECTS_RES_no =
# without internationalization and not linked with libintl.
all : iconv_no_i18n$(EXEEXT) iconv.@OBJEXT@ $(OBJECTS_RES_@WOE32@)
@@ -8,7 +8,7 @@
# This is the temporary iconv executable, without internationalization.
iconv_no_i18n$(EXEEXT) : iconv_no_i18n.@OBJEXT@ ../lib/libiconv.la $(OBJECTS_RES_@WOE32@)
-@@ -113,7 +112,7 @@
+@@ -113,7 +112,7 @@ install : all force
if [ ! -d $(DESTDIR)$(bindir) ] ; then $(mkinstalldirs) $(DESTDIR)$(bindir) ; fi
case "@host_os@" in \
hpux*) $(CC) $(LDFLAGS) $(CFLAGS) $(iconv_LDFLAGS) iconv.@OBJEXT@ ../srclib/libicrt.a -L$(DESTDIR)$(libdir) -liconv @LIBINTL@ $(OBJECTS_RES_@WOE32@) `if test -n '$(DESTDIR)'; then echo " -Wl,+b -Wl,$(libdir)"; fi` -o iconv$(EXEEXT);; \
diff --git a/converters/libiconv/pkg-plist b/converters/libiconv/pkg-plist
index 64341c2e3416..ef1e79084933 100644
--- a/converters/libiconv/pkg-plist
+++ b/converters/libiconv/pkg-plist
@@ -2,7 +2,6 @@ bin/iconv
include/iconv.h
include/libcharset.h
include/localcharset.h
-lib/charset.alias
lib/libcharset.a
lib/libcharset.so
lib/libcharset.so.1
@@ -10,7 +9,7 @@ lib/libcharset.so.1.0.0
lib/libiconv.a
lib/libiconv.so
lib/libiconv.so.2
-lib/libiconv.so.2.5.1
+lib/libiconv.so.2.6.1
man/man1/iconv.1.gz
man/man3/iconv.3.gz
man/man3/iconv_open.3.gz