aboutsummaryrefslogtreecommitdiff
path: root/converters/libticonv
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 18:05:32 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 18:05:32 +0000
commitd5a3fc65be0d1d0d321482e7f3f77cba273faed1 (patch)
tree63197f2107a8e31cafc00203b7a5e63d0e5d1386 /converters/libticonv
parent790db52911dc5cf10c3097649953e0be1e6564e3 (diff)
downloadports-d5a3fc65be0d1d0d321482e7f3f77cba273faed1.tar.gz
ports-d5a3fc65be0d1d0d321482e7f3f77cba273faed1.zip
The ticonv library is a library to work with the various TI
calculator character sets. WWW: http://tilp.info/ - Tijl Coosemans tijl@ulyssis.org PR: ports/104407 Submitted by: Tijl Coosemans <tijl at ulyssis.org>
Notes
Notes: svn path=/head/; revision=175892
Diffstat (limited to 'converters/libticonv')
-rw-r--r--converters/libticonv/Makefile30
-rw-r--r--converters/libticonv/distinfo3
-rw-r--r--converters/libticonv/pkg-descr7
-rw-r--r--converters/libticonv/pkg-plist11
4 files changed, 51 insertions, 0 deletions
diff --git a/converters/libticonv/Makefile b/converters/libticonv/Makefile
new file mode 100644
index 000000000000..42246b133157
--- /dev/null
+++ b/converters/libticonv/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libticonv
+# Date created: 5 October 2006
+# Whom: Tijl Coosemans <tijl@ulyssis.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libticonv
+PORTVERSION= 1.0.0
+CATEGORIES= converters
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtktiemu
+DISTNAME= ${PORTNAME}-20060925
+
+MAINTAINER= tijl@ulyssis.org
+COMMENT= TI calculator character set library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_AUTOTOOLS= libtool:15
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gnomehack pkgconfig
+USE_LDCONFIG= yes
+USE_ICONV= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/converters/libticonv/distinfo b/converters/libticonv/distinfo
new file mode 100644
index 000000000000..ccdef38a4918
--- /dev/null
+++ b/converters/libticonv/distinfo
@@ -0,0 +1,3 @@
+MD5 (libticonv-20060925.tar.bz2) = ab19f2ba8eb82ad303c18867d84299a9
+SHA256 (libticonv-20060925.tar.bz2) = 571028e32397cea1c562ed0c03989d51a068c9496b5fca2ad9ff07fa1a622338
+SIZE (libticonv-20060925.tar.bz2) = 326675
diff --git a/converters/libticonv/pkg-descr b/converters/libticonv/pkg-descr
new file mode 100644
index 000000000000..b96d2439dba5
--- /dev/null
+++ b/converters/libticonv/pkg-descr
@@ -0,0 +1,7 @@
+The ticonv library is a library to work with the various TI
+calculator character sets.
+
+WWW: http://tilp.info/
+
+- Tijl Coosemans
+tijl@ulyssis.org
diff --git a/converters/libticonv/pkg-plist b/converters/libticonv/pkg-plist
new file mode 100644
index 000000000000..4c9676204dae
--- /dev/null
+++ b/converters/libticonv/pkg-plist
@@ -0,0 +1,11 @@
+include/tilp2/charset.h
+include/tilp2/export4.h
+include/tilp2/stdints4.h
+include/tilp2/ticonv.h
+include/tilp2/ticonv.h-e
+lib/libticonv.a
+lib/libticonv.la
+lib/libticonv.so
+lib/libticonv.so.2
+libdata/pkgconfig/ticonv.pc
+@dirrmtry include/tilp2