aboutsummaryrefslogtreecommitdiff
path: root/converters/lua-iconv
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /converters/lua-iconv
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Notes
Notes: svn path=/head/; revision=326307
Diffstat (limited to 'converters/lua-iconv')
-rw-r--r--converters/lua-iconv/Makefile4
-rw-r--r--converters/lua-iconv/files/patch-Makefile2
2 files changed, 4 insertions, 2 deletions
diff --git a/converters/lua-iconv/Makefile b/converters/lua-iconv/Makefile
index 3988537d9b05..8dacfe99119c 100644
--- a/converters/lua-iconv/Makefile
+++ b/converters/lua-iconv/Makefile
@@ -21,7 +21,9 @@ USES= pkgconfig iconv
PLIST_FILES= %%LUA_MODLIBDIR%%/iconv.so
post-patch:
- @${REINPLACE_CMD} -e 's|%%INCDIR%%|-I${PREFIX}/include|;s|%%LIBDIR%%|-L${PREFIX}/lib|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%INCDIR%%|-I${PREFIX}/include| ; \
+ s|%%LIBDIR%%|-L${PREFIX}/lib|; \
+ s|%%ICONV_LIB%%|${ICONV_LIB}|' ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/iconv.so ${LUA_MODLIBDIR}
diff --git a/converters/lua-iconv/files/patch-Makefile b/converters/lua-iconv/files/patch-Makefile
index ae1eeb119222..ed29001d0b7d 100644
--- a/converters/lua-iconv/files/patch-Makefile
+++ b/converters/lua-iconv/files/patch-Makefile
@@ -8,7 +8,7 @@
-CFLAGS = `pkg-config $(LUAPKG) --cflags` -fPIC -O3 -Wall
+LUAPKG = lua-5.1
+CFLAGS += `pkg-config $(LUAPKG) --cflags` -fPIC %%INCDIR%%
-+LIBS = `pkg-config $(LUAPKG) --libs` -liconv %%LIBDIR%%
++LIBS = `pkg-config $(LUAPKG) --libs` %%ICONV_LIB%% %%LIBDIR%%
LFLAGS = -shared $(OMIT_FRAME_POINTER)
INSTALL_PATH = `pkg-config $(LUAPKG) --variable=INSTALL_CMOD`