aboutsummaryrefslogtreecommitdiff
path: root/converters/nomyso
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /converters/nomyso
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'converters/nomyso')
-rw-r--r--converters/nomyso/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/converters/nomyso/Makefile b/converters/nomyso/Makefile
index 7fb2268eb3df..18409f88f803 100644
--- a/converters/nomyso/Makefile
+++ b/converters/nomyso/Makefile
@@ -10,19 +10,14 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert MASM/TASM files to NASM compatible sources
-USES= perl5 zip
+USES= perl5 zip dos2unix shebangfix
+SHEBANG_FILES= nomyso.pl
USE_PERL5= run
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}.pl
-post-patch:
- @${REINPLACE_CMD} -E \
- -e 's|[[:cntrl:]]$$||' \
- -e 's|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/${PORTNAME}.pl
-
do-install:
@${INSTALL_SCRIPT} \
${WRKSRC}/${PORTNAME}.pl \