aboutsummaryrefslogtreecommitdiff
path: root/converters/ocaml-base64
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2015-08-05 19:14:43 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2015-08-05 19:14:43 +0000
commit937b65a4ce3df6af722e0b39c936acc80a15b5e0 (patch)
tree14d7f741c4a5efbb6143f1a9a6a24f61f1405f7c /converters/ocaml-base64
parentd129587b5d568b0ff5300386f1e1b706c349f38e (diff)
downloadports-937b65a4ce3df6af722e0b39c936acc80a15b5e0.tar.gz
ports-937b65a4ce3df6af722e0b39c936acc80a15b5e0.zip
New port: converters/ocaml-base64
Base64 is a group of similar binary-to-text encoding schemes that represent binary data in an ASCII string format by translating it into a radix-64 representation. It is specified in RFC 4648. WWW: https://github.com/mirage/ocaml-base64
Notes
Notes: svn path=/head/; revision=393608
Diffstat (limited to 'converters/ocaml-base64')
-rw-r--r--converters/ocaml-base64/Makefile29
-rw-r--r--converters/ocaml-base64/distinfo2
-rw-r--r--converters/ocaml-base64/pkg-descr5
3 files changed, 36 insertions, 0 deletions
diff --git a/converters/ocaml-base64/Makefile b/converters/ocaml-base64/Makefile
new file mode 100644
index 000000000000..4c00b22d2136
--- /dev/null
+++ b/converters/ocaml-base64/Makefile
@@ -0,0 +1,29 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= base64
+PORTVERSION= 2.0.0
+CATEGORIES= converters
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= vg@FreeBSD.org
+COMMENT= Base64 encoding and decoding in OCaml
+
+USE_GITHUB= yes
+GH_ACCOUNT= mirage
+GH_PROJECT= ocaml-base64
+GH_TAGNAME= v${PORTVERSION}
+
+USES= gmake
+HAS_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
+USE_OCAML_LDCONFIG= yes
+DOCSDIR= ${PREFIX}/share/doc/pcre-ocaml
+
+CONFIGURE_ARGS= --destdir="${DESTDIRNAME}"
+
+.include <bsd.port.mk>
diff --git a/converters/ocaml-base64/distinfo b/converters/ocaml-base64/distinfo
new file mode 100644
index 000000000000..ad8460af0a51
--- /dev/null
+++ b/converters/ocaml-base64/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mirage-ocaml-base64-2.0.0-v2.0.0_GH0.tar.gz) = 029b6a7af1493a077dc25c8e0f3534e5f5ff6e4260e3998a9ca3850fb7238c2c
+SIZE (mirage-ocaml-base64-2.0.0-v2.0.0_GH0.tar.gz) = 46084
diff --git a/converters/ocaml-base64/pkg-descr b/converters/ocaml-base64/pkg-descr
new file mode 100644
index 000000000000..1011a96c0b55
--- /dev/null
+++ b/converters/ocaml-base64/pkg-descr
@@ -0,0 +1,5 @@
+Base64 is a group of similar binary-to-text encoding schemes that
+represent binary data in an ASCII string format by translating it
+into a radix-64 representation. It is specified in RFC 4648.
+
+WWW: https://github.com/mirage/ocaml-base64