aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-Text-Iconv
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-03-25 18:40:44 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-03-25 18:40:44 +0000
commit1aa279d77996f5d32084bcd31cb81664ed741d09 (patch)
treed1b902f71b7e31819ae011724057ced0073fb1a6 /converters/p5-Text-Iconv
parent1e5cb0b6bf28edf8fa2f78dcd483fba1f5086e71 (diff)
downloadports-1aa279d77996f5d32084bcd31cb81664ed741d09.tar.gz
ports-1aa279d77996f5d32084bcd31cb81664ed741d09.zip
Instead of patching the code to use /usr/include/iconv.h replace LOCALBASE
in CONFIGURE_ARGS with ICONV_PREFIX. Also add CFLAGS to INC in CONFIGURE_ARGS to get -DLIBICONV_PLUG on FreeBSD 10 with libiconv installed. PR: ports/187907 Approved by: perl (mat)
Notes
Notes: svn path=/head/; revision=349168
Diffstat (limited to 'converters/p5-Text-Iconv')
-rw-r--r--converters/p5-Text-Iconv/Makefile16
-rw-r--r--converters/p5-Text-Iconv/files/patch-Makefile.PL25
2 files changed, 4 insertions, 37 deletions
diff --git a/converters/p5-Text-Iconv/Makefile b/converters/p5-Text-Iconv/Makefile
index e65f67cfaf3e..11a75454d045 100644
--- a/converters/p5-Text-Iconv/Makefile
+++ b/converters/p5-Text-Iconv/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Text-Iconv
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= converters perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,16 +13,7 @@ COMMENT= Perl interface to iconv() codeset conversion function
USES= perl5 iconv
USE_PERL5= configure
-CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}" \
- ccflags="${CFLAGS}"
+CONFIGURE_ARGS+=INC="-I${ICONV_PREFIX}/include ${CFLAGS}" \
+ LIBS="-L${ICONV_PREFIX}/lib ${ICONV_LIB}"
-.include <bsd.port.pre.mk>
-
-post-patch:
-.if ${OSVERSION} >= 1000043
- @${REINPLACE_CMD} 's|<iconv.h>|"/usr/include/iconv.h"|' \
- ${WRKSRC}/Iconv.xs
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/converters/p5-Text-Iconv/files/patch-Makefile.PL b/converters/p5-Text-Iconv/files/patch-Makefile.PL
deleted file mode 100644
index f68385a8bd35..000000000000
--- a/converters/p5-Text-Iconv/files/patch-Makefile.PL
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.PL.orig 2007-10-17 16:06:22.000000000 +0200
-+++ Makefile.PL 2014-03-24 21:28:37.147481295 +0100
-@@ -90,6 +90,7 @@
- AUTHOR => 'Michael Piotrowski <mxp@dynalabs.de>') : ()),
- 'LIBS' => $config{LIBS},
- 'DEFINE' => "@DEFINE",
-+ 'CCFLAGS' => $config{ccflags},
- 'INC' => $config{INC},
- 'dist' => {COMPRESS => 'gzip', SUFFIX => 'gz'},
- );
-@@ -119,12 +120,12 @@
- {
- # It is admittedly a bit simplistic to simply concatenate all
- # flags, but it seems to work in most cases.
-- $compile = join ' ', $Config{cc}, $incs, $Config{ccflags},
-+ $compile = join ' ', $Config{cc}, $incs, $config{ccflags},
- $Config{ldflags}, $libs;
- }
- else
- {
-- $compile = join ' ', $Config{cc}, $incs, $Config{ccflags}, $libs;
-+ $compile = join ' ', $Config{cc}, $incs, $config{ccflags}, $libs;
- }
-
- if (exists $config{verbose})