aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-Text-Iconv
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 05:51:33 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 05:51:33 +0000
commit641bd655c323339a63706419249effce58575383 (patch)
tree3a6a3e100a40016b13eb719e7de8302aac53520b /converters/p5-Text-Iconv
parent441bdcd6a5240032827d0607153516fc663b914d (diff)
downloadports-641bd655c323339a63706419249effce58575383.tar.gz
ports-641bd655c323339a63706419249effce58575383.zip
Notes
Diffstat (limited to 'converters/p5-Text-Iconv')
-rw-r--r--converters/p5-Text-Iconv/Makefile32
-rw-r--r--converters/p5-Text-Iconv/distinfo1
-rw-r--r--converters/p5-Text-Iconv/pkg-comment1
-rw-r--r--converters/p5-Text-Iconv/pkg-descr1
-rw-r--r--converters/p5-Text-Iconv/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/converters/p5-Text-Iconv/Makefile b/converters/p5-Text-Iconv/Makefile
new file mode 100644
index 000000000000..7cb76dee12d5
--- /dev/null
+++ b/converters/p5-Text-Iconv/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Text::Iconv
+# Date created: 26 Dec 2000
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Iconv
+PORTVERSION= 1.1
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+
+USE_PERL5= yes
+
+MAN3= Text::Iconv.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX} \
+ LIBS="-L${LOCALBASE}/lib -liconv " \
+ INC="-I ${LOCALBASE}/include " \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/converters/p5-Text-Iconv/distinfo b/converters/p5-Text-Iconv/distinfo
new file mode 100644
index 000000000000..b8968f30ada2
--- /dev/null
+++ b/converters/p5-Text-Iconv/distinfo
@@ -0,0 +1 @@
+MD5 (Text-Iconv-1.1.tar.gz) = 17c5da932b61f12d44fa6ca65c1d7775
diff --git a/converters/p5-Text-Iconv/pkg-comment b/converters/p5-Text-Iconv/pkg-comment
new file mode 100644
index 000000000000..3b1c6c5de053
--- /dev/null
+++ b/converters/p5-Text-Iconv/pkg-comment
@@ -0,0 +1 @@
+Perl interface to iconv() codeset conversion function
diff --git a/converters/p5-Text-Iconv/pkg-descr b/converters/p5-Text-Iconv/pkg-descr
new file mode 100644
index 000000000000..8175c1a1f101
--- /dev/null
+++ b/converters/p5-Text-Iconv/pkg-descr
@@ -0,0 +1 @@
+Text::Iconv - Perl interface to iconv() codeset conversion function
diff --git a/converters/p5-Text-Iconv/pkg-plist b/converters/p5-Text-Iconv/pkg-plist
new file mode 100644
index 000000000000..5302781299e5
--- /dev/null
+++ b/converters/p5-Text-Iconv/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Iconv/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Text/Iconv.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Iconv/Iconv.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Iconv/Iconv.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Iconv/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Iconv
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Text 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true