aboutsummaryrefslogtreecommitdiff
path: root/converters/showkey/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-10-24 01:18:37 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-10-24 01:18:37 +0000
commit84e27e4737fd450962aa125245b2327a7b50dec1 (patch)
treefb1621f108450a8601c96bdb77ba7f81f7ce43a7 /converters/showkey/Makefile
parentf7f81e5b9db94f145e07226cc372de3bc8e44ac8 (diff)
downloadports-84e27e4737fd450962aa125245b2327a7b50dec1.tar.gz
ports-84e27e4737fd450962aa125245b2327a7b50dec1.zip
Notes
Diffstat (limited to 'converters/showkey/Makefile')
-rw-r--r--converters/showkey/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/converters/showkey/Makefile b/converters/showkey/Makefile
new file mode 100644
index 000000000000..a64450556eb3
--- /dev/null
+++ b/converters/showkey/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: showkey
+# Date created: 2003-10-24
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= showkey
+PORTVERSION= 1.3
+CATEGORIES= converters
+MASTER_SITES= http://catb.org/~esr/showkey/
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Prints its input, with escapes such as "<NUL>"
+
+ALL_TARGET= showkey
+MAN1= showkey.1
+PLIST= ${WRKDIR}/pkg-plist
+
+pre-install:
+ ${ECHO_CMD} bin/showkey > ${PLIST}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/showkey ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/showkey.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>