aboutsummaryrefslogtreecommitdiff
path: root/converters/uulib
diff options
context:
space:
mode:
authorTim Vanderhoek <hoek@FreeBSD.org>2002-09-06 13:45:33 +0000
committerTim Vanderhoek <hoek@FreeBSD.org>2002-09-06 13:45:33 +0000
commitfe0f46858ba6af8c6ade141faacf9ab094f388cd (patch)
tree383c26eaff3b0805ddfc4d7af79ef2634313f4ee /converters/uulib
parent3d91907984a2169b8321c92d2c1a673c8584577c (diff)
downloadports-fe0f46858ba6af8c6ade141faacf9ab094f388cd.tar.gz
ports-fe0f46858ba6af8c6ade141faacf9ab094f388cd.zip
USE_REINPLACE rather than a somewhat convoluted perl expression.
Notes
Notes: svn path=/head/; revision=65727
Diffstat (limited to 'converters/uulib')
-rw-r--r--converters/uulib/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/converters/uulib/Makefile b/converters/uulib/Makefile
index 69fac9e823a0..2e0f9decb2bf 100644
--- a/converters/uulib/Makefile
+++ b/converters/uulib/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= hoek@FreeBSD.org
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
MAN3= uulib.3
@@ -39,8 +40,10 @@ do-install:
@/usr/bin/ranlib ${PREFIX}/lib/libuu.a
${INSTALL_DATA} ${WRKSRC}/uulib/uudeview.h ${PREFIX}/include
${INSTALL_MAN} ${FILESDIR}/uulib.3 ${PREFIX}/man/man3
- ${PERL} -pi -e '$$a = '\''${PREFIX}/'\''; $$a =~ s/([^\w\/])/\\$$1/g; \
- s/FUNKYTOKENHERE/$$a/' ${PREFIX}/man/man3/uulib.3
+ ${REINPLACE_CMD} -e 's,FUNKYTOKENHERE,${PREFIX}/,' \
+ ${PREFIX}/man/man3/uulib.3
+ @# If we don't remove the .bak file, then man(1) gets confused
+ @${RM} -f ${PREFIX}/man/man3/uulib.3.bak
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
@${MKDIR} ${PREFIX}/share/doc/uulib