aboutsummaryrefslogtreecommitdiff
path: root/converters/wkhtmltopdf
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-10-02 04:00:53 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-10-02 04:00:53 +0000
commit5879bc73ebf42161696293545cab5b923a2327b2 (patch)
tree8c76d8b3022ceee02f5602cf3835d21e4fea6281 /converters/wkhtmltopdf
parent243e899d7eccbb8a3f91cb520f17b0979ccbd9c7 (diff)
downloadports-5879bc73ebf42161696293545cab5b923a2327b2.tar.gz
ports-5879bc73ebf42161696293545cab5b923a2327b2.zip
converters/wkhtmltopdf: fix build on powerpc64
- requires USES=compiler:c++11-lang to build on powerpc64 - It also requires changing values in mkspecs to point to proper compiler PR: 231858 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Sponsored by: Hardware by IntegriCloud
Notes
Notes: svn path=/head/; revision=481095
Diffstat (limited to 'converters/wkhtmltopdf')
-rw-r--r--converters/wkhtmltopdf/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index b23e58f33274..ff59ee31c993 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -17,7 +17,6 @@ BROKEN_aarch64= fails to build: error: cast from pointer to smaller type loses
BROKEN_armv6= fails to build: error: Not supported ARM architecture
BROKEN_armv7= fails to build: error: invalid operand for instruction
BROKEN_mips64= fails to link: undefined reference to __sync_add_and_fetch_4
-BROKEN_powerpc64= fails to build: RenderObject.o: sibling call optimization to does not allow automatic multiple TOCs
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= member access into incomplete type 'SSL_CIPHER' (aka 'ssl_cipher_st')
@@ -26,7 +25,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png
-USES= compiler:env gmake iconv jpeg perl5 pkgconfig ssl:build
+USES= compiler:c++11-lang gmake iconv jpeg perl5 pkgconfig ssl:build
USE_XORG= x11 xext xrender
USE_PERL5= build
USE_LDCONFIG= yes
@@ -70,6 +69,9 @@ post-patch:
-e 's|/usr/X11R6/include|${LOCALBASE}/include/X11|g' \
-e 's|/usr/X11R6/lib|${LOCALBASE}/lib|g' \
${PATCH_WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%GCC_DEFAULT%%|${GCC_DEFAULT}|g' \
+ ${PATCH_WRKSRC}/mkspecs/common/gcc-base.conf
${REINPLACE_CMD} -e "s|gcc|${CC}|g" -e "s|g++|${CXX}|g" \
${PATCH_WRKSRC}/mkspecs/common/g++-base.conf
${REINPLACE_CMD} -e "s|share/man|man|g" \