aboutsummaryrefslogtreecommitdiff
path: root/converters/xdeview
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-06 18:14:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-06 18:14:28 +0000
commit38390d95ee5383456d9956e1c83ddc56e9855fd1 (patch)
tree07b7145dcbf881ca515c46276366f14001f8e5db /converters/xdeview
parent302f9443e128422713451d07ffa22ea28c2220a0 (diff)
downloadports-38390d95ee5383456d9956e1c83ddc56e9855fd1.tar.gz
ports-38390d95ee5383456d9956e1c83ddc56e9855fd1.zip
Support stage
Notes
Notes: svn path=/head/; revision=347292
Diffstat (limited to 'converters/xdeview')
-rw-r--r--converters/xdeview/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/converters/xdeview/Makefile b/converters/xdeview/Makefile
index 6a4de4d65d23..cc5dbb4415b4 100644
--- a/converters/xdeview/Makefile
+++ b/converters/xdeview/Makefile
@@ -9,13 +9,15 @@ MASTER_SITES= http://www.fpx.de/fp/Software/UUDeview/download/
DISTNAME= uudeview-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An X11 program for uu/xx/Base64/BinHex/yEnc de-/encoding
+COMMENT= X11 program for uu/xx/Base64/BinHex/yEnc de-/encoding
LICENSE= GPLv2
+OPTIONS_DEFINE= DOCS
+
LIB_DEPENDS= libuu.so:${PORTSDIR}/converters/uulib
-USES+= tk
+USES+= tk desthack
GNU_CONFIGURE= yes
# Explicitly disable Tcl otherwise the configure script picks-up
# crud from the $PATH like /usr/opt/Simili/tcl/.
@@ -30,22 +32,15 @@ LDFLAGS+= -L${LOCALBASE}/lib \
-lX11 -ltcl${TCL_VER:S/.//} \
-ltk${TCL_VER:S/.//} -lm
-MAN1= xdeview.1
PORTDOCS= porting.notes
-PLIST_FILES= bin/uuwish bin/xdeview
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/uuwish bin/xdeview man/man1/xdeview.1.gz
post-install:
- ${STRIP_CMD} ${PREFIX}/bin/uuwish
-.if ${PORT_OPTIONS:MDOCS}
- @${ECHO_MSG} "===> Installing documents to ${DOCSDIR}"
- @${MKDIR} ${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/uuwish
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- @${INSTALL_DATA} ${FILESDIR}/${file} ${DOCSDIR}
+ @${INSTALL_DATA} ${FILESDIR}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- ${INSTALL_MAN} ${WRKSRC}/man/xdeview.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/xdeview.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>