aboutsummaryrefslogtreecommitdiff
path: root/converters/xdeview
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-03-23 12:29:04 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-03-23 12:29:04 +0000
commit448a166c58cd42d5fb06c1c323ee7b470db5460a (patch)
treeaa9f516504d615e2a9d1f3f4abbe67dd42b6008d /converters/xdeview
parent5cea961203a0e0b6e979e11839d45c4cff23d942 (diff)
downloadports-448a166c58cd42d5fb06c1c323ee7b470db5460a.tar.gz
ports-448a166c58cd42d5fb06c1c323ee7b470db5460a.zip
- switch to USE_TK
- add support from tk82 to tk85 PR: ports/130183
Notes
Notes: svn path=/head/; revision=251403
Diffstat (limited to 'converters/xdeview')
-rw-r--r--converters/xdeview/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/converters/xdeview/Makefile b/converters/xdeview/Makefile
index 9058135892f3..a5b3a96c9962 100644
--- a/converters/xdeview/Makefile
+++ b/converters/xdeview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xdeview
PORTVERSION= 0.5.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters tcl tk
MASTER_SITES= http://www.fpx.de/fp/Software/UUDeview/download/
DISTNAME= uudeview-${PORTVERSION}
@@ -22,12 +22,6 @@ GNU_CONFIGURE= yes
# Explicitly disable Tcl otherwise the configure script picks-up
# crud from the $PATH lie /usr/opt/Simili/tcl/.
CONFIGURE_ARGS= --disable-tcl --disable-tk
-# Season to taste --- anything better or equal to tcl8.0 is probably okay
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib \
- -lX11 -ltcl84 -ltk84 -lm" \
- CPPFLAGS="-I${LOCALBASE}/include/tcl8.4 -DHAVE_TCL \
- -I${LOCALBASE}/include/tk8.4 -DHAVE_TK \
- -I${LOCALBASE}/include"
ALL_TARGET= xdeview
INSTALL_TARGET= install-tcl
@@ -35,6 +29,16 @@ MAN1= xdeview.1
DOCFILES= ${FILESDIR}/porting.notes
+USE_TK= 82+
+
+.include <bsd.port.pre.mk>
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib \
+ -lX11 -ltcl${TCL_VER:S/.//} \
+ -ltk${TCL_VER:S/.//} -lm" \
+ CPPFLAGS="-I${TCL_INCLUDEDIR} -DHAVE_TCL \
+ -I${TK_INCLUDEDIR} -DHAVE_TK \
+ -I${LOCALBASE}/include"
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/uuwish
.if !defined(NOPORTDOCS)
@@ -46,4 +50,4 @@ post-install:
.endif
${INSTALL_MAN} ${WRKSRC}/man/xdeview.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>