aboutsummaryrefslogtreecommitdiff
path: root/converters/xdeview
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-28 18:32:45 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-28 18:32:45 +0000
commitbc087374d35aa9c841dd63d44e9c9697702921ed (patch)
tree9bfffecdf0e79fc2f3af0e2a2f1044536ad164ca /converters/xdeview
parent3689fb2140698b1b4eff0933fe730262b161f533 (diff)
downloadports-bc087374d35aa9c841dd63d44e9c9697702921ed.tar.gz
ports-bc087374d35aa9c841dd63d44e9c9697702921ed.zip
Update to use Tcl/Tk version 8.2.
Submitted by: Ade Lovett <ade@lovett.com>
Notes
Notes: svn path=/head/; revision=23474
Diffstat (limited to 'converters/xdeview')
-rw-r--r--converters/xdeview/Makefile6
-rw-r--r--converters/xdeview/files/patch-aa73
-rw-r--r--converters/xdeview/files/patch-ac23
3 files changed, 97 insertions, 5 deletions
diff --git a/converters/xdeview/Makefile b/converters/xdeview/Makefile
index 80c0008589c3..c5a94c0dbc64 100644
--- a/converters/xdeview/Makefile
+++ b/converters/xdeview/Makefile
@@ -8,19 +8,19 @@
DISTNAME= uudeview-0.5.13
PKGNAME= xdeview-0.5.13
-CATEGORIES= converters tk80
+CATEGORIES= converters tk82
MASTER_SITES= ftp://tsx-11.mit.edu/pub/linux/sources/usr.bin/ \
http://www.informatik.uni-frankfurt.de/~fp/uudeview/Apps/frank/
MAINTAINER= hoek@FreeBSD.org
-LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80 \
+LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
uu.1:${PORTSDIR}/converters/uulib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-tcl="${PREFIX}" --enable-tk="${PREFIX}"
# Season to taste --- anything over tcl7.5
-CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/tcl8.0 -I${PREFIX}/include/tk8.0"
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/tcl8.2 -I${PREFIX}/include/tk8.2"
ALL_TARGET= xdeview
INSTALL_TARGET= install-tcl
diff --git a/converters/xdeview/files/patch-aa b/converters/xdeview/files/patch-aa
index e68426775ef5..99062a06bd52 100644
--- a/converters/xdeview/files/patch-aa
+++ b/converters/xdeview/files/patch-aa
@@ -1,5 +1,74 @@
---- ./configure.org Thu Jan 9 06:22:00 1997
-+++ ./configure Sun Mar 30 04:25:11 1997
+--- configure.orig Thu Jan 9 08:22:00 1997
++++ configure Thu Nov 4 11:29:23 1999
+@@ -2193,7 +2193,7 @@
+
+ if test "$have_tk" = "yes" ; then
+ echo $ac_n "checking for -ltk$tk_major.$tk_minor""... $ac_c" 1>&6
+-ac_lib_var=`echo tk$tk_major.$tk_minor'_'Tk_Main | tr './+\055' '__p_'`
++ac_lib_var=`echo tk$tk_major.$tk_minor'_'Tk_MainEx | tr './+\055' '__p_'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -2205,11 +2205,11 @@
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char Tk_Main();
++char Tk_MainEx();
+
+ int main() { return 0; }
+ int t() {
+-Tk_Main()
++Tk_MainEx()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:2216: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; }; then
+@@ -2233,7 +2233,7 @@
+
+ if test "$have_tk_lib" = "no" ; then
+ echo $ac_n "checking for -ltk$tk_major$tk_minor""... $ac_c" 1>&6
+-ac_lib_var=`echo tk$tk_major$tk_minor'_'Tk_Main | tr './+\055' '__p_'`
++ac_lib_var=`echo tk$tk_major$tk_minor'_'Tk_MainEx | tr './+\055' '__p_'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -2245,11 +2245,11 @@
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char Tk_Main();
++char Tk_MainEx();
+
+ int main() { return 0; }
+ int t() {
+-Tk_Main()
++Tk_MainEx()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:2256: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; }; then
+@@ -2274,7 +2274,7 @@
+ fi
+ if test "$have_tk_lib" = "no" ; then
+ echo $ac_n "checking for -ltk""... $ac_c" 1>&6
+-ac_lib_var=`echo tk'_'Tk_Main | tr './+\055' '__p_'`
++ac_lib_var=`echo tk'_'Tk_MainEx | tr './+\055' '__p_'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -2286,11 +2286,11 @@
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char Tk_Main();
++char Tk_MainEx();
+
+ int main() { return 0; }
+ int t() {
+-Tk_Main()
++Tk_MainEx()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:2297: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; }; then
@@ -3148,7 +3148,7 @@
fi
diff --git a/converters/xdeview/files/patch-ac b/converters/xdeview/files/patch-ac
new file mode 100644
index 000000000000..781256ff61f5
--- /dev/null
+++ b/converters/xdeview/files/patch-ac
@@ -0,0 +1,23 @@
+--- tcl/uuwish.c.orig Thu Jun 6 14:41:11 1996
++++ tcl/uuwish.c Thu Nov 4 11:34:43 1999
+@@ -78,19 +78,7 @@
+ int
+ main (int argc, char *argv[])
+ {
+-#ifdef HAVE_TK
+- Tk_Main
+-#else
+-#ifdef HAVE_TCL
+- Tcl_Main
+-#endif
+-#endif
+- (argc, argv
+-#ifdef TMAIN_THREE
+- , Tcl_AppInit
+-#endif
+- );
+-
++ Tk_MainEx( argc, argv, Tcl_AppInit, Tcl_CreateInterp() );
+ return 0;
+ }
+