aboutsummaryrefslogtreecommitdiff
path: root/converters/xml2c
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-27 21:26:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-27 21:26:41 +0000
commitc43d8da5f4e640477e7af04879b26ca56e12a68c (patch)
tree26c024cbba31e47f1262666adacafc35c8eab80a /converters/xml2c
parent189fd73d359571c3166a15e831abb0e8cba5c9e6 (diff)
downloadports-c43d8da5f4e640477e7af04879b26ca56e12a68c.tar.gz
ports-c43d8da5f4e640477e7af04879b26ca56e12a68c.zip
Reset maintainership
- While I'm here: - Update MASTER_SITES - Clean up Makefile - Update manpage location (r523104) - Update pkg-descr - Update WWW - Take maintainership PR: 244451 Submitted by: Neel Chauhan <neel@neelc.org> (maintainer)
Notes
Notes: svn path=/head/; revision=527303
Diffstat (limited to 'converters/xml2c')
-rw-r--r--converters/xml2c/Makefile15
-rw-r--r--converters/xml2c/pkg-descr10
2 files changed, 14 insertions, 11 deletions
diff --git a/converters/xml2c/Makefile b/converters/xml2c/Makefile
index dc584e7d9877..9619774df6d9 100644
--- a/converters/xml2c/Makefile
+++ b/converters/xml2c/Makefile
@@ -3,25 +3,24 @@
PORTNAME= xml2c
PORTVERSION= 20151019
CATEGORIES= converters
-MASTER_SITES= http://acme.com/software/xml2c/
+MASTER_SITES= https://acme.com/software/xml2c/
DISTNAME= ${PORTNAME}_19Oct2015
-MAINTAINER= neel@neelc.org
-COMMENT= Reads in an XML file and produces equivalent C source code
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Convert an XML file into C struct/string declarations
LICENSE= BSD2CLAUSE
USES= gnome
USE_GNOME= libxml2
-WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_FILES= bin/xml2c man/man1/xml2c.1.gz
+WRKSRC= ${WRKDIR}/xml2c
-#MAKEFILE= /dev/null
-ALL_TARGET= ${PORTNAME}
+PLIST_FILES= bin/xml2c \
+ share/man/man1/xml2c.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xml2c ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xml2c.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/xml2c.1
+ ${INSTALL_MAN} ${WRKSRC}/xml2c.1 ${STAGEDIR}${MAN1PREFIX}/share/man/man1/xml2c.1
.include <bsd.port.mk>
diff --git a/converters/xml2c/pkg-descr b/converters/xml2c/pkg-descr
index 9c171dbb9deb..66d224c8969e 100644
--- a/converters/xml2c/pkg-descr
+++ b/converters/xml2c/pkg-descr
@@ -1,4 +1,8 @@
-xml2c reads in an XML file and produces equivalent C source code,
-suitable for #including in your program.
+xml2c reads in an XML file and produces equivalent C source code, suitable for
+#including in your program. The C version is probably easier deal with in your
+code. You don't have to read and parse the XML file and then look for the nodes
+you want; instead you just loop through a bunch of structs. Or maybe you just
+don't want to distribute extra files with your app, and would rather build them
+into the executable.
-WWW: http://www.acme.com/software/xml2c/
+WWW: https://acme.com/software/xml2c/