aboutsummaryrefslogtreecommitdiff
path: root/converters/yj
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2020-04-01 06:59:48 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2020-04-01 06:59:48 +0000
commit5009ebc92ab2b827e7f186453cc58d41de3cffee (patch)
tree3518ca13972942807fbe341c04af3ef58f53a976 /converters/yj
parent6b542baa094c8019c1f0d5f8884a0c777a998a45 (diff)
downloadports-5009ebc92ab2b827e7f186453cc58d41de3cffee.tar.gz
ports-5009ebc92ab2b827e7f186453cc58d41de3cffee.zip
- add port yj
Convert between YAML, TOML, JSON, and HCL WWW: https://github.com/sclevine/yj
Notes
Notes: svn path=/head/; revision=530201
Diffstat (limited to 'converters/yj')
-rw-r--r--converters/yj/Makefile26
-rw-r--r--converters/yj/distinfo9
-rw-r--r--converters/yj/files/patch-go.mod14
-rw-r--r--converters/yj/files/patch-go.sum10
-rw-r--r--converters/yj/pkg-descr3
5 files changed, 62 insertions, 0 deletions
diff --git a/converters/yj/Makefile b/converters/yj/Makefile
new file mode 100644
index 000000000000..3c547c9d0275
--- /dev/null
+++ b/converters/yj/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= yj
+PORTVERSION= 4.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= converters
+DIST_SUBDIR= yj
+
+MAINTAINER= ohauer@FreeBSD.org
+COMMENT= Convert between YAML, TOML, JSON, and HCL
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+
+GH_ACCOUNT= sclevine
+
+PLIST_FILES= bin/yj
+
+GH_TUPLE= BurntSushi:toml:v0.3.1:burntsushi_toml/vendor/github.com/BurntSushi/toml \
+ go-yaml:yaml:v2.2.7:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
+ hashicorp:hcl:v1.0.0:hashicorp_hcl/vendor/github.com/hashicorp/hcl
+
+.include <bsd.port.mk>
diff --git a/converters/yj/distinfo b/converters/yj/distinfo
new file mode 100644
index 000000000000..6cbd2e07bce1
--- /dev/null
+++ b/converters/yj/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1578243427
+SHA256 (yj/sclevine-yj-v4.0.0_GH0.tar.gz) = 8423486cdc0f6bd912bdcb9f61ef89427a70b094352c45e62b1343c9b2ea92f4
+SIZE (yj/sclevine-yj-v4.0.0_GH0.tar.gz) = 12885
+SHA256 (yj/BurntSushi-toml-v0.3.1_GH0.tar.gz) = 6593da894578ba510a470735ffbdc88ce88033094dc5a8f4d3957ab87e18803f
+SIZE (yj/BurntSushi-toml-v0.3.1_GH0.tar.gz) = 42077
+SHA256 (yj/go-yaml-yaml-v2.2.7_GH0.tar.gz) = 74afe4be0fa4482de73cfaf952dc6c8d41088b687c3f9de4a7ced86d2bbe0cb4
+SIZE (yj/go-yaml-yaml-v2.2.7_GH0.tar.gz) = 72651
+SHA256 (yj/hashicorp-hcl-v1.0.0_GH0.tar.gz) = 50632428210503070fd2fde748c88b7414bf84a6a0eadebf9d8e596a033bead2
+SIZE (yj/hashicorp-hcl-v1.0.0_GH0.tar.gz) = 70658
diff --git a/converters/yj/files/patch-go.mod b/converters/yj/files/patch-go.mod
new file mode 100644
index 000000000000..385f9b0c60ca
--- /dev/null
+++ b/converters/yj/files/patch-go.mod
@@ -0,0 +1,14 @@
+--- go.mod.orig 2019-05-06 05:03:58 UTC
++++ go.mod
+@@ -1,9 +1,9 @@
+ module github.com/sclevine/yj
+
+-go 1.12
++go 1.13
+
+ require (
+ github.com/BurntSushi/toml v0.3.1
+ github.com/hashicorp/hcl v1.0.0
+- gopkg.in/yaml.v2 v2.2.2
++ gopkg.in/yaml.v2 v2.2.7
+ )
diff --git a/converters/yj/files/patch-go.sum b/converters/yj/files/patch-go.sum
new file mode 100644
index 000000000000..5a97d9e919a1
--- /dev/null
+++ b/converters/yj/files/patch-go.sum
@@ -0,0 +1,10 @@
+--- go.sum.orig 2019-05-06 05:03:58 UTC
++++ go.sum
+@@ -4,5 +4,5 @@ github.com/davecgh/go-spew v1.1.1/go.mod
+ github.com/hashicorp/hcl v1.0.0 h1:0Anlzjpi4vEasTeNFn2mLJgTSwt0+6sfsiTG8qcWGx4=
+ github.com/hashicorp/hcl v1.0.0/go.mod h1:E5yfLk+7swimpb2L/Alb/PJmXilQ/rhwaUYs4T20WEQ=
+ gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod h1:Co6ibVJAznAaIkqp8huTwlJQCZ016jof/cbN4VW5Yz0=
+-gopkg.in/yaml.v2 v2.2.2 h1:ZCJp+EgiOT7lHqUV2J862kp8Qj64Jo6az82+3Td9dZw=
+-gopkg.in/yaml.v2 v2.2.2/go.mod h1:hI93XBmqTisBFMUTm0b8Fm+jr3Dg1NNxqwp+5A1VGuI=
++gopkg.in/yaml.v2 v2.2.7 h1:VUgggvou5XRW9mHwD/yXxIYSMtY0zoKQf/v226p2nyo=
++gopkg.in/yaml.v2 v2.2.7/go.mod h1:hI93XBmqTisBFMUTm0b8Fm+jr3Dg1NNxqwp+5A1VGuI=
diff --git a/converters/yj/pkg-descr b/converters/yj/pkg-descr
new file mode 100644
index 000000000000..b4ed1c65692f
--- /dev/null
+++ b/converters/yj/pkg-descr
@@ -0,0 +1,3 @@
+Convert between YAML, TOML, JSON, and HCL.
+
+WWW: https://github.com/sclevine/yj