aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-02-04 10:05:01 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-02-04 10:05:01 +0000
commit0329c0e56d2784db44b23b612415df90020646c1 (patch)
tree2532e8b17062cb02839c6654ad9aeb535e542de1 /converters
parentf1d3f8fb415595cfedb6f3ac5790834010bc1bd9 (diff)
downloadports-0329c0e56d2784db44b23b612415df90020646c1.tar.gz
ports-0329c0e56d2784db44b23b612415df90020646c1.zip
converters/osm2pgrouting: Update to 2.3.7
- Update to 2.3.7 - Update CMakeLists patch - fix: Way - fixed bug handling oneway false conditions - fix: fixed CMakeLists - fix: adjustments to FindPostgreSQL.cmake. - Improvements on map config XML files. - New docs: "Code of Conduct" and "Contributing". - Docs improvements.
Notes
Notes: svn path=/head/; revision=564010
Diffstat (limited to 'converters')
-rw-r--r--converters/osm2pgrouting/Makefile9
-rw-r--r--converters/osm2pgrouting/distinfo6
-rw-r--r--converters/osm2pgrouting/files/patch-CMakeLists.txt8
3 files changed, 11 insertions, 12 deletions
diff --git a/converters/osm2pgrouting/Makefile b/converters/osm2pgrouting/Makefile
index 6112e120bf3f..c92fe5616c0c 100644
--- a/converters/osm2pgrouting/Makefile
+++ b/converters/osm2pgrouting/Makefile
@@ -2,15 +2,14 @@
PORTNAME= osm2pgrouting
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.6
-PORTREVISION= 4
+DISTVERSION= 2.3.7
CATEGORIES= converters databases geography
MAINTAINER= lbartoletti@FreeBSD.org
COMMENT= Import OSM data into pgRouting database
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libexpat.so:textproc/expat2 \
@@ -24,11 +23,11 @@ WANT_PGSQL= client
OPTIONS_DEFINE= DOCS
-PORTDOCS= Readme.md
+PORTDOCS= README.md
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/osm2pgrouting/mapconfig.xml|${PREFIX}/etc/${PORTNAME}/mapconfig.xml|' \
${WRKSRC}/src/utilities/prog_options.cpp \
- ${WRKSRC}/Readme.md
+ ${WRKSRC}/README.md
.include <bsd.port.mk>
diff --git a/converters/osm2pgrouting/distinfo b/converters/osm2pgrouting/distinfo
index b4e28a250307..35bd7c03a19d 100644
--- a/converters/osm2pgrouting/distinfo
+++ b/converters/osm2pgrouting/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1547161773
-SHA256 (pgRouting-osm2pgrouting-v2.3.6_GH0.tar.gz) = c4b1f45ff7a9a184956182e40016fdd9455718821adb25822e2ef8182d2712a6
-SIZE (pgRouting-osm2pgrouting-v2.3.6_GH0.tar.gz) = 182168
+TIMESTAMP = 1612377637
+SHA256 (pgRouting-osm2pgrouting-v2.3.7_GH0.tar.gz) = afbe3ff74c9b9b7b1350362fc839e1466335d57f84941af19b5a663fd58aba0c
+SIZE (pgRouting-osm2pgrouting-v2.3.7_GH0.tar.gz) = 185875
diff --git a/converters/osm2pgrouting/files/patch-CMakeLists.txt b/converters/osm2pgrouting/files/patch-CMakeLists.txt
index f5329a388538..b4fab2a0f483 100644
--- a/converters/osm2pgrouting/files/patch-CMakeLists.txt
+++ b/converters/osm2pgrouting/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2020-08-20 05:32:18 UTC
+--- CMakeLists.txt.orig 2021-02-04 06:38:35 UTC
+++ CMakeLists.txt
@@ -8,7 +8,8 @@ if ( ${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR}
endif()
@@ -30,12 +30,12 @@
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14")
message(STATUS "Using -std=c++14.")
elseif(COMPILER_SUPPORTS_CXX11)
-@@ -114,14 +119,14 @@ if(WIN32)
+@@ -114,14 +119,15 @@ if(WIN32)
endif()
INSTALL(FILES
- "${CMAKE_SOURCE_DIR}/COPYING"
- "${CMAKE_SOURCE_DIR}/Readme.md"
+ "${CMAKE_SOURCE_DIR}/README.md"
- "${CMAKE_SOURCE_DIR}/mapconfig.xml"
- "${CMAKE_SOURCE_DIR}/mapconfig_for_cars.xml"
- "${CMAKE_SOURCE_DIR}/mapconfig_for_bicycles.xml"
@@ -43,12 +43,12 @@
- DESTINATION "${SHARE_DIR}")
+ DESTINATION "${DOC_DIR}")
--
+FOREACH(i mapconfig.xml mapconfig_for_cars.xml mapconfig_for_bicycles.xml mapconfig_for_pedestrian.xml)
+ INSTALL(FILES
+ "${CMAKE_SOURCE_DIR}/${i}"
+ RENAME ${i}.sample
+ DESTINATION "${ETC_DIR}")
+ENDFOREACH()
+
#INCLUDE_DIRECTORIES( ${Boost_INCLUDE_DIR} )
#TARGET_LINK_LIBRARIES( osm2pgrouting ${Boost_LIBRARIES} )