aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-11-01 21:51:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-11-01 21:51:36 +0000
commit3ca3ffe4551bee0f510c9d301bf4f312959dcf25 (patch)
treece13218697645e8981b36e7589f64b42e3049ce5 /converters
parent19c0b79bf443eb706820ac162b35b88fcf9088fd (diff)
downloadports-3ca3ffe4551bee0f510c9d301bf4f312959dcf25.tar.gz
ports-3ca3ffe4551bee0f510c9d301bf4f312959dcf25.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/pdf2djvu/Makefile1
-rw-r--r--converters/pdf2djvu/files/patch-gentoo_pdf2djvu-0.9.12-poppler-0.82-4.patch26
-rw-r--r--converters/pdf2djvu/files/patch-pdf-dpi.cc11
-rw-r--r--converters/pdf2djvu/files/patch-pdf-unicode.cc25
-rw-r--r--converters/pdf2djvu/files/patch-pdf-unicode.hh20
5 files changed, 83 insertions, 0 deletions
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index 3ec67ab013cc..2a5ecf662a5e 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pdf2djvu
PORTVERSION= 0.9.13
+PORTREVISION= 1
CATEGORIES= converters
MASTER_SITES= https://github.com/jwilk/${PORTNAME}/releases/download/${PORTVERSION}/
diff --git a/converters/pdf2djvu/files/patch-gentoo_pdf2djvu-0.9.12-poppler-0.82-4.patch b/converters/pdf2djvu/files/patch-gentoo_pdf2djvu-0.9.12-poppler-0.82-4.patch
new file mode 100644
index 000000000000..c3b4c4781b08
--- /dev/null
+++ b/converters/pdf2djvu/files/patch-gentoo_pdf2djvu-0.9.12-poppler-0.82-4.patch
@@ -0,0 +1,26 @@
+This patch doesn't come from Gentoo, but because there are already
+three unrelated patches that touch the same file, I'm following the
+naming convention so that it gets applied in the right order.
+
+Chase constness changes in the poppler API.
+
+--- pdf2djvu.cc.orig 2019-10-27 19:16:30.654895000 +0000
++++ pdf2djvu.cc 2019-10-27 19:16:47.450786000 +0000
+@@ -333,7 +333,7 @@
+ }
+
+ void drawImage(pdf::gfx::State *state, pdf::Object *object, pdf::Stream *stream, int width, int height,
+- pdf::gfx::ImageColorMap *color_map, bool interpolate, int *mask_colors, bool inline_image)
++ pdf::gfx::ImageColorMap *color_map, bool interpolate, const int *mask_colors, bool inline_image)
+ {
+ if (is_foreground_color_map(color_map) || config.no_render)
+ {
+@@ -376,7 +376,7 @@
+ bool interpretType3Chars() { return false; }
+
+ void drawChar(pdf::gfx::State *state, double x, double y, double dx, double dy, double origin_x, double origin_y,
+- CharCode code, int n_bytes, Unicode *unistr, int length)
++ CharCode code, int n_bytes, const Unicode *unistr, int length)
+ {
+ double pox, poy, pdx, pdy, px, py, pw, ph;
+ x -= origin_x; y -= origin_y;
diff --git a/converters/pdf2djvu/files/patch-pdf-dpi.cc b/converters/pdf2djvu/files/patch-pdf-dpi.cc
new file mode 100644
index 000000000000..e1be2fa9e1c0
--- /dev/null
+++ b/converters/pdf2djvu/files/patch-pdf-dpi.cc
@@ -0,0 +1,11 @@
+--- pdf-dpi.cc.orig 2019-10-27 19:10:07 UTC
++++ pdf-dpi.cc
+@@ -34,7 +34,7 @@ class DpiGuessDevice : public pdf::OutputDevice (prote
+ }
+
+ virtual void drawImage(pdf::gfx::State *state, pdf::Object *object, pdf::Stream *stream, int width, int height,
+- pdf::gfx::ImageColorMap *color_map, bool interpolate, int *mask_colors, bool inline_image)
++ pdf::gfx::ImageColorMap *color_map, bool interpolate, const int *mask_colors, bool inline_image)
+ {
+ this->process_image(state, width, height);
+ }
diff --git a/converters/pdf2djvu/files/patch-pdf-unicode.cc b/converters/pdf2djvu/files/patch-pdf-unicode.cc
new file mode 100644
index 000000000000..f02c7ada514f
--- /dev/null
+++ b/converters/pdf2djvu/files/patch-pdf-unicode.cc
@@ -0,0 +1,25 @@
+--- pdf-unicode.cc.orig 2019-10-27 19:19:18.837645000 +0000
++++ pdf-unicode.cc 2019-10-27 19:20:31.405700000 +0000
+@@ -125,11 +125,11 @@
+ * ===================
+ */
+
+-pdf::FullNFKC::FullNFKC(Unicode *unistr, int length)
++pdf::FullNFKC::FullNFKC(const Unicode *unistr, int length)
+ : data(nullptr), length_(0)
+ {
+ assert(length >= 0);
+- this->data = unicodeNormalizeNFKC(unistr, length, &this->length_, nullptr);
++ this->data = unicodeNormalizeNFKC(const_cast<Unicode*>(unistr), length, &this->length_, nullptr);
+ }
+
+ pdf::FullNFKC::~FullNFKC()
+@@ -141,7 +141,7 @@
+ * ======================
+ */
+
+-pdf::MinimalNFKC::MinimalNFKC(Unicode *unistr, int length)
++pdf::MinimalNFKC::MinimalNFKC(const Unicode *unistr, int length)
+ {
+ this->string.append(unistr, length);
+ }
diff --git a/converters/pdf2djvu/files/patch-pdf-unicode.hh b/converters/pdf2djvu/files/patch-pdf-unicode.hh
new file mode 100644
index 000000000000..7e3f74493925
--- /dev/null
+++ b/converters/pdf2djvu/files/patch-pdf-unicode.hh
@@ -0,0 +1,20 @@
+--- pdf-unicode.hh.orig 2019-10-27 19:18:36.768779000 +0000
++++ pdf-unicode.hh 2019-10-27 19:19:00.052652000 +0000
+@@ -58,7 +58,7 @@
+ Unicode* data;
+ int length_;
+ public:
+- explicit FullNFKC(Unicode *, int length);
++ explicit FullNFKC(const Unicode *, int length);
+ ~FullNFKC();
+ int length() const
+ {
+@@ -79,7 +79,7 @@
+ protected:
+ std::basic_string<Unicode> string;
+ public:
+- explicit MinimalNFKC(Unicode *, int length);
++ explicit MinimalNFKC(const Unicode *, int length);
+ int length() const;
+ operator const Unicode*() const;
+ };