aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2021-01-05 18:46:09 +0000
committerKurt Jaeger <pi@FreeBSD.org>2021-01-05 18:46:09 +0000
commit9468168fec8f31748481abdc2112827c7f034638 (patch)
tree3fd6fcb2e651feb2f12445f71718fe5f86920f2a /converters
parentb9f2c0fc9d5cf49585b7a8d06ccca91ca65ad588 (diff)
downloadports-9468168fec8f31748481abdc2112827c7f034638.tar.gz
ports-9468168fec8f31748481abdc2112827c7f034638.zip
converters/wkhtmltopdf: USE_GCC only on i386
Reported by: arrowd
Notes
Notes: svn path=/head/; revision=560419
Diffstat (limited to 'converters')
-rw-r--r--converters/wkhtmltopdf/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index b488d1142310..88aa1f123b87 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png
USES= gmake iconv jpeg perl5 pkgconfig ssl xorg
-USE_GCC= 8
USE_XORG= x11 xext xrender
USE_PERL5= build
USE_LDCONFIG= yes
@@ -55,6 +54,12 @@ CONFIGURE_ARGS= -prefix ${WRKSRC}/build/qt \
MAKE_ARGS= INSTALL_ROOT="${STAGEDIR}${PREFIX}"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+USE_GCC= 8
+.endif
+
pre-patch:
${RMDIR} ${WRKSRC}/qt
${LN} -s ../qt-${WKQT_TAGNAME} ${WRKSRC}/qt
@@ -88,4 +93,4 @@ post-install:
${STAGEDIR}${PREFIX}/bin/wkhtmltopdf \
${STAGEDIR}${PREFIX}/lib/libwkhtmltox.so.${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>