aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
commitaa7a6c429ea62d972467d6755fa7a6f52256b452 (patch)
tree3c451883d3bd4d2ffe401b2b6aee58825505d145 /converters
parentc3b3e6a10d663bc2672cdd4bf46943046d03ecba (diff)
downloadports-aa7a6c429ea62d972467d6755fa7a6f52256b452.tar.gz
ports-aa7a6c429ea62d972467d6755fa7a6f52256b452.zip
Drop python 2.7 support from a few ports
With hat: portmgr
Notes
Notes: svn path=/head/; revision=559531
Diffstat (limited to 'converters')
-rw-r--r--converters/py-bencode.py/Makefile2
-rw-r--r--converters/py-bencoder/Makefile2
-rw-r--r--converters/py-better-bencode/Makefile2
-rw-r--r--converters/py-bsdconv/Makefile2
-rw-r--r--converters/py-rencode/Makefile2
-rw-r--r--converters/py-text-unidecode/Makefile2
-rw-r--r--converters/py-unidecode/Makefile2
-rw-r--r--converters/py-zfec/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/converters/py-bencode.py/Makefile b/converters/py-bencode.py/Makefile
index 6dc7c8acdd86..3a0a227b526f 100644
--- a/converters/py-bencode.py/Makefile
+++ b/converters/py-bencode.py/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.9:devel/py-pbr@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
do-test:
diff --git a/converters/py-bencoder/Makefile b/converters/py-bencoder/Makefile
index df11e57270f3..a60fb602c795 100644
--- a/converters/py-bencoder/Makefile
+++ b/converters/py-bencoder/Makefile
@@ -10,7 +10,7 @@ COMMENT= Simple bencode decoder/encoder library in pure Python
LICENSE= GPLv1
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
diff --git a/converters/py-better-bencode/Makefile b/converters/py-better-bencode/Makefile
index 62aff78eb2b2..1738a9424cea 100644
--- a/converters/py-better-bencode/Makefile
+++ b/converters/py-better-bencode/Makefile
@@ -11,7 +11,7 @@ COMMENT= Fast, standard compliant Bencode serialization
LICENSE= BSD3CLAUSE
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/converters/py-bsdconv/Makefile b/converters/py-bsdconv/Makefile
index 805cbead9df5..a7c4f06a966e 100644
--- a/converters/py-bsdconv/Makefile
+++ b/converters/py-bsdconv/Makefile
@@ -17,7 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= buganini
GH_PROJECT= python-${PORTNAME}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
diff --git a/converters/py-rencode/Makefile b/converters/py-rencode/Makefile
index f51975f40a4c..3ed5eaa5ea9f 100644
--- a/converters/py-rencode/Makefile
+++ b/converters/py-rencode/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
# Make setup.py test target work with setup.py:test_suite
diff --git a/converters/py-text-unidecode/Makefile b/converters/py-text-unidecode/Makefile
index 557f5fca4ca4..32adb5a4e30e 100644
--- a/converters/py-text-unidecode/Makefile
+++ b/converters/py-text-unidecode/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE_GPLv1+ = ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/converters/py-unidecode/Makefile b/converters/py-unidecode/Makefile
index 2b4818fdc2b5..032f96662f61 100644
--- a/converters/py-unidecode/Makefile
+++ b/converters/py-unidecode/Makefile
@@ -14,7 +14,7 @@ COMMENT= ASCII transliterations of Unicode text
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist concurrent
NO_ARCH= yes
diff --git a/converters/py-zfec/Makefile b/converters/py-zfec/Makefile
index 70933fa86293..6cc6d11f1518 100644
--- a/converters/py-zfec/Makefile
+++ b/converters/py-zfec/Makefile
@@ -19,7 +19,7 @@ LICENSE_PERMS_TGGPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argparse>=0.8:devel/py-argparse@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
post-install: